]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Add systemd unit file (Closes: #795621)
[unscd.git] / debian / rules
index b93568908ee54cf7404cd48c5396f9a745679fee..d45f9e4fc6ed610aefb2314a4fd0663d7d35bc18 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 %:
-       dh $@
+       dh $@ --with systemd
 
 override_dh_auto_clean:
        rm -f nscd
@@ -9,6 +9,11 @@ override_dh_auto_clean:
 
 override_dh_auto_build:
        gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       help2man --name 'nscd which does not hang' \
+               --include debian/help2man \
+               --no-info \
+               ./nscd > debian/unscd.man
+       ln -fs unscd.man debian/nscd.man
 
 override_dh_auto_install:
        install -d debian/unscd/usr/sbin/