]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Enable hardening
[unscd.git] / debian / rules
index e5e2a42358b9aec4a26b346c8a2a7f4828642e63..a5b6f487e82d013d9ddc4ff9f11cf38c806cc989 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
 %:
        dh $@ --with systemd
 
@@ -8,7 +10,7 @@ override_dh_auto_clean:
        dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
+       gcc $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
        help2man --name 'nscd which does not hang' \
                --include debian/help2man \
                --no-info \