]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Update upstream source from tag 'upstream/0.53'
[unscd.git] / debian / rules
index b93568908ee54cf7404cd48c5396f9a745679fee..413cdd5f2814ca78f056a586ebcb099fc1fa0fd1 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 %:
-       dh $@
+       dh $@ --with systemd
 
 override_dh_auto_clean:
        rm -f nscd
@@ -9,9 +9,17 @@ override_dh_auto_clean:
 
 override_dh_auto_build:
        gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       help2man --name 'nscd which does not hang' \
+               --include debian/help2man \
+               --no-info \
+               ./nscd > debian/unscd.man
+       ln -fs unscd.man debian/nscd.man
 
 override_dh_auto_install:
        install -d debian/unscd/usr/sbin/
        install -t debian/unscd/usr/sbin/ nscd
        install -d debian/unscd/etc/
        install -m644 -t debian/unscd/etc/ debian/nscd.conf
+
+override_dh_systemd_start:
+       dh_systemd_start --restart-after-upgrade --no-stop-on-upgrade