]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Re-add 'password' plugin to roundcube-plugins
[roundcube.git] / debian / rules
index 721060c9949958bbc55ed0cd84625bf29c6a197b..e3452ee1245d2bf1d9eb2d638cc8fdb3b44d25b0 100755 (executable)
@@ -4,6 +4,11 @@ include /usr/share/cdbs/1/rules/debhelper.mk
 
 DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 
+DEB_DH_INSTALL_ARGS = \
+       --exclude=chgsaslpasswd.c \
+       --exclude=chgvirtualminpasswd.c \
+       --exclude=chpass-wrapper.py
+
 binary-install/roundcube-core::
        # Install config files
        install -m 0640 $(CURDIR)/config/db.inc.php.dist $(CURDIR)/debian/roundcube-core/etc/roundcube/db.inc.php
@@ -28,7 +33,11 @@ binary-install/roundcube-core::
        # Remove useless file
        rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin
        find $(CURDIR)/debian/roundcube-core -name '._*' -print0 | xargs -r0 rm
-       find $(CURDIR)/debian/roundcube-core -name '*.js.src' -print0 | xargs -r0 rm
+       # Convert .js.src back to js
+       for js in $$(find $(CURDIR)/debian/roundcube-core -name '*.js.src' -print); do \
+               yui-compressor --type js "$$js" -o "$${js%.*}" ; \
+               rm "$$js" ; \
+       done
        # Remove files shipped in tinymce package
        rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/tiny_mce
        dh_link -proundcube-core usr/share/tinymce/www usr/share/roundcube/program/js/tiny_mce