]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Re-add 'password' plugin to roundcube-plugins
[roundcube.git] / debian / rules
index 3a7d8578d22208581eed500004b6274cff2b55b6..e3452ee1245d2bf1d9eb2d638cc8fdb3b44d25b0 100755 (executable)
@@ -1,52 +1,70 @@
 #!/usr/bin/make -f
 
 include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 
-# In order to regenerate 'debian/control' :
-#    DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean
-# Then check manually if everything's ok
+DEB_DH_INSTALL_ARGS = \
+       --exclude=chgsaslpasswd.c \
+       --exclude=chgvirtualminpasswd.c \
+       --exclude=chpass-wrapper.py
 
 binary-install/roundcube-core::
-       # Symlink all that is in /usr/share/roundcube to /var/lib/roundcube
-       find debian/roundcube-core/usr/share/roundcube -maxdepth 1 -mindepth 1 | \
-       while read i; do \
-               if [ ! -L "$$i" ]; then \
-                 dh_link -proundcube-core "`echo "$$i" | sed -e s#debian/roundcube-core/##`" \
-                 "`echo "$$i" | sed -e s#debian/roundcube-core/usr/share/roundcube/#var/lib/roundcube/#`"; \
-               fi \
-       done
-       # Install config/db.inc.php.dist
+       # Install config files
        install -m 0640 $(CURDIR)/config/db.inc.php.dist $(CURDIR)/debian/roundcube-core/etc/roundcube/db.inc.php
        install -m 0640 $(CURDIR)/config/main.inc.php.dist $(CURDIR)/debian/roundcube-core/usr/share/roundcube
+       install -m 0640 $(CURDIR)/.htaccess $(CURDIR)/debian/roundcube-core/etc/roundcube/htaccess
+       for c in $(CURDIR)/debian/roundcube-core/etc/roundcube/*.php; do \
+               dh_link -proundcube-core etc/roundcube/$$(basename $$c) var/lib/roundcube/config/$$(basename $$c) ; \
+       done
+       dh_link -proundcube-core etc/roundcube/htaccess var/lib/roundcube/.htaccess
 
        # Database related files
        # Install empty tables and updates for each db type
        install -m 0644 $(CURDIR)/SQL/mysql.initial.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/install/mysql
        install -m 0644 $(CURDIR)/SQL/postgres.initial.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/install/pgsql
        install -m 0644 $(CURDIR)/SQL/sqlite.initial.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/install/sqlite
-       # Database upgrade from latest versions
-       install -m 0644 $(CURDIR)/SQL/postgres.update.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/pgsql/0.1.1-1
-       install -m 0644 $(CURDIR)/SQL/mysql.update.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/mysql/0.1.1-1
-       install -m 0644 $(CURDIR)/SQL/sqlite.update.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/sqlite/0.1.1-1
 
        # Old database upgrades
        cp -r $(CURDIR)/debian/sql/* $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/.
 
        # Some files are executable while not being scripts or binary...
-       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program -type f -print0 | xargs -r0 chmod -x
+       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube -type f -print0 | xargs -r0 chmod -x
        # Remove useless file
-       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin/*.sh
+       rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin
        find $(CURDIR)/debian/roundcube-core -name '._*' -print0 | xargs -r0 rm
+       # Convert .js.src back to js
+       for js in $$(find $(CURDIR)/debian/roundcube-core -name '*.js.src' -print); do \
+               yui-compressor --type js "$$js" -o "$${js%.*}" ; \
+               rm "$$js" ; \
+       done
        # Remove files shipped in tinymce package
        rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/tiny_mce
        dh_link -proundcube-core usr/share/tinymce/www usr/share/roundcube/program/js/tiny_mce
+       # Remove jquery as well
+       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/jquery-1.4.min.js
+       dh_link -proundcube-core usr/share/javascript/jquery/jquery.min.js usr/share/roundcube/program/js/jquery-1.4.min.js
+
+binary-install/roundcube-plugins::
+       # Plugins are in usr/share/roundcube/plugins, for each plugin
+       # if there is config.inc.php.dist, we symlink a config.inc.php
+       # in /etc/roundcube/plugins with some dummy content.
+       for plugin in $(CURDIR)/debian/roundcube-plugins/usr/share/roundcube/plugins/*; do \
+               dh_link -proundcube-plugins usr/share/roundcube/plugins/$${plugin##*/} \
+                       var/lib/roundcube/plugins/$${plugin##*/} ; \
+               if [ ! -f $${plugin}/config.inc.php.dist ]; then continue; fi ; \
+               dh_installdirs -proundcube-plugins etc/roundcube/plugins/$${plugin##*/} ; \
+               (echo "<?php" ; \
+                echo "// Empty configuration for $${plugin##*/}" ; \
+                echo "// See /usr/share/roundcube/plugins/$${plugin##*/}/config.inc.php.dist for instructions") > \
+                       $(CURDIR)/debian/roundcube-plugins/etc/roundcube/plugins/$${plugin##*/}/config.inc.php ; \
+               dh_link -proundcube-plugins etc/roundcube/plugins/$${plugin##*/}/config.inc.php \
+                       usr/share/roundcube/plugins/$${plugin##*/}/config.inc.php ; \
+       done
 
 $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/% :
        install -d $(CURDIR)/debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)
-       install $(CURDIR)/debian/bug.control $(CURDIR)/debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/control
+       install -m 644 $(CURDIR)/debian/bug.control $(CURDIR)/debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/control
 
 clean::
        debconf-updatepo