]> git.donarmstrong.com Git - perltidy.git/blobdiff - debian/rules
use DESTDIR instead of PREFIX
[perltidy.git] / debian / rules
index f6289a72f7d44941403717b0bcbfe5e964f2ab4b..d501387c4c73bbcd1d46f220852a0a55f2004ccb 100755 (executable)
@@ -6,7 +6,6 @@
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
-export DH_COMPAT=3
 
 PACKAGE=$(shell dh_listpackages)
 
@@ -14,17 +13,12 @@ ifndef PERL
 PERL = /usr/bin/perl
 endif
 
-ifndef DESTDIR
-DESTDIR=..
-endif
 TMP     =`pwd`/debian/$(PACKAGE)
 
 build: build-stamp
 build-stamp:
        dh_testdir
 
-       
-       # Add here commands to compile the package.
        $(PERL) Makefile.PL INSTALLDIRS=vendor
        $(MAKE) OPTIMIZE="-O2 -g -Wall"
 
@@ -35,8 +29,10 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       # Add here commands to clean up after the build process.
-       -$(MAKE) realclean
+       if [ -e Makefile ]; then \
+               $(MAKE) distclean;\
+               rm -f Makefile;\
+       fi
 
        dh_clean
 
@@ -46,9 +42,10 @@ install:
        dh_clean -k
        dh_installdirs
 
-       # Add here commands to install the package into debian/tmp.
-       #$(MAKE) install DESTDIR=`pwd`/debian/tmp
-       $(MAKE) install PREFIX=$(TMP)/usr
+       $(MAKE) install DESTDIR=$(TMP)
+       [ ! -d $(TMP)/usr/lib/perl5 ] || \
+               rmdir -p  --ignore-fail-on-non-empty $(TMP)/usr/lib/perl5
+
 
 
 # Build architecture-dependent files here.
@@ -57,32 +54,21 @@ binary-arch: build install
 
 # Build architecture-independent files here.
 binary-indep: build install
-#      dh_testversion
        dh_testdir
        dh_testroot
        dh_installdocs BUGS TODO README examples/README docs/README
-       dh_installexamples
+       dh_installexamples examples/*
        dh_installmenu
-#      dh_installemacsen
-#      dh_installinit
        dh_installcron
        dh_installman
-#      dh_undocumented
        dh_installchangelogs CHANGES
-       dh_link
-       dh_strip
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
        dh_perl 
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
-       dh_builddeb --destdir=$(DESTDIR)
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+       dh_builddeb
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary