]> git.donarmstrong.com Git - perltidy.git/blobdiff - debian/rules
* Switch to debhelper auto rules
[perltidy.git] / debian / rules
index d501387c4c73bbcd1d46f220852a0a55f2004ccb..945a74d4f412cefdaaeccb7ff2c4ee57a932269e 100755 (executable)
@@ -1,74 +1,7 @@
 #!/usr/bin/make -f
-#-*- makefile -*-
-# Made with the aid of dh_make, by Craig Small
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-# Some lines taken from debmake, by Christoph Lameter.
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+%:
+       dh $@
 
-PACKAGE=$(shell dh_listpackages)
-
-ifndef PERL
-PERL = /usr/bin/perl
-endif
-
-TMP     =`pwd`/debian/$(PACKAGE)
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       $(PERL) Makefile.PL INSTALLDIRS=vendor
-       $(MAKE) OPTIMIZE="-O2 -g -Wall"
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       if [ -e Makefile ]; then \
-               $(MAKE) distclean;\
-               rm -f Makefile;\
-       fi
-
-       dh_clean
-
-install: 
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) install DESTDIR=$(TMP)
-       [ ! -d $(TMP)/usr/lib/perl5 ] || \
-               rmdir -p  --ignore-fail-on-non-empty $(TMP)/usr/lib/perl5
-
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs BUGS TODO README examples/README docs/README
-       dh_installexamples examples/*
-       dh_installmenu
-       dh_installcron
-       dh_installman
-       dh_installchangelogs CHANGES
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_perl 
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+override_dh_installexamples: 
+       dh_installexamples examples/*
\ No newline at end of file