]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Prepare deploying on new server
authorMichael Hanke <michael.hanke@gmail.com>
Wed, 2 Jan 2013 09:55:44 +0000 (10:55 +0100)
committerMichael Hanke <michael.hanke@gmail.com>
Wed, 2 Jan 2013 09:55:44 +0000 (10:55 +0100)
Makefile

index f3d0e1dea76718829370338b53c5835fbcaf5f5d..d0cf9896708f8bbe60677803e8ec947bd825a2cf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
-#WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
-WWW_UPLOAD_URI = ../www
+WWW_UPLOAD_URI = neurodebian@neurodebian.ovgu.de:/home/neurodebian/www
+#WWW_UPLOAD_URI = ../www
 WWW_DIR = build/html/
 
 WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
@@ -23,6 +23,7 @@ html: pics source
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       ln -fs /usr/share/javascript build/html/
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
        cp -r build/src/lists $(WWW_DIR)/
        cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
@@ -52,6 +53,8 @@ source-stamp:
 
 
 updatedb:
+       $(BIGMESS) cachefiles
+       $(BIGMESS) updatedb
 
 upload-website: html
        rsync -rvzlhp --delete \