]> git.donarmstrong.com Git - neurodebian.git/commitdiff
ENH: mirmon and refresh (the one to be called hourly from cron) Makefile rules
authorYaroslav Halchenko <debian@onerussian.com>
Fri, 8 Jun 2012 17:19:58 +0000 (13:19 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Fri, 8 Jun 2012 17:19:58 +0000 (13:19 -0400)
Makefile

index 34adc54d81ca074b34ff39f086714db3522165cf..cf3899471a2864bdf335316887c9c980c5005fd0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,10 @@
 WWW_UPLOAD_URI = ../www
 WWW_DIR = build/html/
 
-all: updatedb upload-website
+# Lentghy one due to updatedb
+all: updatedb upload-website mirmon
+# Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
+refresh: upload-website-stamp mirmon
 
 
 pics:
@@ -71,5 +74,9 @@ upload-website: html
 upload-website-stamp: .git/index
        $(MAKE) upload-website
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html
+mirmon:
+       # update and generate mirrors report
+       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon