]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Add new logo svg and general artwork infrastructure.
authorMichael Hanke <michael.hanke@gmail.com>
Mon, 11 May 2009 08:48:32 +0000 (10:48 +0200)
committerMichael Hanke <michael.hanke@gmail.com>
Mon, 11 May 2009 08:48:32 +0000 (10:48 +0200)
Makefile
artwork/.gitignore [new file with mode: 0644]
artwork/Makefile [new file with mode: 0644]
artwork/logo.svg [new file with mode: 0644]
artwork/logo.svgtune [new file with mode: 0644]
sphinx/conf.py

index a65b6d16e54c97b9b3553e867036032c8fec3677..fd125e1d1c34726cec7b2888f36021a6db2faac4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4,16 +4,22 @@ WWW_DIR = build/html
 
 
 prep:
-       mkdir -p build/src
-       cp -r sphinx/* build/src
+       if [ ! -d build ]; then mkdir build; fi
+       rsync -rvlhp sphinx/ build/src
 
 
-html: prep source
+pics:
+       $(MAKE) -C artwork
+
+
+html: pics prep source
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
 
 
 clean:
        -rm -rf build
+       $(MAKE) -C artwork clean
+
 
 
 distclean: clean
diff --git a/artwork/.gitignore b/artwork/.gitignore
new file mode 100644 (file)
index 0000000..07ff1af
--- /dev/null
@@ -0,0 +1,3 @@
+logo_tuned
+logo_tuned/label_w200.png
+logo_tuned/fmri_w200.png
diff --git a/artwork/Makefile b/artwork/Makefile
new file mode 100644 (file)
index 0000000..9f88e45
--- /dev/null
@@ -0,0 +1,37 @@
+all:: pics
+
+SVGIS=$(shell /bin/ls *.svgtune | sed -e 's/.svgtune/_tuned/g')
+
+pics: $(SVGIS)
+
+clean::
+       for p in *.svg; do rm -f $${p%*.svg}.{pdf,eps,png}; done
+       rm -rf *_tuned
+
+ignore-%:
+       @grep -q "^$*$$" .gitignore || { \
+         echo "$*" >> .gitignore; echo "Ignore $@"; }
+
+%_tuned: %.svgtune ignore-%_tuned
+       @echo "Splitting SVG using $<"
+       @svgtune $<
+
+%.pdf: %.svg ignore-%.pdf
+       @echo "Rendering $@"
+       @inkscape -z -f "$<" -A "$@"
+
+%.png: %.svg ignore-%.png
+       @echo "Rendering $@"
+       @inkscape -z -f "$<" -e "$@" -d 150
+
+%_w200.png: %.svg ignore-%_w200.png
+       @echo "Rendering $@"
+       @inkscape -z -f "$<" -e "$@" -w 200
+
+
+# Some enforced conversions to overcome problems with transparency issues
+# in PDFs
+all:: logo_tuned/fmri_w200.png
+
+
+.PHONY: all pics
diff --git a/artwork/logo.svg b/artwork/logo.svg
new file mode 100644 (file)
index 0000000..2bf2b90
--- /dev/null
@@ -0,0 +1,314 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+<svg
+   xmlns:i="http://ns.adobe.com/AdobeIllustrator/10.0/"
+   xmlns:dc="http://purl.org/dc/elements/1.1/"
+   xmlns:cc="http://creativecommons.org/ns#"
+   xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+   xmlns:svg="http://www.w3.org/2000/svg"
+   xmlns="http://www.w3.org/2000/svg"
+   xmlns:xlink="http://www.w3.org/1999/xlink"
+   xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+   xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+   width="570.47241"
+   height="402.87399"
+   id="svg2"
+   sodipodi:version="0.32"
+   inkscape:version="0.46"
+   sodipodi:docname="logo.svg"
+   inkscape:output_extension="org.inkscape.output.svg.inkscape"
+   version="1.0"
+   inkscape:export-filename="/home/michael/hacking/debneuro.png"
+   inkscape:export-xdpi="32.84"
+   inkscape:export-ydpi="32.84">
+  <defs
+     id="defs4" />
+  <sodipodi:namedview
+     id="base"
+     pagecolor="#ffffff"
+     bordercolor="#666666"
+     borderopacity="1.0"
+     inkscape:pageopacity="0.0"
+     inkscape:pageshadow="2"
+     inkscape:zoom="1.0356496"
+     inkscape:cx="284.94972"
+     inkscape:cy="202.57164"
+     inkscape:document-units="px"
+     inkscape:current-layer="layer3"
+     showgrid="false"
+     inkscape:window-width="807"
+     inkscape:window-height="1029"
+     inkscape:window-x="61"
+     inkscape:window-y="19"
+     units="cm"
+     showguides="false"
+     inkscape:guide-bbox="true"
+     objecttolerance="12"
+     gridtolerance="11"
+     guidetolerance="10"
+     inkscape:object-nodes="true"
+     inkscape:snap-bbox="true"
+     inkscape:bbox-paths="false"
+     inkscape:bbox-nodes="false"
+     inkscape:object-paths="true"
+     inkscape:snap-nodes="true">
+    <sodipodi:guide
+       orientation="1,0"
+       position="11.388664,159.4413"
+       id="guide2475" />
+    <sodipodi:guide
+       orientation="0,1"
+       position="311.76468,391.48533"
+       id="guide2477" />
+    <sodipodi:guide
+       orientation="1,0"
+       position="559.46813,264.78644"
+       id="guide2479" />
+    <sodipodi:guide
+       orientation="0,1"
+       position="371.55517,9.9650811"
+       id="guide2481" />
+  </sodipodi:namedview>
+  <metadata
+     id="metadata7">
+    <rdf:RDF>
+      <cc:Work
+         rdf:about="">
+        <dc:format>image/svg+xml</dc:format>
+        <dc:type
+           rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+      </cc:Work>
+    </rdf:RDF>
+  </metadata>
+  <g
+     inkscape:groupmode="layer"
+     id="layer3"
+     inkscape:label="fMRI"
+     style="display:inline"
+     sodipodi:insensitive="true">
+    <rect
+       style="opacity:1;fill:#000000;fill-opacity:0.05882353;fill-rule:nonzero;stroke:none;stroke-width:0.21259843;stroke-linecap:butt;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1"
+       id="rect3255"
+       width="548.07941"
+       height="31.793367"
+       x="11.388664"
+       y="365.11572"
+       rx="0.70528102"
+       ry="0.89940047" />
+    <rect
+       ry="0.89940047"
+       rx="0.70528102"
+       y="333.32236"
+       x="11.388723"
+       height="31.793367"
+       width="548.07941"
+       id="rect3257"
+       style="opacity:1;fill:#000000;fill-opacity:0.21568627;fill-rule:nonzero;stroke:none;stroke-width:0.21259843;stroke-linecap:butt;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#rect3255"
+       id="use3261"
+       transform="translate(0,-63.586745)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#rect3257"
+       id="use3263"
+       transform="translate(0,-63.58674)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#use3261"
+       id="use3265"
+       transform="translate(0,-63.58674)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#use3263"
+       id="use3267"
+       transform="translate(0,-63.58674)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#use3265"
+       id="use3269"
+       transform="translate(0,-63.586752)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#use3267"
+       id="use3271"
+       transform="translate(0,-63.586734)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#use3269"
+       id="use3273"
+       transform="translate(0,-63.586729)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#use3271"
+       id="use3275"
+       transform="translate(0,-63.586729)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#use3273"
+       id="use3277"
+       transform="translate(0,-63.586733)"
+       width="570.47241"
+       height="402.87399" />
+    <use
+       x="0"
+       y="0"
+       xlink:href="#use3275"
+       id="use3279"
+       transform="translate(0,-63.586737)"
+       width="570.47241"
+       height="402.87399" />
+  </g>
+  <g
+     inkscape:groupmode="layer"
+     id="layer2"
+     inkscape:label="Brain"
+     transform="translate(-95.38553,-296.81011)"
+     sodipodi:insensitive="true">
+    <g
+       id="g2725"
+       transform="translate(36,50)"
+       inkscape:export-xdpi="2.8800001"
+       inkscape:export-ydpi="2.8800001">
+      <path
+         id="path2596"
+         d="M 215.74201,479.87605 L 209.94948,480.24108 C 204.32457,487.27856 197.83149,493.40658 194.13479,501.44639 C 202.09923,494.23775 204.97436,489.70362 215.74201,479.87605"
+         i:knockout="Off"
+         style="fill:#d70751;display:inline" />
+      <path
+         id="path2598"
+         d="M 219.47886,491.93252 C 221.77096,488.39287 224.97291,485.81339 228.09762,483.02955 C 222.20515,486.46499 217.69167,491.47749 213.00954,496.25952 L 219.47886,491.93252"
+         i:knockout="Off"
+         style="fill:#d70751;display:inline" />
+      <path
+         sodipodi:nodetypes="ccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccc"
+         id="path2490"
+         d="M 352.14351,592.05711 C 338.99951,595.85211 305.21651,609.81911 292.59651,609.39811 L 286.90651,604.31911 C 273.84551,602.30511 279.90651,606.62911 269.66051,605.41311 C 258.83951,599.82611 236.07851,588.68611 232.71651,584.12011 C 231.50351,580.46611 238.69551,585.28011 240.93551,585.57811 C 228.91651,577.48511 231.46051,592.56411 220.75751,578.23211 L 221.81051,577.47011 C 189.21846,554.67271 218.12487,500.89218 274.40651,479.95111 C 270.56251,480.48511 271.21151,479.48711 269.41951,479.01411 C 296.14399,477.70006 287.5842,473.81874 312.91079,467.15987 C 325.30651,463.06028 322.01769,459.00916 325.87166,457.83952 C 311.45959,457.86234 307.17559,456.66472 288.28651,463.37211 C 232.37151,470.87911 215.54851,494.46411 199.02551,531.33211 C 196.94251,536.98911 195.14951,533.76111 192.50351,535.12011 C 194.46051,523.77211 199.54751,512.54611 207.09151,502.45311 C 201.60651,508.18811 196.42551,514.18311 193.13851,521.07011 C 193.53051,510.73011 212.28551,492.29111 211.91851,488.40211 C 183.30251,513.31511 175.13051,569.30711 197.32751,591.91111 C 192.48851,580.07011 187.25051,564.80311 188.32451,549.85411 C 189.74651,543.31011 194.14351,533.82011 195.97451,534.85311 C 192.99851,574.14711 197.93751,583.63911 238.06851,606.77711 C 248.07651,612.72111 263.38651,618.09511 264.43551,620.50911 C 256.49151,618.49611 261.48251,621.95011 254.62251,620.59611 C 272.26751,624.54811 259.46251,615.68611 283.16551,622.07111 L 277.79851,628.01811 C 289.58051,623.30711 335.75951,617.94811 354.74151,611.51811 C 361.89951,613.31711 329.64451,628.84611 314.65651,628.82111 C 331.63751,629.82811 352.79451,613.61811 365.81151,611.67211 C 362.06951,614.09111 358.22951,617.02111 354.09551,619.06611 C 367.66851,612.14311 400.04251,608.01811 409.17451,607.44311 C 409.43051,605.65111 400.90451,604.19011 418.00451,599.00511 C 425.59551,597.20211 422.59851,599.77111 424.68651,599.93111 C 425.09251,598.47511 429.70451,593.73511 440.08851,588.93011 C 443.21651,589.69511 434.71151,594.49611 435.03751,596.55311 C 443.40251,593.04911 449.35151,589.17011 456.09151,587.35511 C 468.27851,577.99911 453.45751,585.80911 459.80851,579.12811 C 480.24751,567.27011 466.88451,582.85011 477.43551,580.99611 C 464.83151,594.28311 442.02251,605.83011 432.66751,610.85711 C 444.47551,605.83711 455.49051,599.78211 465.86951,593.16211 C 465.46851,596.33711 489.89751,582.11311 474.91651,594.85411 C 509.98651,576.40511 584.55307,559.27412 591.82307,528.68512 C 589.47407,532.78912 586.53607,537.97312 585.32007,536.69712 C 589.87407,521.23712 591.43507,523.35312 594.67607,520.48012 C 596.00607,508.50912 590.16007,509.21812 588.03407,502.06212 C 593.49307,478.72112 583.59151,468.62811 584.87351,448.09911 L 580.48851,450.13311 C 580.97451,435.46911 572.90851,435.11711 569.70751,420.22011 C 570.20151,419.14111 574.31851,424.08511 576.72151,428.41011 C 570.05951,416.04311 575.32751,415.36011 567.20751,403.66711 C 570.91651,406.11011 573.82351,408.96511 577.21651,411.71611 C 572.67651,401.40911 560.91351,388.48611 568.46451,391.47711 C 553.19651,376.66011 529.47151,349.47911 504.26951,337.24711 L 508.34651,335.62611 C 494.35551,330.64311 462.68651,309.99211 447.44551,311.58111 L 446.11351,309.63311 C 436.44651,307.65411 426.20251,307.37711 416.60551,306.29411 C 403.88851,303.71811 409.63551,299.54611 408.21451,300.73611 C 379.17751,296.68611 356.07351,296.87111 337.03651,296.81011 C 330.70387,302.6502 302.77451,305.60611 280.32551,312.63011 C 165.39451,336.11311 91.945259,402.71327 95.509705,507.44932 C 99.51648,522.60751 120.01011,534.45206 131.95656,544.24821 C 121.48126,528.55194 127.89675,535.14685 115.85953,521.03843 C 108.74478,510.21616 110.15386,505.60616 115.91386,494.79616 L 110.00786,499.99616 C 111.03686,481.41516 115.24286,488.01216 115.47086,473.04616 C 117.77786,473.77616 120.08486,474.50716 122.39186,475.23816 C 120.92786,469.67016 118.10886,458.05416 123.00986,454.13316 L 120.58486,448.24916 C 128.49886,438.43516 130.70286,426.69516 136.67486,425.48416 L 131.89986,424.59916 C 135.56786,421.28916 161.81286,388.27416 158.18786,402.86216 C 159.87086,399.89516 160.34786,396.39816 166.39786,391.20116 L 170.77686,392.86916 C 177.83786,384.50816 187.83686,376.43016 191.91586,375.81716 C 187.91186,380.34216 187.74586,382.81716 187.65586,385.25216 C 227.09886,358.61716 184.33986,368.55216 223.44786,346.04016 C 223.81686,346.83116 224.18486,347.62216 224.55386,348.41316 C 227.24486,345.69516 230.45986,343.63116 233.49186,341.22516 C 237.81086,340.51516 242.12886,339.80416 246.44786,339.09316 C 257.55986,324.31716 314.34951,328.53311 341.79951,323.28611 C 353.11851,321.59511 367.65551,326.69111 388.10851,328.16811 L 387.52651,324.24911 C 404.88351,327.61811 461.59751,349.84111 464.90851,365.97711 C 478.87751,370.64711 464.41251,364.46711 466.70951,362.27411 C 493.04251,373.64211 488.93451,380.36411 496.62451,390.59711 C 509.45751,400.47111 489.58051,381.10811 498.19851,385.14511 C 512.01651,404.35811 517.89151,396.23811 530.87551,422.57711 C 529.97051,425.93611 525.49051,416.69411 522.11651,414.94711 C 538.46051,429.71811 558.61771,476.79131 554.00171,504.59131 C 548.44171,536.87631 462.42951,557.54811 419.12251,569.93011 L 419.17951,571.47411 C 401.52151,575.17611 342.46551,603.25011 322.13951,602.81011"
+         style="fill:#d70751" />
+      <path
+         id="path2584"
+         d="M 409.46096,437.09419 C 416.72765,430.01946 411.79834,442.12904 403.87887,452.93801 C 399.25679,453.50921 394.88904,453.80672 390.80922,453.9124 C 398.05684,449.51587 404.02284,443.617 409.46096,437.09419"
+         i:knockout="Off"
+         style="fill:#d70751;display:inline" />
+      <path
+         id="path2586"
+         d="M 382.16943,461.30713 C 372.47203,464.81365 362.48663,466.50571 352.99096,465.37887 C 359.82547,465.93431 366.40923,464.05728 373.26159,462.44877 C 389.99652,447.55171 366.95151,458.7594 359.49986,458.45659 C 389.82682,446.01183 375.06952,460.03198 382.16943,461.30713"
+         i:knockout="Off"
+         style="fill:#d70751;display:inline" />
+      <path
+         id="path2588"
+         d="M 342.63854,465.30284 C 324.35918,466.32061 330.19947,461.56358 337.17585,460.02431 C 338.14433,461.92306 350.01776,463.56462 342.63854,465.30284"
+         i:knockout="Off"
+         style="fill:#d70751;display:inline" />
+      <path
+         id="path2604"
+         d="M 530.20382,347.62316 C 553.68058,362.52713 550.27618,384.64471 548.85328,356.46097 C 530.84327,328.09514 539.21371,354.72322 530.20382,347.62316"
+         i:knockout="Off"
+         style="fill:#d70751;display:inline" />
+      <path
+         id="path2606"
+         d="M 416.40084,297.82351 C 437.70433,304.77643 450.48346,306.02172 462.83267,308.67539 C 438.31215,289.5067 433.07894,299.83971 416.40084,297.82351"
+         i:knockout="Off"
+         style="fill:#d70751;display:inline" />
+    </g>
+  </g>
+  <g
+     inkscape:groupmode="layer"
+     id="layer4"
+     inkscape:label="Debian"
+     style="display:inline"
+     sodipodi:insensitive="true">
+    <g
+       id="g3504"
+       transform="matrix(1.0864996,-0.3715245,0.3715245,1.0864996,-437.39782,-27.53813)">
+      <path
+         i:knockout="Off"
+         d="M 586.7443,568.51986 C 586.6993,568.56686 586.6993,576.02586 586.6063,577.97286 C 586.5143,579.54686 586.3743,582.92986 583.0383,582.92986 C 579.6093,582.92986 578.7753,578.99086 578.4973,577.27786 C 578.1733,575.37786 578.1733,573.80086 578.1733,573.10786 C 578.1733,570.88286 578.3123,564.67186 583.5483,564.67186 C 585.1243,564.67186 586.0043,565.13686 586.6993,565.50586 L 586.7443,568.51986 z M 573.3073,573.98886 C 573.3073,587.05486 580.2583,587.05486 581.2773,587.05486 C 584.1503,587.05486 586.0043,585.47886 586.7913,582.74586 L 586.8843,586.86886 C 587.7653,586.82186 588.6453,586.72986 590.0813,586.72986 C 590.5913,586.72986 591.0073,586.72986 591.3793,586.77686 C 591.7503,586.77686 592.1203,586.82186 592.5373,586.86886 C 591.7963,585.38686 591.2403,582.05086 591.2403,574.81986 C 591.2403,567.77686 591.2403,555.86886 591.8423,552.25386 C 590.1753,553.04286 588.7373,553.55286 585.5863,553.82986 C 586.8373,555.17386 586.8373,555.86886 586.8373,561.98386 C 585.9583,561.70686 584.8453,561.38186 582.9453,561.38186 C 574.6513,561.38286 573.3073,568.61186 573.3073,573.98886"
+         id="path3402" />
+      <path
+         i:knockout="Off"
+         d="M 598.4373,571.62286 C 598.4843,567.77686 599.2723,564.34786 602.5613,564.34786 C 606.1763,564.34786 606.4523,568.33186 606.3603,571.62286 L 598.4373,571.62286 z M 610.9473,572.08786 C 610.9473,566.66586 609.8823,561.33586 603.0243,561.33586 C 593.5723,561.33586 593.5723,571.81086 593.5723,574.03286 C 593.5723,583.43886 597.7883,587.14586 604.8783,587.14586 C 608.0273,587.14586 609.5583,586.68486 610.3923,586.45086 C 610.3463,584.78286 610.5773,583.71686 610.8573,582.28086 C 609.8823,582.88486 608.6313,583.67186 605.8513,583.67186 C 598.6223,583.67186 598.5293,577.08986 598.5293,574.81986 L 610.8573,574.81986 L 610.9473,572.08786"
+         id="path3404" />
+      <path
+         i:knockout="Off"
+         d="M 626.0223,574.07986 C 626.0223,578.38886 625.2353,584.18186 619.8603,584.18186 C 619.1183,584.18186 618.1923,584.04086 617.5903,583.90286 C 617.4973,582.23486 617.4973,579.36186 617.4973,576.02586 C 617.4973,572.03986 617.9133,569.95786 618.2393,568.93586 C 619.2113,565.64686 621.3893,565.60186 621.8053,565.60186 C 625.3273,565.60186 626.0223,570.46686 626.0223,574.07986 z M 612.7243,579.13086 C 612.7243,582.56086 612.7243,584.50586 612.1683,585.98786 C 614.0683,586.72986 616.4303,587.14586 619.2583,587.14586 C 621.0653,587.14586 626.3013,587.14586 629.1273,581.35486 C 630.4713,578.66686 630.9343,575.05186 630.9343,572.31786 C 630.9343,570.64986 630.7483,566.98986 629.4053,564.67186 C 628.1093,562.49586 626.0233,561.38286 623.8003,561.38286 C 619.3513,561.38286 618.0543,565.08986 617.3603,566.98986 C 617.3603,564.62686 617.4053,556.37886 617.7753,552.16186 C 614.7643,553.55286 612.9093,553.78286 610.9183,553.96886 C 612.7253,554.70886 612.7253,557.76986 612.7253,567.73286 L 612.7253,579.13086"
+         id="path3406" />
+      <path
+         i:knockout="Off"
+         d="M 639.8423,586.86886 C 638.9143,586.72986 638.2643,586.63686 636.9203,586.63686 C 635.4403,586.63686 634.4183,586.73086 633.3543,586.86886 C 633.8173,585.98786 634.0023,585.56986 634.1413,582.55986 C 634.3273,578.43486 634.3733,567.40586 634.0493,565.08886 C 633.8173,563.32686 633.4013,563.04986 632.7523,562.58686 C 636.5513,562.21586 637.6173,561.93886 639.3773,561.10486 C 639.0083,563.14186 638.9593,564.16386 638.9593,567.26686 C 638.8683,583.25586 638.8213,584.96886 639.8423,586.86886"
+         id="path3408" />
+      <path
+         i:knockout="Off"
+         d="M 654.6803,573.75386 C 654.5883,576.67386 654.5413,578.71286 653.7523,580.33386 C 652.7793,582.41986 651.1583,583.02186 649.9533,583.02186 C 647.1703,583.02186 646.5703,580.70586 646.5703,578.43586 C 646.5703,574.08086 650.4633,573.75386 652.2223,573.75386 L 654.6803,573.75386 z M 641.9363,579.45486 C 641.9363,582.37486 642.8173,585.29286 645.4133,586.54486 C 646.5713,587.05486 647.7293,587.05486 648.1013,587.05486 C 652.3653,587.05486 653.8003,583.90286 654.6813,581.95686 C 654.6343,583.99586 654.6813,585.24586 654.8203,586.86886 C 655.6543,586.82186 656.4883,586.72986 657.8793,586.72986 C 658.6663,586.72986 659.4083,586.82186 660.1953,586.86886 C 659.6853,586.08186 659.4083,585.61686 659.2673,583.80986 C 659.1753,582.04986 659.1753,580.28886 659.1753,577.83286 L 659.2223,568.37986 C 659.2223,564.85686 658.2943,561.38186 651.3433,561.38186 C 646.7573,561.38186 644.0703,562.77286 642.7263,563.46786 C 643.2833,564.48786 643.7463,565.36586 644.1623,567.36086 C 645.9713,565.78486 648.3343,564.95086 650.7423,564.95086 C 654.5903,564.95086 654.5903,567.49986 654.5903,571.11286 C 653.7093,571.06786 652.9673,570.97586 651.7153,570.97586 C 645.8283,570.97686 641.9363,573.24386 641.9363,579.45486"
+         id="path3410" />
+      <path
+         i:knockout="Off"
+         d="M 681.3703,582.28186 C 681.4173,583.85786 681.4173,585.52586 682.0653,586.86986 C 681.0443,586.77786 680.4423,586.63786 678.5443,586.63786 C 677.4313,586.63786 676.8293,586.73186 675.9483,586.86986 C 676.1323,586.26786 676.2273,586.03586 676.3193,585.24686 C 676.4583,584.18286 676.5513,580.61386 676.5513,579.36186 L 676.5513,574.35786 C 676.5513,572.17986 676.5513,569.02786 676.4103,567.91686 C 676.3183,567.12986 676.0883,564.99886 673.3983,564.99886 C 670.7573,564.99886 669.8773,566.94386 669.5523,568.51986 C 669.1833,570.14086 669.1833,571.90286 669.1833,578.75986 C 669.2283,584.69186 669.2283,585.24586 669.6913,586.86886 C 668.9043,586.77686 667.9313,586.68486 666.5413,586.68486 C 665.4283,586.68486 664.6873,586.72986 663.7623,586.86886 C 664.0863,586.12686 664.2723,585.75586 664.3643,583.16186 C 664.4583,580.61286 664.6433,568.10086 664.2233,565.13686 C 663.9933,563.32786 663.5283,562.91186 663.0203,562.44886 C 666.7743,562.26286 667.9773,561.65986 669.1373,561.05986 L 669.1373,565.96986 C 669.6923,564.53186 670.8503,561.33486 675.4853,561.33486 C 681.2783,561.33486 681.3233,565.55186 681.3703,568.33086 L 681.3703,582.28186"
+         id="path3412" />
+      <path
+         style="fill:#d70751"
+         i:knockout="Off"
+         d="M 640.2333,554.54686 L 636.3953,558.38286 L 632.5593,554.54686 L 636.3953,550.71086 L 640.2333,554.54686"
+         id="path3414" />
+    </g>
+  </g>
+  <g
+     inkscape:groupmode="layer"
+     id="layer5"
+     inkscape:label="EEG"
+     sodipodi:insensitive="true"
+     style="display:inline">
+    <path
+       id="path3525"
+       style="fill:none;fill-rule:evenodd;stroke:#000000;stroke-width:2.65748024;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+       d="M 144.4234,78.975388 C 266.02989,-77.854986 517.89394,31.598913 544.30928,206.19246 M 235.52123,47.182022 C 346.11429,-52.460919 514.87505,31.449949 544.30928,206.19246 M 332.17381,47.182022 C 422.50525,-23.52659 511.10143,30.082837 544.30928,206.19246 M 429.58867,66.478997 C 483.92989,13.647221 520.15812,42.230553 544.30928,206.19246"
+       sodipodi:nodetypes="cccccccc" />
+    <path
+       style="opacity:1;fill:#ffffff;fill-opacity:1;fill-rule:nonzero;stroke:#000000;stroke-width:3.77901149;stroke-linecap:butt;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1"
+       d="M 139.95489,62.706883 C 134.10022,65.277871 132.85694,75.42525 136.97971,85.690035 L 127.67995,89.773886 C 126.05578,90.487114 125.32363,92.365717 126.03687,93.989892 L 126.91796,95.996323 C 127.63119,97.620493 129.5098,98.35263 131.13397,97.6394 L 169.75204,80.680866 C 171.37621,79.967637 172.10835,78.089033 171.39512,76.464861 L 170.51403,74.45843 C 169.8008,72.83426 167.92219,72.102123 166.29802,72.815352 L 158.89788,76.06501 C 154.12984,66.083576 145.80956,60.135897 139.95489,62.706883 z"
+       id="path3514" />
+    <path
+       id="path3519"
+       d="M 232.97728,34.179007 C 226.72252,35.507566 223.44459,45.191068 225.39707,56.079174 L 215.46179,58.189507 C 213.72662,58.558067 212.62825,60.248858 212.99682,61.984027 L 213.45213,64.127572 C 213.82069,65.862734 215.51149,66.961093 217.24665,66.592531 L 258.50379,57.829205 C 260.23895,57.460644 261.33731,55.76985 260.96875,54.034686 L 260.51345,51.891141 C 260.14488,50.155979 258.45408,49.05762 256.71892,49.426181 L 248.81307,51.105442 C 246.17123,40.363753 239.23205,32.850451 232.97728,34.179007 z"
+       style="opacity:1;fill:#ffffff;fill-opacity:1;fill-rule:nonzero;stroke:#000000;stroke-width:3.77901149;stroke-linecap:butt;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1" />
+    <path
+       style="opacity:1;fill:#ffffff;fill-opacity:1;fill-rule:nonzero;stroke:#000000;stroke-width:3.77901149;stroke-linecap:butt;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1"
+       d="M 333.85888,26.48456 C 327.48678,25.952166 321.55458,34.278275 320.28289,45.266715 L 310.16122,44.421046 C 308.3935,44.273348 306.85405,45.575375 306.70636,47.343098 L 306.52391,49.526857 C 306.37621,51.29457 307.67825,52.834015 309.44596,52.981708 L 351.47708,56.493448 C 353.2448,56.641142 354.78424,55.339108 354.93194,53.571393 L 355.1144,51.387637 C 355.26208,49.619921 353.96004,48.080476 352.19233,47.932782 L 344.13817,47.259848 C 344.70757,36.212723 340.23099,27.016959 333.85888,26.48456 z"
+       id="path3521" />
+    <path
+       id="path3523"
+       d="M 436.78602,52.620877 C 431.04287,49.809599 422.49086,55.411221 417.31349,65.18659 L 408.19085,60.72106 C 406.59762,59.941165 404.69029,60.594853 403.91041,62.188098 L 402.94697,64.156314 C 402.16707,65.749546 402.82077,67.656867 404.41401,68.436755 L 442.29652,86.980282 C 443.88976,87.760174 445.79708,87.106476 446.57697,85.513242 L 447.54042,83.545032 C 448.3203,81.95179 447.66659,80.044469 446.07336,79.26458 L 438.81417,75.711199 C 443.35858,65.625983 442.52918,55.432163 436.78602,52.620877 z"
+       style="opacity:1;fill:#ffffff;fill-opacity:1;fill-rule:nonzero;stroke:#000000;stroke-width:3.77901149;stroke-linecap:butt;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1" />
+    <path
+       style="fill:none;fill-rule:evenodd;stroke:#000000;stroke-width:2.65748024;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+       d="M 544.30928,206.19246 C 555.56938,278.53581 567.46939,345.83027 514.92619,365.23576 L 419.15824,397.15841"
+       id="path3538"
+       sodipodi:nodetypes="ccc" />
+  </g>
+</svg>
diff --git a/artwork/logo.svgtune b/artwork/logo.svgtune
new file mode 100644 (file)
index 0000000..020a518
--- /dev/null
@@ -0,0 +1,16 @@
+%file logo.svg
+
+# Disable ALL layers
+layers style=display:none
+
+layer label=Brain style=display:inline
+%save plain
+
+layer label=Debian style=display:inline
+%save label
+
+layer label=fMRI style=display:inline
+%save fmri
+
+layer label=EEG style=display:inline
+%save full
index 16125ab1087798935f432898dc1ffe52ec4df92a..7f5eb46b130430be1d9b4e9a49653a4f4ac0217f 100644 (file)
@@ -21,6 +21,21 @@ import sys, os
 # absolute, like shown here.
 #sys.path.append(os.path.abspath('.'))
 
+def artworkdir():
+    """Look into every parent dir for 'artwork' and return its relative path."""
+    level = 0
+    while True:
+        target = os.path.join(*([os.path.pardir] * level + ['artwork']))
+        if os.path.isdir(target):
+            return target
+        else:
+            level += 1
+        # if there is no way up
+        if os.path.abspath(os.path.join(*([os.path.pardir] * level))) == \
+           os.path.abspath(os.path.join(*([os.path.pardir] * (level + 1)))):
+            raise(ValueError, "Cannot find 'artwork'.")
+
+
 # General configuration
 # ---------------------
 
@@ -105,7 +120,7 @@ html_title = project
 
 # The name of an image file (relative to this directory) to place at the top
 # of the sidebar.
-html_logo = 'pics/neurodebian.png'
+html_logo = os.path.join(artworkdir(), 'logo_tuned/fmri_w200.png')
 
 # The name of an image file (within the static path) to use as favicon of the
 # docs.  This file should be a Windows icon file (.ico) being 16x16 or 32x32