]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Discontinue the twitter widget
authorMichael Hanke <michael.hanke@gmail.com>
Fri, 1 Apr 2011 19:53:45 +0000 (15:53 -0400)
committerMichael Hanke <michael.hanke@gmail.com>
Fri, 1 Apr 2011 19:53:45 +0000 (15:53 -0400)
and pull news directly from identi.ca

Makefile
sphinx/_static/neurodebian.css
sphinx/_static/neurodebian_bullet.png [new file with mode: 0644]
sphinx/index.rst

index 880f0d2f4123dccda9de3cafeb38c2dfd791ea09..cbd3f0fc835c59fdae57cb5e4148301ecd635cbc 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,7 @@ pics:
 html: pics source
        rsync -rvlhp sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
        cp -r build/src/lists $(WWW_DIR)/
index 799714d5a602d28d82af050131b612d21796f135..f20f4e9abffa3692f8bf324cac2c6f61bd36c607 100644 (file)
@@ -42,6 +42,30 @@ div.sphinxsidebar {
     font-size: 90%;
 }
 
+div#identica_widget {
+    font-size: 80%;
+}
+
+div#identica_widget p {
+       margin-top: 0.2em;
+       margin-bottom: 0.2em;
+       display: list-item;
+       list-style-image:url(neurodebian_bullet.png);
+}
+
+div.tweet {
+    border-bottom: 1px dotted #aaa;
+       margin-left: 2em;
+}
+
+span.time:before {
+    content: "[";
+}
+
+span.time:after {
+    content: "]";
+}
+
 div.clearer {
     clear: both;
 }
diff --git a/sphinx/_static/neurodebian_bullet.png b/sphinx/_static/neurodebian_bullet.png
new file mode 100644 (file)
index 0000000..74b51e7
Binary files /dev/null and b/sphinx/_static/neurodebian_bullet.png differ
index 495348e95e0ef71053be6129a9b31c43fac80aee..e87a3cedb127c28b548e9198e53711b97a4a9024 100644 (file)
@@ -43,39 +43,18 @@ News
 
 .. raw:: html
 
- <script src="http://widgets.twimg.com/j/2/widget.js"></script>
- <script>
- new TWTR.Widget({
-   version: 2,
-   type: 'profile',
-   rpp: 15,
-   interval: 6000,
-   width: 'auto',
-   height: 150,
-   theme: {
-     shell: {
-       background: '#898989',
-       color: '#ffffff'
-     },
-     tweets: {
-       background: '#ffffff',
-       color: '#000000',
-       links: '#82032f'
-     }
-   },
-   features: {
-     scrollbar: true,
-     loop: false,
-     live: false,
-     hashtags: true,
-     timestamp: true,
-     avatars: false,
-     behavior: 'all'
-   }
- }).render().setUser('NeuroDebian').start();
+ <script src="_static/jquery.livetwitter.min.js"></script>
+ <div id="identica_widget"></div>
+ <script type="text/javascript">
+ $("#identica_widget").liveTwitter('neurodebian',
+                                   {service: 'identi.ca',
+                                    mode: 'user_timeline',
+                                    limit: 10,
+                                    rate: 300000});
  </script>
 
-Follow us on identi.ca_ or twitter_ to subscribe to the NeuroDebian news.
+Older news items are available on identi.ca_. Follow us on identi.ca_
+(preferred) or twitter_ to subscribe to the NeuroDebian news.
 
 .. _identi.ca: http://identi.ca/neurodebian
 .. _twitter: http://twitter.com/NeuroDebian