]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Merge branch 'master' of alioth:/git/pkg-exppsy/neurodebian
authorMichael Hanke <michael.hanke@gmail.com>
Mon, 16 May 2011 15:34:31 +0000 (11:34 -0400)
committerMichael Hanke <michael.hanke@gmail.com>
Mon, 16 May 2011 15:34:31 +0000 (11:34 -0400)
* 'master' of alioth:/git/pkg-exppsy/neurodebian:
  Added an hlist into virt section as well
  BF for previous commit -- makedirs only if necessary
  minor fixes to get stats build from "clean page"

survey/Makefile
survey/makestats
survey/survey.rst

index 5dc7f7b03125de77da010fc38072b1bf1a423b67..31ee5e166e16a6eb5671a19e3e9c0d1d8ccc9aa7 100644 (file)
@@ -21,7 +21,7 @@ results_snippet.html: results.html
 statfigures: oslist.txt swlist.txt datamodlist.txt
 # create "lockfile'
        @touch $@
-       @[ "$$(cat nsubmissions.stamp || true)" != "$$(ls -1 data |wc -l)" ] \
+       @[ "$$(cat nsubmissions.stamp 2>/dev/null || echo)" != "$$(ls -1 data |wc -l)" ] \
                && ls -1 data |wc -l > nsubmissions.stamp \
                && MVPA_MATPLOTLIB_BACKEND=agg ./makestats data figures || true
 # remove lockfile
@@ -29,7 +29,7 @@ statfigures: oslist.txt swlist.txt datamodlist.txt
 
 getdata:
        rsync -rvzlhp --delete \
-               neurodebian@www.pymvpa.org:/home/neurodebian/surveydata .
+               neurodebian@www.pymvpa.org:/home/neurodebian/survey/data .
 
 oslist.txt: select_os_options.inc
        grep -v selected select_os_options.inc | sed -e 's/<option value="//' \
index 4ca6abc6d05775c4850d560d92a896d31bfee398..f12a37af2b78eadae685224314637c6463840b3c 100755 (executable)
@@ -10,7 +10,7 @@ except ImportError:
     from json import read as jread
     def jsonload(f):
         return jread(f.read())
-import sys
+import sys, os
 import pylab as pl
 import numpy as np
 import time
@@ -75,8 +75,8 @@ os_family = {
 # end the reverse mapping
 os_family_rev = {}
 for ost in os_family:
-    for os in os_family[ost]:
-        os_family_rev[os] = ost
+    for os_ in os_family[ost]:
+        os_family_rev[os_] = ost
 
 
 def load_list2dict(name):
@@ -269,6 +269,8 @@ def mkpic_rating_by_os(db, env, items, destdir, title):
 
 def main(srcdir, destdir):
     db = DB(srcdir)
+    if not os.path.exists(destdir):
+        os.makedirs(destdir)
     for pic in [mkpic_submissions_per_datamod, mkpic_os_per_env, mkpic_software,
                 mkpic_resources]:
         pic(db, destdir)
index 9b0bf507df0eb3c0754d778bc0c074979cd92796..65ec1b8b86b5cc748187cb01c1cbf9e38e07b1f0 100644 (file)
@@ -544,14 +544,17 @@ What **host operating system** are the virtual machines running on?
 .. raw:: html
 
    </select>
-   </td></tr><tr><td colspan="2">
+   </td></tr></table>
+
+---------------------------------------------------------------
 
 What are your reasons for employing virtualization in you research?
 Please indicate how much you agree to the following statements
 
 .. raw:: html
 
-   </td></tr><tr class="oddrow"><td class="task">
+   <table>
+   <tr class="oddrow"><td class="task">
 
 I can run software that is otherwise incompatible with my system