]> git.donarmstrong.com Git - neurodebian.git/commitdiff
describe dependency for stats.txt
authorYaroslav Halchenko <debian@onerussian.com>
Thu, 19 May 2011 14:05:09 +0000 (10:05 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Thu, 19 May 2011 14:05:09 +0000 (10:05 -0400)
survey/Makefile

index 662eadcba91cc47999166ff5ba508e8e6c0bee52..a4f6223051e9d0581a7c25bb4a1dcd2e14c7e8f8 100644 (file)
@@ -18,10 +18,13 @@ results_snippet.html: results.html
                | tail -n$$(echo "$$(wc -l < results.html) - $$(grep -n '<body>' \
                < results.html | cut -d ':' -f 1,1) - 2" | bc ) > $@
 
+figures/stats.txt: statfigures
+
 statfigures: oslist.txt swlist.txt datamodlist.txt employer-dd-list.txt position-dd-list.txt ratingslist.txt vmlist.txt
 # create "lockfile'
        @touch $@
        @[ "$$(cat nsubmissions.stamp 2>/dev/null || echo)" != "$$(ls -1 data |wc -l)" ] \
+               && echo "I: Re-generating stats figures" \
                && ls -1 data |wc -l > nsubmissions.stamp \
                && MVPA_MATPLOTLIB_BACKEND=agg ./makestats data figures || true
 # remove lockfile
@@ -68,3 +71,4 @@ upload: index.html results.html results_snippet.html jquery.form.js survey.css s
                --chmod=Dg+s,g+rw * neurodebian@www.pymvpa.org:/home/neurodebian/survey/
        scp surveycollector.cgi neurodebian@www.pymvpa.org:/srv/neuro.debian.net/cgi-bin/
 
+.PHONY: statfigures