]> git.donarmstrong.com Git - neurodebian.git/commitdiff
adding website-build-depends Makefile rule to ease figuring out what is needed to...
authorYaroslav Halchenko <debian@onerussian.com>
Wed, 24 Apr 2013 17:39:13 +0000 (13:39 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Wed, 24 Apr 2013 17:39:13 +0000 (13:39 -0400)
Makefile

index 124f83757b15a9f70a81a9c17ba47121f0e8dc21..de232c7f9ba364e6fdb7691eb0ad89497e3be0b1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -13,6 +13,12 @@ all: updatedb upload-website mirmon
 # Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
 refresh: upload-website-stamp mirmon
 
+website-build-depends:
+       : # Python modules
+       sudo apt-get install python-sphinx python-argparse python-xdg python-debian
+       : # JavaScripts
+       sudo apt-get install libjs-jquery-easing libjs-jquery-mousewheel libjs-jquery-fancybox
+
 
 pics:
        $(MAKE) -C artwork