]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Rename neurodebian-keyring to neurodebian-archive-keyring to be closer to what it...
authorYaroslav Halchenko <debian@onerussian.com>
Thu, 14 Aug 2014 16:56:25 +0000 (12:56 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Thu, 14 Aug 2014 16:56:25 +0000 (12:56 -0400)
debian/.gitignore
debian/TODO
debian/control
live/auto/config
sphinx/faq.rst
tools/nd-configurerepo
tools/tests/test_neurodebian-repository-deployment
vm/d-i/tools/initial_setup
vm/d-i/wheezy/initial_setup

index 2ffbef44694ef7ff7e46d2ecc383f498c90a9881..2ab32f217987eb9ceb45ed88916bdb89567f3c92 100644 (file)
@@ -3,6 +3,6 @@
 /neurodebian-desktop
 /neurodebian-dev
 /neurodebian-guest-additions
-/neurodebian-keyring
+/neurodebian-archive-keyring
 /*.log
 /*.substvars
index 0e69205d89c095be4ce0f401403317fdf6adb469..9d4f16768539d9fd1f0615296c39997141110f65 100644 (file)
@@ -19,14 +19,14 @@ set -ex
 apt_file=/etc/apt/sources.list.d/local.list
 
 # clean up from a previous test
-dpkg --purge neurodebian neurodebian-keyring || :
+dpkg --purge neurodebian neurodebian-archive-keyring || :
 echo PURGE | debconf-communicate neurodebian || :
 rm -rf /tmp/apt $apt_file;
 
 mkdir -p /tmp/apt; cd /tmp/apt;
 rm -f neurodebian-*deb; apt-get update -y; apt-get install -y wget;
 wget http://www.onerussian.com/tmp/neurodebian_0.33~a1_all.deb;
-wget http://www.onerussian.com/tmp/neurodebian-keyring_0.33~a1_all.deb;
+wget http://www.onerussian.com/tmp/neurodebian-archive-keyring_0.33~a1_all.deb;
 
 # generate APT repo
 apt-get install -y dpkg-dev ;  dpkg-scanpackages  . /dev/null > Packages
index f6629ed7754b843414f47ac4482241cc459ded02..20a1feb62f6711ef673464f53fdcd7e4c4483b69 100644 (file)
@@ -12,7 +12,7 @@ Vcs-Git: git://git.debian.org/git/pkg-exppsy/neurodebian.git
 Package: neurodebian
 Architecture: all
 Pre-depends: python, wget
-Depends: neurodebian-keyring, ${misc:Depends}
+Depends: neurodebian-archive-keyring, ${misc:Depends}
 Recommends: netselect
 Suggests: neurodebian-desktop, neurodebian-popularity-contest
 Description: turnkey platform for the neuroscience
@@ -27,7 +27,7 @@ Description: turnkey platform for the neuroscience
 
 Package: neurodebian-dev
 Architecture: all
-Depends: ${misc:Depends}, devscripts, cowbuilder, neurodebian-keyring
+Depends: ${misc:Depends}, devscripts, cowbuilder, neurodebian-archive-keyring
 Recommends: python, zerofree, moreutils, time, ubuntu-keyring, debian-archive-keyring, apt-utils
 Suggests: virtualbox-ose, virtualbox-ose-fuse
 Description: NeuroDebian development tools
@@ -47,9 +47,11 @@ Description: neuroscience research environment
  automatically installed upon initial invocation.
 
 
-Package: neurodebian-keyring
+Package: neurodebian-archive-keyring
 Architecture: all
 Depends: ${misc:Depends}
+Replaces: neurodebian-keyring (<< 0.34~)
+Breaks: neurodebian-keyring (<< 0.34~)
 Description: GnuPG archive keys of the NeuroDebian archive
  The NeuroDebian project digitally signs its Release files. This package
  contains the archive keys used for that.
index ebafd66b1dbb6a4b6befd2298517fbccc6dc6212..a15c60e5a69faf39a72deb2184cb3c3bdd5da038 100755 (executable)
@@ -34,7 +34,7 @@ lb config noauto \
   --iso-preparer "NeuroDebian ${nd_version}; http://neuro.debian.net" \
   --iso-publisher "NeuroDebian project; http://neuro.debian.net" \
   --iso-volume "NeuroDebian Live ${nd_version} $nd_arch" \
-  --keyring-packages "debian-archive-keyring neurodebian-keyring" \
+  --keyring-packages "debian-archive-keyring neurodebian-archive-keyring" \
   --memtest memtest86+ \
   --mirror-bootstrap "${deb_mirror}/debian/" \
   --mirror-chroot "${deb_mirror}/debian/" \
index febb136d62fd66d5dd7aeb899d434ff369c28a85..67a44129f9651af331b93e6faa91c5abf5731d0a 100644 (file)
@@ -107,7 +107,7 @@ Frequently Asked Questions
 
     This is because your APT installation initially does not know the GPG
     key that is used to sign the release files of this repository. It is easy to
-    make APT happy again. The simplest way is to install the ``neurodebian-keyring``
+    make APT happy again. The simplest way is to install the ``neurodebian-archive-keyring``
     package that is available from the NeuroDebian repository. Alternatively:
 
     1. Get the key. Either download the `repository key from here
index feed5d58c283693b498fddf0a3b8161bc8fd386d..d8e3868f20dd4c7ea551d42e4e13d02f49541861 100755 (executable)
@@ -543,7 +543,7 @@ fi
 #
 
 # Figure out if key needs to be imported (if ran within package,
-# should already be there due to neurodebian-keyring package)
+# should already be there due to neurodebian-archive-keyring package)
 if LANG=C eval $ae_sudo apt-key export $nd_key_id 2>&1 1>/dev/null | grep -qe "nothing exported"; then
     print_verbose 1 "Fetching the key from the server"
     eval_dry apt-key adv --recv-keys --keyserver pgp.mit.edu $nd_key_id
index 690041701e6b11a2f9377d9c00becd8a75fd2bb0..48f2f94c8707caa36915bc57df3dc743adb99f0b 100755 (executable)
@@ -6,14 +6,14 @@ apt_file=/etc/apt/sources.list.d/local.list
 apt_nd_file=/etc/apt/sources.list.d/neurodebian.sources.list
 
 # clean up from a previous test
-dpkg --purge neurodebian neurodebian-keyring || :
+dpkg --purge neurodebian neurodebian-archive-keyring || :
 echo PURGE | debconf-communicate neurodebian || :
 rm -rf /tmp/apt $apt_file;
 
 mkdir -p /tmp/apt; cd /tmp/apt;
 rm -f neurodebian-*deb; apt-get update -y; apt-get install -y wget;
-wget http://www.onerussian.com/tmp/neurodebian_0.33~a1_all.deb;
-wget http://www.onerussian.com/tmp/neurodebian-keyring_0.33~a1_all.deb;
+wget http://www.onerussian.com/tmp/neurodebian_0.34_all.deb;
+wget http://www.onerussian.com/tmp/neurodebian-archive-keyring_0.34_all.deb;
 
 # generate APT repo
 apt-get install -y dpkg-dev ;  dpkg-scanpackages  . /dev/null > Packages
index 67c31530eab6592e4f771438723dd662f9f60c14..1b19b02c1c545ac94b4e98dc2af1d2e2a491bc67 100755 (executable)
@@ -63,7 +63,7 @@ apt-get update -y
 gpg --keyserver hkp://subkeys.pgp.net --recv-keys 16BA136C && \
         gpg --export 16BA136C | apt-key add - || :
 
-apt-get install -y --allow-unauthenticated neurodebian-keyring
+apt-get install -y --allow-unauthenticated neurodebian-archive-keyring
 apt-get update -y
 
 # to cheat the VM check
index 852ea58ed0ed574aa96cad89d9e6d137e5e32f4e..7161959ce1a19629426f8545512f6964793f549b 100755 (executable)
@@ -68,7 +68,7 @@ apt-get update -y
 gpg --keyserver hkp://subkeys.pgp.net --recv-keys 16BA136C && \
         gpg --export 16BA136C | apt-key add - || :
 
-apt-get install -y --allow-unauthenticated neurodebian-keyring
+apt-get install -y --allow-unauthenticated neurodebian-archive-keyring
 apt-get update -y
 
 # to cheat the VM check