]> git.donarmstrong.com Git - neurodebian.git/commitdiff
changelog + nd-vmsetupwizard: Preparing 0.29 release of neurodebian for updated nd...
authorYaroslav Halchenko <debian@onerussian.com>
Mon, 1 Oct 2012 18:11:00 +0000 (14:11 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Mon, 1 Oct 2012 18:11:00 +0000 (14:11 -0400)
* VM (6.0.6):
  - base on 6.0.6 Debian point release (finally version of NeuroDebian
    VM is in sync with the Debian release)
  - nd-vmsetupwizard:
    - robustify check/linking of $HOME/host
    - optional installations dialog:
      - set height of the dialog to 450 for to fit all list items
      - refactored "GIMP" section into "Graphics" which would install
        also inkscape, vym and svgtune
      - added sections for "PyMVPA tutorial", and different collections of
        Python modules (Neuroimaging, Electrophysiology, etc)
      - Python selections depend on ipython01x instead of older ipython
        to provide IPython notebooks facilities out-of-the-box

debian/changelog
tools/nd-vmsetupwizard
vm/tools/nd_createappliance

index c37d29206be287a40ce2ce1e8672523df3ff1594..ad929db81b9acbd03e1c5873c845913eb1252430 100644 (file)
@@ -1,3 +1,25 @@
+neurodebian (0.29) unstable; urgency=low
+
+  [ Yaroslav Halchenko & Michael Hanke ]
+  * website:
+    - new mirror ([de-md])
+    - dynamic ranges for the new distributions subscription stats plot
+  * VM (6.0.6):
+    - base on 6.0.6 Debian point release (finally version of NeuroDebian
+      VM is in sync with the Debian release)
+    - nd-vmsetupwizard:
+      - robustify check/linking of $HOME/host
+      - optional installations dialog:
+        - set height of the dialog to 450 for to fit all list items
+        - refactored "GIMP" section into "Graphics" which would install
+          also inkscape, vym and svgtune
+        - added sections for "PyMVPA tutorial", and different collections of
+          Python modules (Neuroimaging, Electrophysiology, etc)
+        - Python selections depend on ipython01x instead of older ipython
+          to provide IPython notebooks facilities out-of-the-box
+
+ -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 01 Oct 2012 12:26:37 -0400
+
 neurodebian (0.28) unstable; urgency=low
 
   [ Michael Hanke & Yaroslav Halchenko]
index 8d69df4b38c3da75afb345ade40b7363371c9428..496ccf173ef74afb1577c9668b132dfc56819442 100755 (executable)
@@ -102,12 +102,14 @@ Do you want to get those files, if available, sourced automatically for your env
 fi
 
 # create symlink to shared folder into homedir
-[ ! -e $HOME/host ] && ln -s /media/sf_host $HOME/host
+# note: -e check would exit 1 if link is broken
+#       ln -f is used for further robustness
+[ ! -L $HOME/host ] && ln -sf /media/sf_host $HOME/host
 
 # TODO: add PyMVPA:
 #   FALSE "PyMVPA" "python-mvpa2,python-mvpa2-doc,python-mvpa2-tutorial-data" \
 # needs -doc and -tutorial-data package
-packages=$(zenity --list $icon_opt --checklist --column="Install" --column="Description" \
+packages=$(zenity --height 450 --list $icon_opt --checklist --column="Install" --column="Description" \
           --column="Package Name" --print-column=3 --hide-column=3 --hide-header \
           --separator=' ' --text="Please select any additional component that shall be installed.
 
@@ -115,10 +117,14 @@ Please note that this selection will not affect packages already installed
 on the system. No installed packages will be reinstalled or removed, only
 additional components will be installed." \
 FALSE "Emacs" "emacs" \
-FALSE "GNU Image Manipulation Program (Gimp)" "gimp" \
+FALSE "Graphics (e.g. GIMP, Inscape)" "gimp,inkscape,svgtune,xzgv,vym" \
 FALSE "Octave" "octave,qtoctave" \
 FALSE "OpenOffice.org" "openoffice.org" \
-FALSE "Scientific Python" "ipython,python-scipy,python-matplotlib" \
+FALSE "PyMVPA Tutorial" "ipython01x,python-mvpa2,python-mvpa2-doc,python-mvpa2-tutorialdata,spyder" \
+FALSE "Python: Electrophysiology & Modeling" "python-brian,python-pynn,python-pyentropy,stimfit" \
+FALSE "Python: Neuroimaging" "ipython01x,spyder,nipy-suite,python-mvpa2" \
+FALSE "Python: Scientific stack" "ipython01x,spyder,python-matplotlib,python-pandas,python-sympy" \
+FALSE "R" "r-recommended" \
 FALSE "TeX Live" "texlive" \
 FALSE "Adobe Flash browser plugin" "flashplugin-nonfree" \
 FALSE "Sun Java browser plugin" "sun-java6-plugin" \
index 6a4539bb962f96136efc042e0730ac1e5f27de07..fc76bcbeb2cc0f737f5a3ee5437680f6e3883c98 100755 (executable)
@@ -6,14 +6,14 @@ set -eu
 
 # TODO: arguments later on to become cmdline args
 #iso=debian-squeeze-di-beta1-amd64-businesscard.iso
-iso=debian-6.0.3-${ARCH:=amd64}-businesscard.iso
+iso=debian-6.0.6-${ARCH:=amd64}-businesscard.iso
 di_cd=$(readlink -f $PWD/../../../neurodebian-images/$iso)
 di_host=head1.hydra.dartmouth.edu               # where to look for di preseed
 
 build_dir=$PWD/build
 dist_dir=$PWD/dist
 vendor="NeuroDebian"
-vm_version="6.0.5"
+vm_version="6.0.6"
 vm_ostype=Debian
 vendor_url="http://neuro.debian.net"
 product_url="${vendor_url}/vm.html"