]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Replace a good chunk of code with the new bigmess
authorMichael Hanke <michael.hanke@gmail.com>
Thu, 27 Dec 2012 09:17:10 +0000 (10:17 +0100)
committerMichael Hanke <michael.hanke@gmail.com>
Thu, 27 Dec 2012 09:17:10 +0000 (10:17 +0100)
Makefile

index 7829c85774b0b909963660244608712998858bc4..0bf8ada90cfc7e5e7390297589ef716f8e756014 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -36,15 +36,20 @@ distclean: clean
 
 
 source: source-stamp
-source-stamp: build/db.db
-       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
-               --cfg neurodebian.cfg \
-               --db build/db.db \
-               --outdir build/src \
-               --pkgaddenum pkgs \
-               --extracts /home/www/neuro.debian.net/www/debian/extracts \
-               commandisirrelevant
-       rm -f html-stamp
+source-stamp: 
+       mkdir -p build/src/pkgs/
+       mkdir -p build/src/lists/
+       PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess genpkgs -d build/src/pkgs/
+       PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess genaptlists -d build/src/lists/
+       PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess genmirrorselect > build/src/sources_lists
+#      PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
+#              --cfg neurodebian.cfg \
+#              --db build/db.db \
+#              --outdir build/src \
+#              --pkgaddenum pkgs \
+#              --extracts /home/www/neuro.debian.net/www/debian/extracts \
+#              commandisirrelevant
+#      rm -f html-stamp
        touch $@