]> git.donarmstrong.com Git - neurodebian.git/commitdiff
All backported packages will depend on neurodebian-popularity-contest now
authorYaroslav Halchenko <debian@onerussian.com>
Mon, 6 Dec 2010 21:30:06 +0000 (16:30 -0500)
committerYaroslav Halchenko <debian@onerussian.com>
Mon, 6 Dec 2010 21:30:11 +0000 (16:30 -0500)
debian/changelog
tools/nd_backport

index 5376a3c0b26531bda7ee17492a51e6ff93fdda74..7b457145999d3d26fdc2f9926369abf4644ac3df 100644 (file)
@@ -1,6 +1,7 @@
 neurodebian (0.20) unstable; urgency=low
 
-  * New package neurodebian-popularity-contest
+  * New package neurodebian-popularity-contest, which all backported
+    packages will depend on.
 
  -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 06 Dec 2010 14:27:56 -0500
 
index 19b49541c4250dd894c62e13aac0b2497e8334d7..b71fe5d6ba0b3f9b23cf5f89ccfb47603e3dea12 100755 (executable)
@@ -27,13 +27,21 @@ EOT
 exit 1
 fi
 
+upstream_name=${dscfile%%_*}
+
+# To overcome bash desire to claim empty array unbound under 'set -u'
+# above, lets just specify empty rule for sed when nothing to be done
+mod_control=""
+if [ "$upstream_name" != "neurodebian" ]; then
+       # Avoid injection into neurodebian package itself
+       mod_control='s/\(^Depends:\) */\1 neurodebian-popularity-contest, /g'
+fi
+
 # assemble an appropriate backport-dsc call
 backport-dsc \
        --maint-name "NeuroDebian Maintainers" \
        --maint-email "team@neuro.debian.net" \
        --target-distribution "$release" \
        --version-suffix "$(nd_querycfg "release backport ids" "$release")" \
+       --mod-control "$mod_control" \
        "$dscfile"
-
-# not adding the auto-dep for now
-#      --mod-control 's/^Depends:.*$/&, neurodebian-trailer/' \