]> git.donarmstrong.com Git - lilypond.git/blob - make/out/lilypond.redhat.spec
f17159888ba17ca230784dce7bbd3252602704fc
[lilypond.git] / make / out / lilypond.redhat.spec
1 # -*- rpm-spec-mode -*-
2
3 %define info yes
4
5 Name: lilypond
6 Version: 1.5.48
7 Release: 1
8 License: GPL
9 Group: Applications/Publishing
10 Source0: ftp.cs.uu.nl:/pub/GNU/LilyPond/development/lilypond-1.5.48.tar.gz
11 Summary: Create and print music notation 
12 URL: http://www.lilypond.org/
13 BuildRoot: /tmp/lilypond-install
14
15 # add lots of Buildreq: flex, bison, tetex, tetex-devel, tetex-latex, texinfo
16 # better prereqs: tetex-latex, python, (mpost?) etc.
17 Prereq: tetex t1utils bison flex pktrace texinfo tetex-latex gcc-c++ python 
18
19 %description
20 LilyPond lets you create music notation.  It produces
21 beautiful sheet music from  a high-level description file.
22
23 %package documentation
24 Summary: Prebuilt website containing all LilyPond documentation.
25 Group: Applications/Publishing
26 # BuildArchitectures: noarch
27
28 %description documentation
29
30 The documentation of LilyPond, both in HTML and PostScript.
31
32 %prep
33 %setup
34
35 %build
36
37 # DO NOT use % { configure } , it hardcodes all paths, runs libtool,
38 # so we can't do make prefix=/tmp/ install.
39
40 # In fact, do not take out the spaces between % and { in the above comment,
41 # because RPM will gladly do a substitution anyway.
42
43 ./configure --disable-checking --prefix=%{_prefix} --enable-optimise
44
45 make MAKE_PFA_FILES=1 all
46
47 # make info
48 make -C Documentation
49
50 # make  html
51 make web-doc top-web 
52
53 %install
54
55
56 rm -rf $RPM_BUILD_ROOT
57 mkdir -p $RPM_BUILD_ROOT/tmp/lilypond-rpm-doc
58
59 strip lily/out/lilypond 
60 make prefix="$RPM_BUILD_ROOT%{_prefix}" MAKE_PFA_FILES=1 install
61
62 %if info=="yes"
63 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/info/*
64 %endif
65
66 mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/site-start.d
67 install -m 644 lilypond-mode.el lilypond-font-lock.el $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/
68 install -m 644 lilypond-init.el $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/site-start.d
69
70 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/man/man1/*
71
72 mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
73 cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
74 cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
75
76
77 # again, make sure that main package installs even if doco fails
78 mkdir -p web/out
79 tar -C web -xzf out/web.tar.gz 
80
81
82 %post
83
84 touch /tmp/.lilypond-install
85 rm `find /var/lib/texmf -name 'feta*pk -print' -or -name 'feta*tfm -print'` /tmp/.lilypond-install
86
87 %if info=="yes"
88 /sbin/install-info %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir 
89 %endif
90
91
92 echo 'Please logout first before using LilyPond.'
93
94 %preun
95
96 %if info=="yes"
97 if [ $1 = 0 ]; then
98     /sbin/install-info --delete %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir 
99 fi
100 %endif
101
102
103 %files
104 %defattr(-, root, root)
105 %{_datadir}/emacs/site-lisp/lilypond-*
106 %{_datadir}/emacs/site-lisp/site-start.d/lilypond-*
107
108 %{_prefix}/bin/abc2ly
109 %{_prefix}/bin/as2text
110 %{_prefix}/bin/convert-ly
111 %{_prefix}/bin/etf2ly
112 %{_prefix}/bin/lilypond
113 %{_prefix}/bin/ly2dvi
114 %{_prefix}/bin/midi2ly
115 %{_prefix}/bin/lilypond-book
116 %{_prefix}/bin/mup2ly
117 %{_prefix}/bin/musedata2ly
118 %{_prefix}/bin/pmx2ly
119
120 %if info=="yes"
121 %{_prefix}/info/lilypond.info.gz
122 %{_prefix}/info/lilypond-internals.info.gz
123 %endif
124
125 %{_prefix}/man/man1/abc2ly.1.gz
126 %{_prefix}/man/man1/as2text.1.gz
127 %{_prefix}/man/man1/convert-ly.1.gz
128 %{_prefix}/man/man1/etf2ly.1.gz
129 %{_prefix}/man/man1/lilypond.1.gz
130 %{_prefix}/man/man1/ly2dvi.1.gz
131 %{_prefix}/man/man1/midi2ly.1.gz
132 %{_prefix}/man/man1/lilypond-book.1.gz
133 %{_prefix}/man/man1/musedata2ly.1.gz
134 %{_prefix}/man/man1/mup2ly.1.gz
135 %{_prefix}/man/man1/pmx2ly.1.gz
136
137 %{_prefix}/share/lilypond/
138 %{_prefix}/share/locale/*/LC_MESSAGES/lilypond.mo
139 %{_prefix}/../etc/profile.d/lilypond.*
140
141 %files documentation
142 %doc web/