]> git.donarmstrong.com Git - kiibohd-controller.git/blobdiff - LoadFile/CMakeLists.txt
Windows is now working with libusb1.0 for the teensy-loader-cli.
[kiibohd-controller.git] / LoadFile / CMakeLists.txt
index 5baea82e579c02dd436118bfccc87c137d9d9a26..7b5ace25d33afd8b7e05b0859b3ac73ce89d1e47 100644 (file)
@@ -45,8 +45,8 @@ set( SRCS
 #
 list( APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR} ) # Use local find scripts
 
-#| Linux - libusb
-if( CMAKE_SYSTEM_NAME MATCHES "Linux" )
+#| Linux/Windows - libusb
+if( CMAKE_SYSTEM_NAME MATCHES "Linux" OR CMAKE_SYSTEM_NAME MATCHES "CYGWIN" )
        # Find libusb (not 1.0)
        find_package( LibUSB-1.0 REQUIRED )
 
@@ -59,16 +59,6 @@ if( CMAKE_SYSTEM_NAME MATCHES "Linux" )
        # Libraries
        set( LIBS ${LIBUSB_LIBRARIES} )
 
-#| Windows
-elseif( CMAKE_SYSTEM_NAME MATCHES "CYGWIN" )
-       message( AUTHOR_WARNING "Not Tested...")
-
-       # Defines
-       set( DEFINES -s -DUSE_WIN32 )
-
-       # Libraries
-       set( LIBS hid setupapi )
-
 #| Mac OS X
 elseif( CMAKE_SYSTEM_NAME MATCHES "Darwin" )
        message( AUTHOR_WARNING "Not Tested...")