]> git.donarmstrong.com Git - kiibohd-controller.git/blobdiff - Bootloader/CMakeLists.txt
Fixing bugs in mk20dx128vlf5 support
[kiibohd-controller.git] / Bootloader / CMakeLists.txt
index ebe5ff4603a99351e1d7460d977ca6ca7ec4590d..41c2bccb1ffcc790cffc0125a1b01e0d8ffcf091 100644 (file)
 #| You _MUST_ clean the build directory if you change this value
 #|
 set( CHIP
-       "mk20dx128vlf5"    # McHCK    mk20dx128vlf5
-#      "mk20dx256vlh7"    # Kiibohd-dfu
+       #"mk20dx128vlf5"    # McHCK       mk20dx128vlf5
+       "mk20dx256vlh7"    # Kiibohd-dfu mk20dx256vlh7
 )
 
 
+
+###
+# Compiler Selection
+#
+
+#| *** EXPERIMENTAL ***
+#| Stick with gcc unless you know what you're doing
+#| Currently only arm is supported with clang
+set( COMPILER
+       "gcc"   # arm-none-eabi-gcc / avr-gcc - Default
+#       "clang" # arm-none-eabi
+       CACHE STRING "Compiler Type" )
+
+
+
 ###
 # Bootloader Configuration
 #
@@ -52,6 +67,14 @@ set( SRCS
        usb.c
 )
 
+# Only compile in if necessary
+if( CHIP STREQUAL "mk20dx256vlh7" )
+       set( SRCS ${SRCS}
+               debug.c
+       )
+endif()
+
+
 message( STATUS "Bootloader Source Files:" )
 message( "${SRCS}" )