]> git.donarmstrong.com Git - kiibohd-controller.git/blobdiff - Bootloader/CMakeLists.txt
Fixing bugs in mk20dx128vlf5 support
[kiibohd-controller.git] / Bootloader / CMakeLists.txt
index 704115db663a92adea330460918d10f087d23e60..41c2bccb1ffcc790cffc0125a1b01e0d8ffcf091 100644 (file)
@@ -20,8 +20,8 @@
 #| You _MUST_ clean the build directory if you change this value
 #|
 set( CHIP
-       "mk20dx128vlf5"    # McHCK       mk20dx128vlf5
-#      "mk20dx256vlh7"    # Kiibohd-dfu mk20dx256vlh7
+       #"mk20dx128vlf5"    # McHCK       mk20dx128vlf5
+       "mk20dx256vlh7"    # Kiibohd-dfu mk20dx256vlh7
 )
 
 
@@ -34,8 +34,8 @@ set( CHIP
 #| Stick with gcc unless you know what you're doing
 #| Currently only arm is supported with clang
 set( COMPILER
-       "gcc"   # arm-none-eabi-gcc / avr-gcc - Default
-#      "clang" # arm-none-eabi
+       "gcc"   # arm-none-eabi-gcc / avr-gcc - Default
+#       "clang" # arm-none-eabi
        CACHE STRING "Compiler Type" )
 
 
@@ -67,6 +67,14 @@ set( SRCS
        usb.c
 )
 
+# Only compile in if necessary
+if( CHIP STREQUAL "mk20dx256vlh7" )
+       set( SRCS ${SRCS}
+               debug.c
+       )
+endif()
+
+
 message( STATUS "Bootloader Source Files:" )
 message( "${SRCS}" )