]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
Add Policy version to DocBook subdocuments, fix whitespace
authorRuss Allbery <rra@debian.org>
Sat, 3 Mar 2012 02:41:34 +0000 (18:41 -0800)
committerRuss Allbery <rra@debian.org>
Sat, 3 Mar 2012 02:41:34 +0000 (18:41 -0800)
* Embed the Debian Policy version and build date in the debconf
  specification and the copyright-format document.  We'll make
  non-normative changes without updating other version numbers, and it's
  good to know which version one is looking at.
* Fix some whitespace issues in the debconf specification articleinfo.

.gitignore
copyright-format/copyright-format-1.0.xml
debconf_spec/debconf_specification.xml
debian/changelog
debian/rules

index 88799311e8697a4a527079f0402a87c55234a461..5c80ed52b265274cec8a57b8ffc85e99835b34b1 100644 (file)
@@ -1,8 +1,10 @@
 /Process.html
 /README.html
 /copyright-format/copyright-format-1.0.html
+/copyright-format/version.xml
 /debconf_spec/debconf_specification.html
 /debconf_spec/debconf_specification.txt.gz
+/debconf_spec/include/version.xml
 /debian/files
 /debian/tmp/
 /menu-policy.html/
index afa0c02bfbc47135da0d1c05cd25259ef8f4a2c6..217e8dda778cfc62b370550f252aec25bbd3dba8 100644 (file)
@@ -3,7 +3,9 @@
     href="http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl"?>
 
 <!DOCTYPE article PUBLIC '-//OASIS//DTD DocBook XML V4.5//EN'
-    'http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd'>
+    'http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd' [
+<!ENTITY % versiondata SYSTEM "version.xml"> %versiondata;
+]>
 
 <article class="specification" lang="en" id="copyright-format-1.0">
   <articleinfo>
@@ -11,6 +13,7 @@
       Machine-readable <filename>debian/copyright</filename> file
     </title>
     <subtitle>Version 1.0</subtitle>
+    <releaseinfo>Debian Policy &version;, &date;</releaseinfo>
     <legalnotice>
       <para>
         Copying and distribution of this file, with or without modification,
index a163213b97d37ed64d394e47c50e5ea614092c3e..638688a25349ab84fa449b5f6cc84470494e7509 100644 (file)
@@ -5,54 +5,35 @@
 <!ENTITY command_list SYSTEM "include/commands.xml">
 <!ENTITY priority_table SYSTEM "include/priorities.xml">
 <!ENTITY type_table SYSTEM "include/types.xml">
+<!ENTITY % versiondata SYSTEM "include/version.xml"> %versiondata;
 ]>
 <article>
 
   <articleinfo>
     <title>Configuration management</title>
     <subtitle>Protocol version 2.1</subtitle>
-    <releaseinfo>Revision 7.1</releaseinfo>
+    <releaseinfo>Revision 7.1, Debian Policy &version;, &date;</releaseinfo>
     <author>
-      <firstname>
-        Wichert
-      </firstname>
-      <surname>
-        Akkerman
-      </surname>
+      <firstname>Wichert</firstname>
+      <surname>Akkerman</surname>
       <affiliation>
-        <orgname>
-         The Debian Project
-       </orgname>
+        <orgname>The Debian Project</orgname>
        <address><email>wakkerma@debian.org</email></address>
       </affiliation>
     </author>
     <author>
-      <firstname>
-        Joey
-      </firstname>
-      <surname>
-        Hess
-      </surname>
+      <firstname>Joey</firstname>
+      <surname>Hess</surname>
       <affiliation>
-        <orgname>
-         The Debian Project
-       </orgname>
+        <orgname>The Debian Project</orgname>
        <address><email>joeyh@debian.org</email></address>
       </affiliation>
     </author>
     <copyright>
-      <year>
-        1998
-      </year>
-      <year>
-        1999
-      </year>
-      <year>
-        2000
-      </year>
-      <holder>
-        Wichert Akkerman and Joey Hess
-      </holder>
+      <year>1998</year>
+      <year>1999</year>
+      <year>2000</year>
+      <holder>Wichert Akkerman and Joey Hess</holder>
     </copyright>
     <legalnotice>
       <para>
index 566a8c52e22392f7b77730d7b9d45afb96ef9255..7aa9c6660252d27f4add85f13dcdfc3fbc7376c7 100644 (file)
@@ -24,6 +24,11 @@ debian-policy (3.9.3.1) UNRELEASED; urgency=low
     Morris.  (Closes: #658009)
   * Fix the legal notice in copyright-format to not refer to a nonexistent
     copyright notice.
+  * Embed the Debian Policy version and build date in the debconf
+    specification and the copyright-format document.  We'll make
+    non-normative changes without updating other version numbers, and it's
+    good to know which version one is looking at.
+  * Fix some whitespace issues in the debconf specification articleinfo.
   * Install the HTML version of upgrading-checklist in the policy.html
     directory as upgrading-checklist.html so that it can be deployed on
     www.debian.org in a way that will allow links to Policy sections to
index a3950ca7e2e88416cad8c5655315e1b70c4fbdbc..1f69ddb37eec3ab8e594352ff0b158d617f62243 100755 (executable)
@@ -56,7 +56,8 @@ FILES_TO_CLEAN        := $(SGML_FILES:=.txt) $(SGML_FILES:=.txt.gz)           \
                   $(ORG_FILES:=.html) $(ORG_FILES:=.txt)               \
                   policy.pdf.gz policy.ps.gz                           \
                   policy.pdf policy.ps policy.tpt policy.txt           \
-                  version.ent                                          \
+                  copyright-format/version.xml                         \
+                  debconf_spec/include/version.xml version.ent         \
                   copyright-format.xml.tar.gz                          \
                   debconf_specification.xml.tar.gz                     \
                   debian/files
@@ -68,7 +69,8 @@ mkdir   := install -d -o root -g root -m 755
 
 all build build-indep: stamp-build
 build-arch:
-stamp-build: version.ent
+stamp-build: version.ent copyright-format/version.xml \
+            debconf_spec/include/version.xml
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
                 $(SGML_FILES:=-1.html) \
@@ -84,11 +86,25 @@ stamp-build: version.ent
                tar -zcf ../debconf_specification.xml.tar.gz *
        touch stamp-build
 
-configure: version.ent
+# Create the version files for inclusion in the various documents.  We want
+# to put the Policy version and date in each document, even if they
+# separately have their own versions.
+configure: version.ent copyright-format/version.xml \
+          debconf_spec/include/version.xml
 version.ent: debian/changelog
        rm -f $@
        echo "<!entity version \"$(version)\">" >> $@
        echo "<!entity date    \"$(date)\">"    >> $@
+copyright-format/version.xml: debian/changelog
+       rm -f $@
+       echo '<?xml version="1.0" standalone="no"?>' >  $@
+       echo '<!ENTITY version "$(version)">'        >> $@
+       echo '<!ENTITY date    "$(date)">'           >> $@
+debconf_spec/include/version.xml: debian/changelog
+       rm -f $@
+       echo '<?xml version="1.0" standalone="no"?>' >  $@
+       echo '<!ENTITY version "$(version)">'        >> $@
+       echo '<!ENTITY date    "$(date)">'           >> $@
 
 clean:
        rm -f $(STAMPS_TO_CLEAN)