]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
Add build-arch and build-indep targets to debian/rules
authorRuss Allbery <rra@debian.org>
Sat, 5 Nov 2011 20:35:31 +0000 (13:35 -0700)
committerRuss Allbery <rra@debian.org>
Sat, 5 Nov 2011 20:35:31 +0000 (13:35 -0700)
debian/changelog
debian/rules

index 239db7563c8dad9f54b197ba1e8c8a345fdcf9a0..f7980d63cdd3643b784db248313cd1f430ee49dc 100644 (file)
@@ -18,6 +18,7 @@ debian-policy (3.9.3.0) UNRELEASED; urgency=low
   * Fix typo in upgrading-checklist entry for multiarch paths.  Thanks,
     Michael Dorrington. Closes: #626408
   * Add AGPL-3 to tools/license-count.
+  * Add build-arch and build-indep targets to debian/rules.
 
   [ Bill Allombert ]
   * Policy: Link relationship fields (7.1) to architecture specification
index 96565f0ffc6c8f85b7531dea4bb9e415d530b2ac..6a2803303ebf2c4caba99bfa53801dc1b75ca275 100755 (executable)
@@ -80,7 +80,8 @@ install_program := install -p -o root -g root  -m  755
 make_directory  := install -p -d       -o root -g root  -m  755
 
 
-all build: stamp-build
+all build build-indep: stamp-build
+build-arch:
 stamp-build: version.ent $(sanitycheck)
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
@@ -171,7 +172,8 @@ stamp-policy:  build $(sanitycheck)
        touch               stamp-policy
 
 
-.PHONY: configure build binary binary-arch binary-indep clean checkroot
+.PHONY: configure build build-arch build-indep binary binary-arch
+.PHONY: binary-indep clean checkroot
 
 #Local variables:
 #mode: makefile