]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
Install HTML upgrading-checklist in policy.html directory
authorRuss Allbery <rra@debian.org>
Mon, 27 Feb 2012 00:29:38 +0000 (16:29 -0800)
committerRuss Allbery <rra@debian.org>
Mon, 27 Feb 2012 00:29:38 +0000 (16:29 -0800)
* Install the HTML version of upgrading-checklist in the policy.html
  directory as upgrading-checklist.html so that it can be deployed on
  www.debian.org in a way that will allow links to Policy sections to
  work easily.  Thanks, Charles Plessy.  (Closes: #639663)

For right now, this is done with a bit of a hack to copy the file into
the appropriate directory and to turn the one-page HTML version of it
into a symlink inside the constructed package.

The clean solution will be to make the upgrading checklist an appendix
of Policy, which may be done as part of a DocBook conversion.

Makefile
debian/changelog
debian/rules

index 1f3675cf0858e084c39ece76c4193305020fbe47..a10b93d7092ebb6e22e33e3023d94b892f7422c4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -45,6 +45,16 @@ perl-policy.sgml: version.ent
 %.pdf.gz: %.pdf
        gzip -cf9 $< > $@
 
+# This is a temporary hack to fold the upgrading-checklist into the Policy
+# HTML directory so that it can be deployed alongside Policy on
+# www.debian.org in a way that lets the cross-document links work properly.
+# The correct solution is to make upgrading-checklist an appendix of Policy,
+# which will probably be done as part of a general conversion to DocBook.
+policy.html.tar.gz:: policy.html/upgrading-checklist.html
+policy.html/upgrading-checklist.html: upgrading-checklist-1.html \
+                                     policy.html/index.html
+       cp -p $< $@
+
 # convenience aliases :)
 html: policy.html/index.html
 html-1: policy-1.html
index d189ecb2e17ea9f335f4cdd796fc125f14abdca2..bf14fe3c819aec2c8c958b5bf8b5f7684c02e093 100644 (file)
@@ -1,5 +1,9 @@
 debian-policy (3.9.3.1) UNRELEASED; urgency=low
 
+  * Install the HTML version of upgrading-checklist in the policy.html
+    directory as upgrading-checklist.html so that it can be deployed on
+    www.debian.org in a way that will allow links to Policy sections to
+    work easily.  Thanks, Charles Plessy.  (Closes: #639663)
   * Fix mistaken word choice (prefix instead of suffix) in the upgrading
     checklist entry for 3.9.3.0.
   * Add some missing entries to the virtual package names list changelog.
index d242b66020baaee7f0d0acb3934ce63ffab7b099..e0e8c131f3ee8e4003bf10b2e42594ac8f6e945f 100755 (executable)
@@ -131,6 +131,13 @@ stamp-binary: stamp-build
                tar -C $(DOCDIR) -zxf $$file.html.tar.gz;       \
        done
 #
+# Make upgrading-checklist-1.html a symlink to the copy in the policy.html
+# directory.  This is temporary until it becomes a proper appendix.
+#
+       rm -f $(DOCDIR)/upgrading-checklist-1.html
+       ln -s policy.html/upgrading-checklist.html \
+               $(DOCDIR)/upgrading-checklist-1.html
+#
 # Install doc-base files.
 #
        @set -ex; for file in $(DESC_FILES); do                 \