]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
debian/rules: Fix a race condition while generating DEBIAN/md5sums.
authorBill Allombert <Bill.Allombert@math.u-bordeaux.fr>
Tue, 16 Jun 2009 20:14:33 +0000 (22:14 +0200)
committerBill Allombert <Bill.Allombert@math.u-bordeaux.fr>
Tue, 16 Jun 2009 20:14:33 +0000 (22:14 +0200)
debian/changelog
debian/rules

index c861aaa9fb721296da90449defb3478bcc6d402d..820230775f2b2dfb8f93e77d1c18676d91fd046b 100644 (file)
@@ -46,10 +46,12 @@ debian-policy (3.8.2.0) unstable; urgency=low
   [ Bill Allombert ]
   * Add myself to Uploaders.
   * Update Standards-Version to 3.8.1 (no changes required).
-  * debian/rules: use dpkg --print-architecture instead of
-    obsolete form dpkg --print-installation-architecture
+  * debian/rules: 
+    - use `dpkg --print-architecture' instead of obsolete form 
+      `dpkg --print-installation-architecture'.
+    - fix a race condition while generating DEBIAN/md5sums.
 
- -- Bill Allombert <ballombe@debian.org>  Tue, 16 Jun 2009 20:46:11 +0200
+ -- Bill Allombert <ballombe@debian.org>  Tue, 16 Jun 2009 21:42:53 +0200
 
 debian-policy (3.8.1.0) unstable; urgency=low
 
index aa42324469ec08a073067c9b6ac4d851f0cfe990..4fa4518f6025ca9d00892df9815d627cd4435bfc 100755 (executable)
@@ -142,7 +142,8 @@ stamp-policy:  build $(sanitycheck)
        $(install_file)     $(FHS_HTML)   $(DOCDIR)/fhs
        @set -ex; \
        cd debian/tmp; \
-       find . -type f -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
+       find . -path "./DEBIAN" -prune -o -type f -printf '%P\0' \
+           | xargs -r0 md5sum > DEBIAN/md5sums
        dpkg-gencontrol     -p$(package) -Pdebian/tmp -isp
        chown               -R root:root debian/tmp
        chmod               -R go=rX debian/tmp