]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
Debian changelogs should be UTF-8 encoded. Changed the wording from a
authorManoj Srivastava <srivasta@debian.org>
Thu, 16 Jun 2005 05:40:29 +0000 (05:40 +0000)
committerManoj Srivastava <srivasta@debian.org>
Thu, 16 Jun 2005 05:40:29 +0000 (05:40 +0000)
Author: srivasta
Date: 2003/06/07 17:39:17
Debian changelogs should be UTF-8 encoded. Changed the wording from a
should to a may; since a should would make an unknown number of
packages insta buggy. A reuest makes all these wishlist bugs; we can
raise the severity in a later version of policy.

Added LANG=C before the debiandoc2X invocations, this ensures that the
resulting documents do not get converted to the locale on the building
machine.

git-archimport-id: srivasta@debian.org--etch/debian-policy--devel--3.0--patch-230

Makefile
debian/changelog
debian/rules
policy.sgml

index 575a00dd2c2bff5e894b9944f73ce801cc700819..2335da48cb773a6c37a124d202245a41ce57b8f4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -8,25 +8,25 @@ mime-policy.sgml: version.ent
        nsgmls -wall -gues $<
 
 %.html/index.html: %.sgml
-       debiandoc2html $<
+       LANG=C debiandoc2html $<
 
 %.html.tar.gz: %.html/index.html
        tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
 %.txt: %.sgml
-       debiandoc2text $<
+       LANG=C debiandoc2text $<
 
 %.txt.gz: %.txt
        gzip -cf9 $< > $@
 
 %.ps: %.sgml
-       debiandoc2latexps $<
+       LANG=C debiandoc2latexps $<
 
 %.ps.gz: %.ps
        gzip -cf9 $< > $@
 
 %.pdf: %.sgml
-       debiandoc2latexpdf $<
+       LANG=C debiandoc2latexpdf $<
 
 %.pdf.gz: %.pdf
        gzip -cf9 $< > $@
index 6b99bc6eec074d34540b5449bef5782b580e6db0..e790f75d539c8d2e0e2b26b4d37118735845177c 100644 (file)
@@ -4,6 +4,14 @@ debian-policy (3.6.0) unstable; urgency=low
     XXX write a better description here XXX
     XXX update the section numbers in the upgrading checklist XXX
   * Added Games/Simulation to menu subpolicy               closes: Bug#194974
+  * [ACCEPTED]: Debian changelogs should be UTF-8 encoded. Changed the
+    wording from a should to a may; since a should would make an unknown
+    number of packages insta buggy. A reuest makes all these wishlist
+    bugs; we can raise the severity in a later version of policy.
+                                                           closes: Bug#174982
+  * Added LANG=C before the debiandoc2X invocations, this ensures that the
+    resulting documents do not get converted to the locale on the building
+    machine.                                               closes: Bug#175064
 
  -- 
 
@@ -321,7 +329,7 @@ debian-policy (3.5.3.0) unstable; urgency=low
     version.
   * Richard Braakman and Michael Dorman have expressed their resignation
     from policy maintenance duties.
-  * fixed the date thinko in upgrading checklist. Thanks to Sébastien
+  * fixed the date thinko in upgrading checklist. Thanks to Sébastien
     Montagne <sebastien.montagne@netcourrier.com>        closes: Bug#84236
 
  -- Manoj Srivastava <srivasta@debian.org>  Sun, 15 Apr 2001 13:36:19 -0500
index cfbfb6f5c0a047a9fe98d980b0c6b1a0324251a4..9a9650f426d7e96d7d97a8d0b1f694c033d82b12 100755 (executable)
@@ -5,30 +5,30 @@
 ## Created On      : Thu Oct 29 15:35:55 1998
 ## Created On Node  : tiamat.datasync.com
 ## Last Modified By : Manoj Srivastava
-## Last Modified On : Sat Oct 26 12:29:03 2002
+## Last Modified On : Sat Jun  7 12:35:31 2003
 ## Last Machine Used: glaurung.green-gryphon.com
-## Update Count            : 58
+## Update Count            : 59
 ## Status          : Unknown, Use with caution!
 ## HISTORY         :
 ## Description     :
 ## $Id$
 ###############################################################################
 
-ifdef ARCH
-  ha:=-a$(ARCH)
-endif
-
-set the dpkg-architecture vars; but we don't use them, so we'll comment out
-export DEB_BUILD_ARCH      ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
-export DEB_BUILD_GNU_CPU   ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
-export DEB_BUILD_GNU_SYSTEM?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
-export DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
-export DEB_HOST_ARCH       ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
-export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
-export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
-export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
-
-# arch := $(shell dpkg --print-installation-architecture)
+ifdef ARCH
+  ha:=-a$(ARCH)
+endif
+
+set the dpkg-architecture vars; but we don't use them, so we'll comment out
+export DEB_BUILD_ARCH      ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
+export DEB_BUILD_GNU_CPU   ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
+export DEB_BUILD_GNU_SYSTEM?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
+export DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_ARCH       ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
+export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
+export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
+export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
+
+arch   := $(shell dpkg --print-installation-architecture)
 
 # Basic information
 package := $(shell grep Source debian/control | sed 's/^Source: //')
index cdc21270968eb52c773fc77e1c829abd023bcc37..a98b2309e0169dae4add9a24cee89509c7b6df2d 100644 (file)
@@ -2815,7 +2815,7 @@ Package: libc6
              Those containing a single space followed by a single full stop
              character. These are rendered as blank lines. This is the
              <em>only</em> way to get a blank line<footnote>
-               Completely empty lines will not be rendered as blank lines. 
+               Completely empty lines will not be rendered as blank lines.
                Instead, they will cause the parser to think you're starting
                a whole new record in the control file, and will therefore
                likely abort with an error.
@@ -3870,7 +3870,7 @@ Build-Depends: kernel-headers-2.2.10 [!hurd-i386],
           they may not be installed at the same time as certain other
           packages, and/or that they depend on the presence of others.
         </p>
-  
+
         <p>
           This is done using the <tt>Depends</tt>, <tt>Pre-Depends</tt>,
           <tt>Recommends</tt>, <tt>Suggests</tt>, <tt>Enhances</tt> and
@@ -4266,7 +4266,7 @@ Replaces: mail-transport-agent
           installed or absent at the time of building the package
           can declare relationships to those binary packages.
         </p>
-  
+
         <p>
           This is done using the <tt>Build-Depends</tt>,
           <tt>Build-Depends-Indep</tt>, <tt>Build-Conflicts</tt> and
@@ -8175,9 +8175,9 @@ name ["<var>syshostname</var>"]:
           maintainer of the package is allowed to write this bug report
           themselves, if they so desire).  Do not close the bug report
           until a proper manpage is available.<footnote>
-              It is not very hard to write a man page. See the 
+              It is not very hard to write a man page. See the
              <url id="http://www.schweikhardt.net/man_page_howto.html"
-               name="Man-Page-HOWTO">, 
+               name="Man-Page-HOWTO">,
              <manref name="man" section="7">, the examples
               created by <prgn>debmake</prgn> or <prgn>dh_make</prgn>,
              the helper programs <prgn>help2man</prgn>, or the
@@ -9219,7 +9219,48 @@ install-info --quiet --remove /usr/share/info/foobar.info
            See <ref id="dpkgchangelog">.
          </p>
 
-         <sect2><heading>Defining alternative changelog formats
+         <p>
+           It is recommended that the entire changelog be encoded in the
+           <url id="http://www.cis.ohio-state.edu/cgi-bin/rfc/rfc2279.html" name="UTF-8">
+           encoding of
+           <url id="http://www.unicode.org/"
+           name="Unicode">.<footnote>
+             <p>
+               Support for Unicode, and specifically UTF-8, is
+               steadily increasing among popular applications in
+               Debian.  For example, in unstable, GNOME 2 has
+               excellent support (almost level 2) in almost all its
+               applications; the big remaining one is gnome-terminal,
+               of which one requires development versions in order to
+               support UTF-8 (available in Debian experimental now if
+               you want to play).  I think that by the time sarge is
+               released, UTF-8 support will start to hit critical
+               mass. </p>
+             <p>
+               I think it is fairly obvious that we need to
+               eventually transition to UTF-8 for our package
+               infrastructure; it is really the only sane charset in
+               an international environment.  Now, we can't switch to
+               using UTF-8 for package control fields and the like
+               until dpkg has better support, but one thing we can
+               start doing today is requesting that Debian changelogs
+               are UTF-8 encoded. At some point in time, we can start
+               requiring them to do so. 
+             </p>
+             <p>
+               Checking for non-UTF8 characters in a changelog is
+               trivial.  Dump the file through 
+               <example>iconv -f utf-8 -t ucs-4</example>
+                  discard the output, and check the return
+               value.  If there are any characters in the stream
+               which are invalid UTF-8 sequences, iconv will exit
+               with an error code; and this will be the case for the
+               vast majority of other character sets.
+             </p>
+           </footnote>
+         </p>
+
+         <sect2><heading>Defining alternative changelog formats
            </heading>
 
            <p>