]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
* Also provide documents in single-file HTML format.
authorBill Allombert <Bill.Allombert@math.u-bordeaux.fr>
Sat, 5 Sep 2009 09:10:30 +0000 (11:10 +0200)
committerBill Allombert <Bill.Allombert@math.u-bordeaux.fr>
Sat, 5 Sep 2009 09:10:30 +0000 (11:10 +0200)
  Proposed by Jari Aalto.
Closes: #544353
Makefile
debian/changelog
debian/rules

index efb5b7b927e1897e054f9e90df1354e5a2e589da..1d0852e5141aa6722af1acaeadf14ef2298acaf6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,11 @@ mime-policy.sgml: version.ent
 %.html/index.html: %.sgml
        LANG=C debiandoc2html $<
 
+%-1.html: %.sgml
+       LANG=C debiandoc2html -1 -b $*-1d $< && \
+        mv $*-1d.html/index.html $*-1.html && \
+        rmdir $*-1d.html
+
 %.html.tar.gz: %.html/index.html
        tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
@@ -33,6 +38,7 @@ mime-policy.sgml: version.ent
 
 # convenience aliases :)
 html: policy.html/index.html
+html-1: policy-1.html
 txt text: policy.txt
 ps: policy.ps
 pdf: policy.pdf
index a9d54e6ab995e313dbd4405998436c3965faa0f0..6da7e5a1c97ea0e2d5b26af7b795fd0fd4fcdeb1 100644 (file)
@@ -1,3 +1,11 @@
+debian-policy (3.8.3.1) unstable; urgency=low
+
+  * Also provide documents in single-file HTML format.
+    Proposed by Jari Aalto.
+    Closes: #544353
+
+ -- Bill Allombert <ballombe@debian.org>  Fri, 04 Sep 2009 14:32:42 +0200
+
 debian-policy (3.8.3.0) unstable; urgency=low
 
   * Policy: Bring Architecture description in line with dpkg-source
index 4fa4518f6025ca9d00892df9815d627cd4435bfc..07e635e68cd5cb537c4349d18e7895d5b0b5be29 100755 (executable)
@@ -55,6 +55,7 @@ FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
                  version.ent upgrading-checklist.txt \
                  $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
+                  $(SGML_FILES:=-1.html) \
                  policy.pdf.gz policy.ps.gz \
                  debconf_specification.xml.tar.gz \
                  policy.pdf policy.ps policy.txt policy. \
@@ -73,6 +74,7 @@ all build: stamp-build
 stamp-build: version.ent $(sanitycheck)
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
+                $(SGML_FILES:=-1.html) \
                $(SGML_FILES:=.txt.gz) \
                policy.ps.gz policy.pdf.gz
        links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
@@ -139,6 +141,9 @@ stamp-policy:  build $(sanitycheck)
        for file in $(SGML_FILES); do \
          tar -C $(DOCDIR) -zxf $$file.html.tar.gz; \
        done
+       for file in $(SGML_FILES); do \
+         $(install_file) $${file}-1.html $(DOCDIR); \
+       done
        $(install_file)     $(FHS_HTML)   $(DOCDIR)/fhs
        @set -ex; \
        cd debian/tmp; \