]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
Use gzip -n for compressing generated files.
[debian/debian-policy.git] / Makefile
index 4b7f62dbb6b7f12189c7247715a967d975c0b8a8..aa5408f8ee6e1985c8f472fe263882768cfb2eb8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -25,25 +25,25 @@ perl-policy.sgml: version.ent
         rmdir $*-1d.html
 
 %.html.tar.gz: %.html/index.html
-       tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
+       GZIP=-n9 tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
 %.txt: %.sgml
        LANG=C debiandoc2text $<
 
 %.txt.gz: %.txt
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 %.ps: %.sgml
        LANG=C debiandoc2latexps $<
 
 %.ps.gz: %.ps
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 %.pdf: %.sgml
        LANG=C debiandoc2latexpdf $<
 
 %.pdf.gz: %.pdf
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 # This is a temporary hack to fold the upgrading-checklist into the Policy
 # HTML directory so that it can be deployed alongside Policy on