]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
Use gzip -n for compressing generated files.
authorBill Allombert <Bill.Allombert@math.u-bordeaux1.fr>
Tue, 13 Oct 2015 20:09:08 +0000 (22:09 +0200)
committerBill Allombert <Bill.Allombert@math.u-bordeaux1.fr>
Tue, 13 Oct 2015 20:09:08 +0000 (22:09 +0200)
Makefile
copyright-format/Makefile
debconf_spec/Makefile
debian/changelog
debian/rules

index 4b7f62dbb6b7f12189c7247715a967d975c0b8a8..aa5408f8ee6e1985c8f472fe263882768cfb2eb8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -25,25 +25,25 @@ perl-policy.sgml: version.ent
         rmdir $*-1d.html
 
 %.html.tar.gz: %.html/index.html
-       tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
+       GZIP=-n9 tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
 %.txt: %.sgml
        LANG=C debiandoc2text $<
 
 %.txt.gz: %.txt
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 %.ps: %.sgml
        LANG=C debiandoc2latexps $<
 
 %.ps.gz: %.ps
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 %.pdf: %.sgml
        LANG=C debiandoc2latexpdf $<
 
 %.pdf.gz: %.pdf
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 # This is a temporary hack to fold the upgrading-checklist into the Policy
 # HTML directory so that it can be deployed alongside Policy on
index 92ef4f3c357addff88e05b3f8aaf0eb66a98b93a..9d03436d59fd28ce8741eed2808e1c26c3db9456 100644 (file)
@@ -9,7 +9,7 @@ copyright-format-1.0.txt: copyright-format-1.0.html
        links -dump $< | perl -pe 's/[\r\0]//g' > $@
 
 copyright-format-1.0.txt.gz: copyright-format-1.0.txt
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 clean:
        rm -f *.css *.html *.txt *.txt.gz
index ba5c251622ef634c30d65f01a1903c271222bdba..cd3e4a3a6b5d96d1446d60c6d426b9ce2bf465eb 100644 (file)
@@ -9,7 +9,7 @@ all: debconf_specification.txt.gz debconf_specification.html
        links -dump $< | perl -pe 's/[\r\0]//g' > $@
 
 %.txt.gz: %.txt
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 clean:
        rm -f *.css *.html *.txt *.txt.gz
index d48eac8a5ec9ffe5570fe2814f725b6a02b9d638..c26afda0f5cf98e55b8ffd2f2bda57b1ee5f6cf0 100644 (file)
@@ -1,6 +1,7 @@
 debian-policy (3.9.7.0) unstable; urgency=low
 
   * Policy: refreshed the names of the Policy Editors.
+  * Makefile: use gzip -n when compressing generated files.
   * Policy: Symbolic links must not traverse above the root directory.
     Wording: Andrey Rahmatullin <wrar@debian.org>
     Seconded: Bill Allombert <ballombe@debian.org>
@@ -32,7 +33,7 @@ debian-policy (3.9.7.0) unstable; urgency=low
     Seconded: Charles Plessy <plessy@debian.org>
     Closes: #106073
 
- -- Bill Allombert <ballombe@debian.org>  Fri, 08 May 2015 15:10:02 +0200
+ -- Bill Allombert <ballombe@debian.org>  Tue, 13 Oct 2015 22:03:00 +0200
 
 debian-policy (3.9.6.1) unstable; urgency=low
 
index 689ba738fca06b44916b1ec6ea8aee94ff676959..b18029210ffe6f22b98ac0ce3efb6b2acb63bb85 100755 (executable)
@@ -80,10 +80,10 @@ stamp-build: version.ent copyright-format/version.xml \
                $(ORG_FILES:=.txt)
        $(MAKE) -C copyright-format all
        $(MAKE) -C debconf_spec all
-       GZIP=-9 cd copyright-format && \
-               tar -zcf ../copyright-format.xml.tar.gz *
-       GZIP=-9 cd debconf_spec && \
-               tar -zcf ../debconf_specification.xml.tar.gz *
+       cd copyright-format && \
+               GZIP=-n9 tar -zcf ../copyright-format.xml.tar.gz *
+       cd debconf_spec && \
+               GZIP=-n9 tar -zcf ../debconf_specification.xml.tar.gz *
        touch stamp-build
 
 # Create the version files for inclusion in the various documents.  We want
@@ -162,7 +162,8 @@ stamp-binary: stamp-build
 #
 # Compress files and build MD5 checksums.
 #
-       gzip -f9 $(DOCDIR)/*.txt $(DOCDIR)/*.sgml $(DOCDIR)/changelog
+       gzip -f9 $(DOCDIR)/*.sgml $(DOCDIR)/changelog
+       gzip -f9 -n $(DOCDIR)/*.txt
        @set -ex; cd debian/tmp; \
        find . -path './DEBIAN' -prune -o -type f -printf '%P\0' \
                | xargs -r0 md5sum > DEBIAN/md5sums