]> git.donarmstrong.com Git - deb_pkgs/spamass-milter.git/commitdiff
Don't bother to report the queue id as a debugging value
authorDon Armstrong <don@donarmstrong.com>
Sat, 17 Nov 2018 16:04:04 +0000 (08:04 -0800)
committerDon Armstrong <don@donarmstrong.com>
Sun, 18 Nov 2018 01:26:26 +0000 (17:26 -0800)
debian/changelog
debian/patches/queueid_in_envrcpt [new file with mode: 0644]
debian/patches/series

index 8c26a259a5b96fec7c35a2ec2e48f8f140661cea..347beb41afc9fc87ad12009a4933609ed40b274e 100644 (file)
@@ -1,3 +1,9 @@
+spamass-milter (0.4.0-3) unstable; urgency=medium
+
+  * Call the i macro only after envrcpt time. (closes: #696856)
+
+ -- Don Armstrong <don@debian.org>  Sat, 17 Nov 2018 08:02:28 -0800
+
 spamass-milter (0.4.0-2) unstable; urgency=medium
 
   * Document milter env variables (closes: #816799)
diff --git a/debian/patches/queueid_in_envrcpt b/debian/patches/queueid_in_envrcpt
new file mode 100644 (file)
index 0000000..98d072f
--- /dev/null
@@ -0,0 +1,27 @@
+--- a/spamass-milter.cpp
++++ b/spamass-milter.cpp
+@@ -784,7 +784,6 @@
+ {
+   SpamAssassin* assassin;
+   struct context *sctx = (struct context *)smfi_getpriv(ctx);
+-  const char *queueid;
+   if (sctx == NULL)
+   {
+@@ -837,16 +836,6 @@
+   // remember the MAIL FROM address
+   assassin->set_from(string(envfrom[0]));
+   
+-  queueid=smfi_getsymval(ctx, const_cast<char *>("i"));
+-  if (!queueid)
+-  {
+-    queueid="unknown";
+-    warnmacro("i", "ENVFROM");
+-  }
+-  assassin->queueid = queueid;
+-
+-  debug(D_MISC, "queueid=%s", queueid);
+-
+   // tell Milter to continue
+   debug(D_FUNC, "mlfi_envfrom: exit");
index 0b89743a1b050b3a20ddd86d7c952190fb860e2c..0c34f8ef1d8bf026f1b849364b26ce9881301748 100644 (file)
@@ -1,3 +1,4 @@
 ignore_by_smtp_auth
 fix_spacing_in_received_header
 auth_in_received
+queueid_in_envrcpt