]> git.donarmstrong.com Git - deb_pkgs/spamass-milter.git/commitdiff
update standards version; add vcs-svn and vcs-browser; switch to dh 9
authordon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Thu, 21 Jun 2012 18:45:02 +0000 (18:45 +0000)
committerdon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Thu, 21 Jun 2012 18:45:02 +0000 (18:45 +0000)
debian/control
debian/rules

index 315e72da009084975d482868af0de9610d902a7f..eaad4ccd7673ae90babbfa4649aae426b8dd9586 100644 (file)
@@ -1,13 +1,15 @@
 Source: spamass-milter
 Section: mail
 Priority: extra
-Standards-Version: 3.8.0
-Build-Depends: libmilter-dev, debhelper (>= 7), groff-base
+Standards-Version: 3.9.2
+Build-Depends: libmilter-dev, debhelper (>= 9), groff-base
 Maintainer: Don Armstrong <don@debian.org>
+Vcs-Svn: svn://svn.donarmstrong.com/deb_pkgs/spamass-milter/trunk
+Vcs-Browser: http://wsvn.donarmstrong.com/deb_pkgs/spamass-milter/trunk
 
 Package: spamass-milter
 Architecture: any
-Depends: ${shlibs:Depends}, spamc, adduser
+Depends: ${shlibs:Depends}, ${misc:Depends}, spamc, adduser
 Recommends: spamassassin, sendmail|postfix
 Homepage: http://savannah.nongnu.org/projects/spamass-milt/
 Description: milter for filtering mail through spamassassin
index 139f2967b8aa73d8f80afe21cd6d3cd99f4c3e38..949977e147569629752a2e15680a67eceace131d 100755 (executable)
 #!/usr/bin/make -f
 
-#DH_VERBOSE = 1
-
-
-PREFIX=$(shell pwd)/debian/spamass-milter/usr
-
-patch: patch-stamp
-patch-stamp:
-       dh_testdir
-
-       if [ -e debian/patches ]; then \
-               for a in `ls debian/patches/*.diff`; do \
-                       patch -f -p0 < $$a; \
-               done; \
-       fi;
-
-       rm -f unpatch-stamp;
-       touch $@
-
-unpatch: unpatch-stamp
-unpatch-stamp:
-       dh_testdir
-
-       if [ -e debian/patches ]; then \
-               for a in `ls debian/patches/*.diff`; do \
-                       patch -f -p0 -R < $$a; \
-               done; \
-       fi;
-
-       rm -f patch-stamp
-       touch $@
-
-
-configure: configure-stamp
-configure-stamp:
-
-# SPAMC and SENDMAIL are the location of the spamc and sendmail binary, respectively. PREFIX is the location to install to.
-# We must specify --mandir because for some ungodly reason, it's being installed into /usr/man by default
-       LDFLAGS="-L/usr/lib/libmilter" SPAMC="/usr/bin/spamc" SENDMAIL="/usr/sbin/sendmail" \
-               ./configure --prefix=$(PREFIX) --mandir=$(PREFIX)/share/man
-       touch $@
-
-build: configure build-stamp
-build-stamp:
-       dh_testdir
-
-       $(MAKE)
-
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-
-       rm -f build-stamp
-       rm -f patch-stamp
-       rm -f unpatch-stamp
-       rm -f configure-stamp
-
-       if [ -e Makefile -a -e config.status ]; then \
-               $(MAKE) clean; \
-       fi
-# the clean target doesn't nuke these, so we kill them here.
-       rm -f config.log config.h config.status
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) install
-
-binary-indep:
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs ChangeLog
-       dh_installdocs NEWS README
-       dh_installman
-       dh_installinit
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-arch
-.PHONY: build clean binary-arch binary-indep binary install
+DH_VERBOSE = 1
+
+%: 
+       dh $@ --parallel
+
+override_dh_auto_configure:
+        SPAMC="/usr/bin/spamc" SENDMAIL="/usr/sbin/sendmail" \
+               dh_auto_configure;
+
+override_dh_auto_clean:
+       dh_auto_clean;
+       rm -f config.log config.status config.h Makefile
+
+# PREFIX=$(shell pwd)/debian/spamass-milter/usr
+# 
+# patch: patch-stamp
+# patch-stamp:
+#      dh_testdir
+# 
+#      if [ -e debian/patches ]; then \
+#              for a in `ls debian/patches/*.diff`; do \
+#                      patch -f -p0 < $$a; \
+#              done; \
+#      fi;
+# 
+#      rm -f unpatch-stamp;
+#      touch $@
+# 
+# unpatch: unpatch-stamp
+# unpatch-stamp:
+#      dh_testdir
+# 
+#      if [ -e debian/patches ]; then \
+#              for a in `ls debian/patches/*.diff`; do \
+#                      patch -f -p0 -R < $$a; \
+#              done; \
+#      fi;
+# 
+#      rm -f patch-stamp
+#      touch $@
+# 
+# 
+# configure: configure-stamp
+# configure-stamp:
+# 
+# # SPAMC and SENDMAIL are the location of the spamc and sendmail binary, respectively. PREFIX is the location to install to.
+# # We must specify --mandir because for some ungodly reason, it's being installed into /usr/man by default
+#      LDFLAGS="-L/usr/lib/libmilter" SPAMC="/usr/bin/spamc" SENDMAIL="/usr/sbin/sendmail" \
+#              ./configure --prefix=$(PREFIX) --mandir=$(PREFIX)/share/man
+#      touch $@
+# 
+# build: configure build-stamp
+# build-stamp:
+#      dh_testdir
+# 
+#      $(MAKE)
+# 
+#      touch $@
+# 
+# clean:
+#      dh_testdir
+#      dh_testroot
+# 
+#      rm -f build-stamp
+#      rm -f patch-stamp
+#      rm -f unpatch-stamp
+#      rm -f configure-stamp
+# 
+#      if [ -e Makefile -a -e config.status ]; then \
+#              $(MAKE) clean; \
+#      fi
+# # the clean target doesn't nuke these, so we kill them here.
+#      rm -f config.log config.h config.status
+#      dh_clean
+# 
+# install: build
+#      dh_testdir
+#      dh_testroot
+#      dh_clean -k
+#      dh_installdirs
+# 
+#      $(MAKE) install
+# 
+# binary-indep:
+# 
+# binary-arch: build install
+#      dh_testdir
+#      dh_testroot
+#      dh_installchangelogs ChangeLog
+#      dh_installdocs NEWS README
+#      dh_installman
+#      dh_installinit
+#      dh_link
+#      dh_strip
+#      dh_compress
+#      dh_fixperms
+#      dh_installdeb
+#      dh_shlibdeps
+#      dh_gencontrol
+#      dh_md5sums
+#      dh_builddeb
+# 
+# binary: binary-arch
+# .PHONY: build clean binary-arch binary-indep binary install