]> git.donarmstrong.com Git - deb_pkgs/spamass-milter.git/commitdiff
do not remove the socket if spamass milter is already running
authorDon Armstrong <don@donarmstrong.com>
Thu, 10 May 2018 20:31:13 +0000 (13:31 -0700)
committerDon Armstrong <don@donarmstrong.com>
Thu, 10 May 2018 20:45:57 +0000 (13:45 -0700)
debian/changelog
debian/rules
debian/spamass-milter.init

index a24efdfc38c9489bdc1d2b8c9fa73202ca0a1185..841160af02832f70af92b54ea021de3f232b19d6 100644 (file)
@@ -1,6 +1,9 @@
 spamass-milter (0.4.0-2) unstable; urgency=medium
 
   * Document milter env variables (closes: #816799)
+  * Do not remove the socket if spamass-milter is already running (closes:
+    #782252)
+  * Enable the hardening flags (closes: #879671)
 
  -- Don Armstrong <don@debian.org>  Thu, 10 May 2018 12:13:11 -0700
 
index 50211298557e7c6d9ec390436364559616169927..ba664ea82bfd6c1d4d19d768d0e1d58e29a3205e 100755 (executable)
@@ -1,6 +1,8 @@
 #!/usr/bin/make -f
 
 DH_VERBOSE = 1
+# enable hardening
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %: 
        dh $@ --parallel --with autotools_dev
index 310ae83ce6182856b2ac0a93c5204b58595a9438..b94fd43e70339048e9bb642dfbfce22b91f26cc3 100644 (file)
@@ -90,6 +90,10 @@ fi;
 set -e
 
 start() {
+    if status; then
+        echo "$NAME is already running";
+        exit 1;
+    fi;
     # Because the default socket is in the same location as the
     # pidfile, we create them in this order.
     for DIR in "$(dirname $PIDFILE)" "$(dirname $SOCKET)"; do