]> git.donarmstrong.com Git - deb_pkgs/spamass-milter.git/commitdiff
* Update README.Debian for postfix install instructions
authordon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Wed, 13 Sep 2006 03:38:31 +0000 (03:38 +0000)
committerdon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Wed, 13 Sep 2006 03:38:31 +0000 (03:38 +0000)
 * Create sendmail directory to allow /var/run to be on a tmpfs partition
 * Update changelog and control (do not depend on sendmail; recommend it or postfix)

debian/README.Debian
debian/changelog
debian/control
debian/spamass-milter.init

index 60e5d86622012c6f8809285e316365fd0d754643..309eb50a193039854572379acfabc15bc8c594cb 100644 (file)
@@ -34,6 +34,21 @@ See http://www.sendmail.com/partner/resources/development/milter_api/installatio
 and http://www.sendmail.org/m4/adding_mailfilters.html#INPUT_MAIL_FILTER
 for more information on milters.
 
 and http://www.sendmail.org/m4/adding_mailfilters.html#INPUT_MAIL_FILTER
 for more information on milters.
 
+--------------------------------------------------------------
+  Integrating spamass-milter into your postfix installation
+--------------------------------------------------------------
+
+You need to edit /etc/postfix/main.cf and configure smptpd_milters so
+that postfix connects to the spamass-milter socket. Something like:
+
+  # spamass-milter configuration
+  smtpd_milters = unix:/var/run/sendmail/spamass.sock
+
+should work. See http://www.postfix.org/MILTER_README.html or
+/usr/share/doc/postfix/MILTER_README.gz (in postfix-doc) for
+information on how to set tempfail and the various timeouts that the
+sendmail configuration above uses.
+
 -------------------------------------------------------------
   Adjusting how spamass-milter is started
 -------------------------------------------------------------
 -------------------------------------------------------------
   Adjusting how spamass-milter is started
 -------------------------------------------------------------
@@ -71,4 +86,4 @@ q
 
 and send the results along with your bug report using reportbug.
 
 
 and send the results along with your bug report using reportbug.
 
- -- Don Armstrong <don@donarmstrong.com>, Wed Feb  9 14:58:46 2005
+ -- Don Armstrong <don@donarmstrong.com>, Tuesday, September 12, 2006 20:24:40 PDT
index 88ce355ca50753f2408f83d18e06d1616e22945a..3497dc50bca303f011818b064e7173f9f2f5c568 100644 (file)
@@ -1,3 +1,12 @@
+spamass-milter (0.3.1-2) UNRELEASED; urgency=low
+
+  * Create /var/run/sendmail if it doesn't already exist to allow for
+    /var/run on a tmpfs (closes: #373812)
+  * Stop depending on sendmail, and begin recommending sendmail or postfix
+    (closes: #378460)
+
+ -- Don Armstrong <don@debian.org>  Wed,  5 Apr 2006 13:21:11 -0700
+
 spamass-milter (0.3.1-1) unstable; urgency=low
 
   * New upstream release
 spamass-milter (0.3.1-1) unstable; urgency=low
 
   * New upstream release
index e0f84077ff0dd5da448ac03835db0ae76b4c2701..22b9e917d80063fee62eb855abf4c8b4b19731ab 100644 (file)
@@ -1,7 +1,7 @@
 Source: spamass-milter
 Section: mail
 Priority: extra
 Source: spamass-milter
 Section: mail
 Priority: extra
-Standards-Version: 3.6.2
+Standards-Version: 3.7.2
 Build-Depends: libmilter-dev, debhelper (>= 4), groff-base
 Maintainer: Don Armstrong <don@debian.org>
 
 Build-Depends: libmilter-dev, debhelper (>= 4), groff-base
 Maintainer: Don Armstrong <don@debian.org>
 
@@ -9,13 +9,15 @@ Package: spamass-milter
 Section: mail
 Priority: extra
 Architecture: any
 Section: mail
 Priority: extra
 Architecture: any
-Depends: ${shlibs:Depends}, spamc, sendmail
-Recommends: spamassassin
-Description: sendmail milter for filtering mail through spamassassin
- A sendmail milter used to filter mail through spamassassin (spamc)
+Depends: ${shlibs:Depends}, spamc
+Recommends: spamassassin, sendmail|postfix
+Description: milter for filtering mail through spamassassin
+ A milter used to filter mail through spamassassin (spamc)
  early in the delivery process. Enables site wide filtering through
  spamassassin without speed penalties incured by setting up and
  tearing down procmail processes for each e-mail.
  early in the delivery process. Enables site wide filtering through
  spamassassin without speed penalties incured by setting up and
  tearing down procmail processes for each e-mail.
+ .
+ Will work with sendmail, postfix, or any other MTA which can use milters.
  .
   - Administrator (or user) specified rejection threshold
   - User specific spamassassin settings
  .
   - Administrator (or user) specified rejection threshold
   - User specific spamassassin settings
index fcb8611cf3c1008dc938d02ab2af5c81c30de5f1..98647d9cfafb2bdff0788f406a6c1f2b0ae4413a 100644 (file)
@@ -1,6 +1,6 @@
 #!/bin/sh
 #
 #!/bin/sh
 #
-# $Id: spamass-milter,v 1.4 2002/07/24 16:19:53 dnelson Exp $
+# $Id$
 #
 # Sample init script for Debian GNU/Linux
 #
 #
 # Sample init script for Debian GNU/Linux
 #
@@ -52,6 +52,9 @@ case "$1" in
   start)
        echo -n "Starting $DESC: "
 
   start)
        echo -n "Starting $DESC: "
 
+       if [ ! -d $(basename $SOCKET) ]; then
+           mkdir -p $(basename $SOCKET);
+       fi;
        start-stop-daemon --start -p $PIDFILE --exec $DAEMON -- -P $PIDFILE -f -p $SOCKET $OPTIONS
 
        echo "${DAEMON}"
        start-stop-daemon --start -p $PIDFILE --exec $DAEMON -- -P $PIDFILE -f -p $SOCKET $OPTIONS
 
        echo "${DAEMON}"