]> git.donarmstrong.com Git - deb_pkgs/spamass-milter.git/commitdiff
* Update milter_connect_macros_line (thanks to Marco d'Itri)
authordon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Tue, 6 Jan 2009 02:41:02 +0000 (02:41 +0000)
committerdon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Tue, 6 Jan 2009 02:41:02 +0000 (02:41 +0000)
* Fix the code to generate a sendmail-compatible header (thanks to Marco
  d'Itri) (Closes: #510665).

debian/NEWS.Debian
debian/README.Debian
debian/changelog
spamass-milter.cpp

index 5956d137b469530cc5e7be19f7aa3c6861d7d2fe..ec0469e5471df23dd5e76132f3f0fbda2d29697d 100644 (file)
@@ -1,3 +1,11 @@
+spamass-milter (0.3.1-6) unstable; urgency=low
+
+  * Note that users of postfix may wish to add "milter_connect_macros = j
+    {daemon_name} v {if_name} _" to their main.cf if they haven't already
+    done so. See README.Debian.
+
+ -- Don Armstrong <don@debian.org>  Mon, 05 Jan 2009 13:04:21 -0800
+
 spamass-milter (0.3.1-5) unstable; urgency=low
 
   * spamass-milter now tries to run as spamass-milter. This means that the
 spamass-milter (0.3.1-5) unstable; urgency=low
 
   * spamass-milter now tries to run as spamass-milter. This means that the
index c141cd87db6b9af8aeb6d0652222730fe614aa32..4c40aee53c0e782c96beeee068970cc4607a60e5 100644 (file)
@@ -53,6 +53,8 @@ chroot. In recent versions of Debian the following should work:
 
   # spamass-milter configuration
   smtpd_milters = unix:/spamass/spamass.sock
 
   # spamass-milter configuration
   smtpd_milters = unix:/spamass/spamass.sock
+  # milter macros usefull for spamass-milter
+  milter_connect_macros = j {daemon_name} v {if_name} _
 
 See http://www.postfix.org/MILTER_README.html or
 /usr/share/doc/postfix/MILTER_README.gz (in postfix-doc) for
 
 See http://www.postfix.org/MILTER_README.html or
 /usr/share/doc/postfix/MILTER_README.gz (in postfix-doc) for
@@ -60,8 +62,8 @@ information on how to set tempfail and the various timeouts that the
 sendmail configuration above uses.
 
 The defaults for spamass-milter adjust themselves so that no
 sendmail configuration above uses.
 
 The defaults for spamass-milter adjust themselves so that no
-configuration in /etc/default/milter should be required. [However, if
-you are not doing so, see below.]
+configuration in /etc/default/spamass-milter should be required.
+[However, if you are not doing so, see below.]
 
 -------------------------------------------------------------
   Adjusting how spamass-milter is started
 
 -------------------------------------------------------------
   Adjusting how spamass-milter is started
@@ -116,4 +118,4 @@ q
 
 and send the results along with your bug report using reportbug.
 
 
 and send the results along with your bug report using reportbug.
 
- -- Don Armstrong <don@debian.org>, Thu, 21 Aug 2008 16:52:22 -0700
+ -- Don Armstrong <don@debian.org>, Mon,  5 Jan 2009 13:03:36 -0800
index 1a2b935d6f0e433b0a5ba434f0e815edc1cd6eb6..5b4343ac2f881ec033c17ddebd04bc1b4929f8e1 100644 (file)
@@ -4,8 +4,11 @@ spamass-milter (0.3.1-8) UNRELEASED; urgency=low
   * Update the documentation in README.Debian to indicate that a different
     path to the postfix socket may be required in chrooted postfix
     installs (closes: #496003)
   * Update the documentation in README.Debian to indicate that a different
     path to the postfix socket may be required in chrooted postfix
     installs (closes: #496003)
+  * Update milter_connect_macros_line (thanks to Marco d'Itri)
+  * Fix the code to generate a sendmail-compatible header (thanks to Marco
+    d'Itri) (Closes: #510665).
 
 
- -- Don Armstrong <don@debian.org>  Thu, 21 Aug 2008 16:54:35 -0700
+ -- Don Armstrong <don@debian.org>  Mon, 05 Jan 2009 18:40:16 -0800
 
 spamass-milter (0.3.1-7) unstable; urgency=low
 
 
 spamass-milter (0.3.1-7) unstable; urgency=low
 
index 1b89268fcda6679dfb33bfd250f5f37d59c76ded..d4879f1b490490462bccb031f9279a04fe122d16 100644 (file)
@@ -1024,9 +1024,9 @@ mlfi_envrcpt(SMFICTX* ctx, char** envrcpt)
 
                assassin->output((string)
                        "Received: from "+macro_s+" ("+macro__+")\r\n\t"+
 
                assassin->output((string)
                        "Received: from "+macro_s+" ("+macro__+")\r\n\t"+
-                       "by "+macro_j+"("+macro_v+"/"+macro_Z+") with "+macro_r+" id "+macro_i+"\r\n\t"+
+                       "by "+macro_j+" ("+macro_v+"/"+macro_Z+") with "+macro_r+" id "+macro_i+"\r\n\t"+
                        macro_b+"\r\n\t"+
                        macro_b+"\r\n\t"+
-                       "(envelope-from "+assassin->from()+"\r\n");
+                       "(envelope-from "+assassin->from()+")\r\n");
 
        } else
                assassin->output((string)"X-Envelope-To: "+envrcpt[0]+"\r\n");
 
        } else
                assassin->output((string)"X-Envelope-To: "+envrcpt[0]+"\r\n");