]> git.donarmstrong.com Git - deb_pkgs/scowl.git/commitdiff
Fix uniqifying using dictionary order (Closes: #1003935) debian/2020.12.07-2
authorDon Armstrong <don@donarmstrong.com>
Thu, 20 Jan 2022 05:49:01 +0000 (21:49 -0800)
committerDon Armstrong <don@donarmstrong.com>
Thu, 20 Jan 2022 05:49:01 +0000 (21:49 -0800)
debian/changelog
debian/rules

index cbba9c9ad6b75cada86e6ff5a4fb3ea97feaf168..2ed6c73fc7bfb92633e17970f8f5152a57e48e9e 100644 (file)
@@ -1,3 +1,11 @@
+scowl (2020.12.07-2) unstable; urgency=medium
+
+  * Separate uniqifying from sort; users (and other plurals with
+    contractions) missing from wordlist because of this. (Closes:
+    #1003935)
+
+ -- Don Armstrong <don@debian.org>  Wed, 19 Jan 2022 21:16:40 -0800
+
 scowl (2020.12.07-1) unstable; urgency=medium
 
   * New upstream release
index 9747002c9884f32e1e788e44858862cc0f920571..a72a41e1796392f38481aba48a40d56157914533 100755 (executable)
@@ -55,7 +55,7 @@ override_dh_auto_build:
                                echo "  $${word_list}" >> w$$SPELLING$$SIZE.scowl-word-lists-used;\
                        fi;\
                done; \
-         cat $$SPELLING-english$$SIZE.unsorted | LC_ALL=C sort -ud | iconv -f 'iso8859-1' -t 'utf-8' > $$SPELLING-english$$SIZE; rm $$SPELLING-english$$SIZE.unsorted;\
+         cat $$SPELLING-english$$SIZE.unsorted | LC_ALL=C sort -d | uniq | iconv -f 'iso8859-1' -t 'utf-8' > $$SPELLING-english$$SIZE; rm $$SPELLING-english$$SIZE.unsorted;\
          done;\
        done
        cd speller && $(MAKE) hunspell