]> git.donarmstrong.com Git - deb_pkgs/scowl.git/commitdiff
* Taking over this package (Closes: #487734)
authordon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Fri, 4 Jul 2008 01:22:41 +0000 (01:22 +0000)
committerdon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Fri, 4 Jul 2008 01:22:41 +0000 (01:22 +0000)
* Fix the building of -huge binaries (Closes: #346113) [Thanks to Jason
  Rhinelander <jagerman@jagerman.com> for a patch, though I actually
  implemented myself without seeing his.]

git-svn-id: svn+ssh://svn.donarmstrong.com/sites/don_svn/deb_pkgs/scowl/trunk@373 8f7917da-ec0b-0410-a553-b9b0e350d17e

debian/changelog
debian/control
debian/rules

index 20533a21a54fdc20bf5cda5f62621cd3a1e8472a..8f08605b1593a67f66e76cb21626d2968a708491 100644 (file)
@@ -1,3 +1,12 @@
+scowl (6-2.3) unstable; urgency=low
+
+  * Taking over this package (Closes: #487734)
+  * Fix the building of -huge binaries (Closes: #346113) [Thanks to Jason
+    Rhinelander <jagerman@jagerman.com> for a patch, though I actually
+    implemented myself without seeing his.]
+  
+ -- Don Armstrong <don@debian.org>  Thu, 03 Jul 2008 18:16:08 -0700
+
 scowl (6-2.2) unstable; urgency=low
 
   * Non-maintainer upload.
index a374b71223567fe118996f791b183572747686cd..ad9a8ff35384f57f1bf575ebca4cc774b97b7620 100644 (file)
@@ -1,9 +1,9 @@
 Source: scowl
-Maintainer: David Coe <davidc@debian.org>
+Maintainer: Don Armstrong <don@debian.org>
 Section: text
 Priority: standard
 Standards-Version: 3.7.3
-Build-Depends: debhelper (>=5)
+Build-Depends: debhelper (>= 5)
 Build-Depends-Indep: dictionaries-common-dev (>=0.20)
 
 Package: scowl
index d00537b09c4f93b1c561f7d5af61518cc6fdc7ef..49d4e60371ed44fe6c6a2542bed06c27228dbe9d 100755 (executable)
@@ -16,10 +16,15 @@ export DH_OPTIONS
 # The medium size packages have no -size part in their names
 # These are the scowl extensions (complexity numbers?) that contribute to each word list (i.e. each size);
 # the -size parts "-small", "", "-large", and "-huge" correspond to the end of the binary package name:
-export SIZE_EXTENSIONS-small:=10 20 35
-export SIZE_EXTENSIONS:=$(SIZE_EXTENSIONS-small) 40 50
-export SIZE_EXTENSIONS-large:=$(SIZE_EXTENSIONS) 55 60 70
-export SIZE_EXTENSIONS-huge:=$(SIZE_EXTENSIONS-large) 80
+SIZE_EXTENSIONS_small:=10 20 35
+SIZE_EXTENSIONS:=$(SIZE_EXTENSIONS_small) 40 50
+SIZE_EXTENSIONS_large:=$(SIZE_EXTENSIONS) 55 60 70
+SIZE_EXTENSIONS_huge:=$(SIZE_EXTENSIONS_large) 80 95
+#SIZE_EXTENSIONS-huge:=10 20 35 40 50 55 60 70 80 95
+export SIZE_EXTENSIONS_small
+export SIZE_EXTENSIONS
+export SIZE_EXTENSIONS_large
+export SIZE_EXTENSIONS_huge
 
 # These are the scowl word list classes we use:
 CLASSES:=words proper-names upper contractions
@@ -31,11 +36,13 @@ build-stamp:
 
        set -e;\
        for SPELLING in american british canadian; do\
-         for SIZE in -small "" -large -huge; do\
+         for SIZE in small "" large huge; do\
+           if [ -n "$$SIZE" ]; then SIZE_NAME="_$$SIZE"; SIZE="-$$SIZE"; else SIZE_NAME=""; SIZE=""; fi; \
            echo "The following SCOWL word lists were concatenated and sorted (with duplicates" > w$$SPELLING$$SIZE.scowl-word-lists-used;\
            echo "removed) to create this word list (see README.Debian for more details):" >> w$$SPELLING$$SIZE.scowl-word-lists-used;\
            for CLASS in $(CLASSES); do\
-             for EXT in $$(eval echo \\$$SIZE_EXTENSIONS$$SIZE); do\
+             for EXT in $$(eval echo "\$$""SIZE_EXTENSIONS$$SIZE_NAME"); do\
+               echo "class $$CLASS ext $$EXT size name $$SIZE_NAME"; \
                if [ -f final/english-$$CLASS.$$EXT ]; then\
                  echo "cat final/english-$$CLASS.$$EXT >> $$SPELLING-english$$SIZE.unsorted";\
                  cat final/english-$$CLASS.$$EXT >> $$SPELLING-english$$SIZE.unsorted;\
@@ -175,27 +182,9 @@ binary-common:
        dh_testdir
        dh_testroot
        dh_installchangelogs
-#      dh_installdocs    # moved to the install targets, because it doesn't DWIM with "-A -p scowl README"
-#      dh_installexamples
-#      dh_installmenu
-#      dh_installdebconf
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installcatalogs
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installman
-#      dh_installcron
-#      dh_installinfo
-#      dh_undocumented
-#      dh_strip
        dh_link
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_python
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
@@ -208,8 +197,6 @@ binary-indep: build install
 
 # Build architecture dependant packages using the common target.
 binary-arch: build install
-# (Uncomment this next line if you have such packages.)
-#      $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
 
 # Any other binary targets build just one binary package at a time.
 binary-%: build install