]> git.donarmstrong.com Git - deb_pkgs/scowl.git/blobdiff - speller/Makefile
Imported Upstream version 2015.08.24
[deb_pkgs/scowl.git] / speller / Makefile
diff --git a/speller/Makefile b/speller/Makefile
new file mode 100644 (file)
index 0000000..cf51c14
--- /dev/null
@@ -0,0 +1,21 @@
+
+all: 
+       @echo "Please use hunspell or aspell as target"
+
+.aspell: make-aspell-dict
+       make -C src deaccent
+       ./make-aspell-dict
+       touch .aspell
+aspell: .aspell
+
+.hunspell: make-hunspell-dict add-no-suggest en.aff en.dic.supp README_en.txt.sh
+       ./make-hunspell-dict -all
+       touch .hunspell
+hunspell: .hunspell
+
+clean:
+       rm -rf hunspell/ *.zip
+       cat to-clean | xargs rm -f
+
+to-clean: .gitignore
+       echo `cat .gitignore | grep -v '^#'` | tr ' ' '\n' | grep -v hunspell/ | grep -v \.zip > to-clean