]> git.donarmstrong.com Git - deb_pkgs/libhtml-calendarmonth-perl.git/commitdiff
* Fix FTBFS caused by new version of Date::Manip (closes: 571421) debian/1.19-2
authorDon Armstrong <don@donarmstrong.com>
Fri, 26 Feb 2010 22:40:48 +0000 (22:40 +0000)
committerDon Armstrong <don@donarmstrong.com>
Fri, 26 Feb 2010 22:40:48 +0000 (22:40 +0000)
* Bumb standards version; no changes needed
* Require debhelper 7
* Fix some minor POD errors

debian/changelog
debian/compat
debian/control
debian/rules
lib/HTML/CalendarMonth.pm
lib/HTML/CalendarMonth/DateTool/DateManip.pm
lib/HTML/CalendarMonth/Locale.pm

index f3501874f702951adfb35cee3116513d907dfeba..320eae1544ee6203960a7af27a133fb08c0e2d49 100644 (file)
@@ -1,3 +1,12 @@
+libhtml-calendarmonth-perl (1.19-2) unstable; urgency=low
+
+  * Fix FTBFS caused by new version of Date::Manip (closes: 571421)
+  * Bumb standards version; no changes needed
+  * Require debhelper 7
+  * Fix some minor POD errors
+
+ -- Don Armstrong <don@debian.org>  Fri, 26 Feb 2010 13:08:35 -0800
+
 libhtml-calendarmonth-perl (1.19-1) unstable; urgency=low
 
   * New upstream release
index b8626c4cff2849624fb67f87cd0ad72b163671ad..7f8f011eb73d6043d2e6db9d2c101195ae2801f2 100644 (file)
@@ -1 +1 @@
-4
+7
index 3cfb47821e9908a17d9a229f453d3f7da63b6a55..afa10962b24f615572cf57dab70a35333e2aca00 100644 (file)
@@ -1,16 +1,17 @@
 Source: libhtml-calendarmonth-perl
 Section: perl
 Priority: extra
-Standards-Version: 3.8.0
+Standards-Version: 3.8.4
 Maintainer: Don Armstrong <don@debian.org>
-Build-Depends: debhelper (>= 4)
+Build-Depends: debhelper (>= 7)
 Build-Depends-Indep: libhtml-element-extended-perl (>=1.15-0), libdatetime-locale-perl, libclass-accessor-perl, libdate-calc-perl, libdate-manip-perl, libdatetime-perl
 
 Package: libhtml-calendarmonth-perl
-Section: perl
-Priority: extra
 Architecture: all
-Depends: ${perl:Depends}, libhtml-element-extended-perl (>=1.15-0), libdatetime-locale-perl, libdate-calc-perl|libdate-manip-perl|libdatetime-perl, libclass-accessor-perl
+Depends: ${perl:Depends}, ${misc:Depends}, libhtml-element-extended-perl (>=1.15-0), libdatetime-locale-perl, libdate-calc-perl|libdate-manip-perl|libdatetime-perl, libclass-accessor-perl
 Description: generate and manipulate calandar months in HTML
  This module enables you to generate and manipulate calendar
  months in HTML.
+ .
+ Useful for making calendars to display in web pages and other similar
+ tasks.
index 627e74d564487e3b8e9abb05bb9c2534105dffe7..c5814f2049edc546eb012f4d3fc00e4457d8c033 100755 (executable)
@@ -33,7 +33,7 @@ clean:
 install: build test
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        $(MAKE) install PREFIX=$(DESTDIR)/usr
index 7ae7ae854f882a2a6ab1f1e08882720de26e0802..8d4445647c685f787c2780f92630504da2e0f021 100644 (file)
@@ -968,10 +968,10 @@ DateTime::Locale->ids().
 All arguments appearing in [brackets] are optional, and do not represent
 anonymous array references.
 
-=over
-
 B<Constructor>
 
+=over
+
 =item new()
 
 With no arguments, the constructor will return a calendar object
index 882aed69b970b58118f20f13044e4fafc759575d..3ed893c1163ad0705e4803e8ae56eff7a7eac6d0 100644 (file)
@@ -52,7 +52,7 @@ sub add_days {
   $month ||= $self->month;
   $year  ||= $self->year;
   my $date = DateCalc(sprintf("%04d%02d%02d", $year, $month, $day),
-                      "+ $delta days");
+                      ($delta < 0 ? '':'+')." $delta days");
   my($y, $m, $d) = $date =~ /^(\d{4})(\d\d)(\d\d)/;
   $_ += 0 foreach ($y, $m, $d);
   ($d, $m, $y);
index bb45bb3755d00aaa356e388173a7bd6c86043cef..063db739e23dd1953fb7e5d17f47f052f9496aa1 100644 (file)
@@ -201,12 +201,12 @@ developers:
 
 =head1 METHODS
 
+=over
+
 =item new()
 
 Constructor. Takes the following parameters:
 
-=over
-
 =item id
 
 Locale id, e.g. 'en_US'.
@@ -221,8 +221,6 @@ Default 0, use abbreviated days.
 Specifies whether full month names or their abbreviations are desired.
 Default 1, use full months.
 
-=back
-
 =item id()
 
 Returns the locale id used during object construction.
@@ -287,6 +285,8 @@ This is the method used to generate the minimal match hash referenced
 above. Given an arbitrary list, a hash reference will be returned with
 minimal match strings as keys and full names as values.
 
+=back
+
 =head1 AUTHOR
 
 Matthew P. Sisk, E<lt>F<sisk@mojotoad.com>E<gt>