]> git.donarmstrong.com Git - deb_pkgs/libhtml-calendarmonth-perl.git/commitdiff
Load /home/don/tmp/tmp.QFHG70/libhtml-calendarmonth-perl-1.18 into
authorDon Armstrong <don@donarmstrong.com>
Wed, 1 Mar 2006 04:26:06 +0000 (04:26 +0000)
committerDon Armstrong <don@donarmstrong.com>
Wed, 1 Mar 2006 04:26:06 +0000 (04:26 +0000)
libhtml-calendarmonth-perl/branches/upstream/current.

current/Changes
current/META.yml
current/Makefile.PL
current/lib/HTML/CalendarMonth.pm
current/lib/HTML/CalendarMonth/DateTool/DateCalc.pm
current/t/testload.pm

index c27997a3695eafbe4d57ea6d514484a6389aa335..7f67f72b5a086465b3f701cbbbd2067b23d6d499 100644 (file)
@@ -1,5 +1,11 @@
 Revision history for Perl extension HTML-CalendarMonth.
 
+1.18  Fri Feb 24 15:53:41 EST 2006
+        - Fixed some scoping issues in DateTool/DateCalc.pm (thanks
+          Carl Franks)
+        - Fixed a Win32 test module location issue (File::Spec tricks)
+          (thanks Carl Franks)
+
 1.17  Fri Jan  6 16:09:46 EST 2006
         - Updated tests with more recent test cases
 
index 7900645a65b7511a787b1fc36f8b3e7d856bed24..2048e068bf7578ad837d009d0d903ed0701fde1f 100644 (file)
@@ -1,13 +1,14 @@
 # http://module-build.sourceforge.net/META-spec.html
 #XXXXXXX This is a prototype!!!  It will change in the future!!! XXXXX#
 name:         HTML-CalendarMonth
-version:      1.17
+version:      1.18
 version_from: lib/HTML/CalendarMonth.pm
 installdirs:  site
 requires:
     Class::Accessor:               0
     DateTime::Locale:              0
-    HTML::ElementTable:            1.13
+    File::Spec:                    0
+    HTML::ElementTable:            1.15
     Time::Local:                   0
 
 distribution_type: module
index 2bc6c3cb4e34e636a010758dff3c0352457503de..c293ba754543953e913bd644a4b1d31e59ef3437 100644 (file)
@@ -43,9 +43,10 @@ WriteMakefile(
               VERSION_FROM => 'lib/HTML/CalendarMonth.pm',
               PREREQ_PM    => {
                                Time::Local        => 0,
-                               HTML::ElementTable => 1.13,
+                               HTML::ElementTable => 1.15,
                                DateTime::Locale   => 0,
                                Class::Accessor    => 0,
+                               File::Spec         => 0,
                               },
               dist         => {
                                COMPRESS => 'gzip -9f',
index 70d1bbec5e120fc17ba491d6ce778ed7ef9e38b4..a3dd380fe1c1e74cc31891c329b379a2d364475f 100644 (file)
@@ -3,11 +3,11 @@ package HTML::CalendarMonth;
 use strict;
 use vars qw($VERSION @ISA);
 
-$VERSION = '1.17';
+$VERSION = '1.18';
 
 use Carp;
 
-use HTML::ElementTable 1.13;
+use HTML::ElementTable 1.15;
 use HTML::CalendarMonth::Locale;
 use HTML::CalendarMonth::DateTool;
 
index 97db69135b85ea27cd0a2580636c38a809f4de32..17c3ed5dea5c9c5cb032b138baaa14cf591e1649 100644 (file)
@@ -9,7 +9,7 @@ use vars qw(@ISA $VERSION);
 
 @ISA = qw(HTML::CalendarMonth::DateTool);
 
-$VERSION = '0.01';
+$VERSION = '0.02';
 
 use Date::Calc qw(Days_in_Month Day_of_Week Add_Delta_Days
                   Weeks_in_Year Week_of_Year Week_Number Mktime
@@ -58,7 +58,8 @@ sub week_of_year {
   $day || croak "Day required.\n";
   $month ||= $self->month;
   $year  ||= $self->year;
-  my($week, $year) = Week_of_Year($year, $month, $day);
+  my $week;
+  ($week, $year) = Week_of_Year($year, $month, $day);
   ($year, $week);
 }
 
index d822ee7742b564ace66c3d17cf7e2b5c853c89bb..cfb25461c66926d8924f4d24788b031ab27fc30e 100644 (file)
@@ -19,21 +19,23 @@ use File::Spec;
 use HTML::CalendarMonth;
 use HTML::CalendarMonth::DateTool;
 
-my $base_dir;
+my($base_dir, $vol, $dir);
 BEGIN {
   my $pkg = __PACKAGE__;
   $pkg =~ s%::%/%g;
   $pkg .= '.pm';
   $pkg = File::Spec->canonpath($INC{$pkg});
-  $pkg =~ s/\/[^\/]+\.pm$//;
-  $base_dir = $pkg;
+  my $file;
+  ($vol, $dir, $file) = File::Spec->splitpath($pkg);
+  $base_dir = File::Spec->catpath($vol, $dir);
 }
 $Dat_Dir = $base_dir;
 
 my($tcount, $rds, %dates, @tmethods, @twy_methods, @Cals);
 
 # Required test dates
-open(D, "$Dat_Dir/test.dat") or die "Problem reading $Dat_Dir/test.dat: $!\n";
+my $dat_file = File::Spec->catpath($vol, $dir, 'test.dat');
+open(D, "<$dat_file") or die "Problem reading $dat_file: $!\n";
 $rds = <D>;
 foreach (split(' ', $rds)) {
   ++$dates{$_};