]> git.donarmstrong.com Git - deb_pkgs/libhtml-calendarmonth-perl.git/commitdiff
* Add 1.18 HTML::CalendarMonth upgrade
authorDon Armstrong <don@donarmstrong.com>
Wed, 1 Mar 2006 04:30:48 +0000 (04:30 +0000)
committerDon Armstrong <don@donarmstrong.com>
Wed, 1 Mar 2006 04:30:48 +0000 (04:30 +0000)
Changes
META.yml
Makefile.PL
debian/changelog
debian/control
lib/HTML/CalendarMonth.pm
lib/HTML/CalendarMonth/DateTool/DateCalc.pm
t/testload.pm

diff --git a/Changes b/Changes
index c27997a3695eafbe4d57ea6d514484a6389aa335..7f67f72b5a086465b3f701cbbbd2067b23d6d499 100644 (file)
--- a/Changes
+++ b/Changes
@@ -1,5 +1,11 @@
 Revision history for Perl extension HTML-CalendarMonth.
 
+1.18  Fri Feb 24 15:53:41 EST 2006
+        - Fixed some scoping issues in DateTool/DateCalc.pm (thanks
+          Carl Franks)
+        - Fixed a Win32 test module location issue (File::Spec tricks)
+          (thanks Carl Franks)
+
 1.17  Fri Jan  6 16:09:46 EST 2006
         - Updated tests with more recent test cases
 
index 7900645a65b7511a787b1fc36f8b3e7d856bed24..2048e068bf7578ad837d009d0d903ed0701fde1f 100644 (file)
--- a/META.yml
+++ b/META.yml
@@ -1,13 +1,14 @@
 # http://module-build.sourceforge.net/META-spec.html
 #XXXXXXX This is a prototype!!!  It will change in the future!!! XXXXX#
 name:         HTML-CalendarMonth
-version:      1.17
+version:      1.18
 version_from: lib/HTML/CalendarMonth.pm
 installdirs:  site
 requires:
     Class::Accessor:               0
     DateTime::Locale:              0
-    HTML::ElementTable:            1.13
+    File::Spec:                    0
+    HTML::ElementTable:            1.15
     Time::Local:                   0
 
 distribution_type: module
index 2bc6c3cb4e34e636a010758dff3c0352457503de..c293ba754543953e913bd644a4b1d31e59ef3437 100644 (file)
@@ -43,9 +43,10 @@ WriteMakefile(
               VERSION_FROM => 'lib/HTML/CalendarMonth.pm',
               PREREQ_PM    => {
                                Time::Local        => 0,
-                               HTML::ElementTable => 1.13,
+                               HTML::ElementTable => 1.15,
                                DateTime::Locale   => 0,
                                Class::Accessor    => 0,
+                               File::Spec         => 0,
                               },
               dist         => {
                                COMPRESS => 'gzip -9f',
index a6666b734322f029ea8c4594251ee565b9ec424b..99cc2abb25a65005e68984e3ebc7e4cf5622ba50 100644 (file)
@@ -1,3 +1,9 @@
+libhtml-calendarmonth-perl (1.18-1) UNRELEASED; urgency=low
+
+  * (NOT RELEASED YET) New upstream release
+
+ -- Don Armstrong <don@debian.org>  Tue, 28 Feb 2006 20:26:10 -0800
+
 libhtml-calendarmonth-perl (1.17-1) unstable; urgency=low
 
   * New upstream release
index be72803602491c4ca3ba53528629ee02120acd92..ab9c92fc96603dfe9b2fbb2e768304b5e38a5911 100644 (file)
@@ -3,13 +3,13 @@ Section: perl
 Priority: optional
 Standards-Version: 3.6.2
 Maintainer: Don Armstrong <don@debian.org>
-Build-Depends-Indep: libhtml-element-extended-perl (>=1.11-0), debhelper (>= 3.0.18), libdatetime-locale-perl, libclass-accessor-perl, libdate-calc-perl, libdate-manip-perl, libdatetime-perl
+Build-Depends-Indep: libhtml-element-extended-perl (>=1.15-0), debhelper (>= 3.0.18), libdatetime-locale-perl, libclass-accessor-perl, libdate-calc-perl, libdate-manip-perl, libdatetime-perl
 
 Package: libhtml-calendarmonth-perl
 Section: perl
 Priority: optional
 Architecture: all
-Depends: ${perl:Depends}, libhtml-element-extended-perl (>=1.11-0), libdatetime-locale-perl, libdate-calc-perl|libdate-manip-perl|libdatetime-perl, libclass-accessor-perl
+Depends: ${perl:Depends}, libhtml-element-extended-perl (>=1.15-0), libdatetime-locale-perl, libdate-calc-perl|libdate-manip-perl|libdatetime-perl, libclass-accessor-perl
 Description: generate and manipulate calandar months in HTML
  This module enables you to generate and manipulate calendar
  months in HTML.
index 70d1bbec5e120fc17ba491d6ce778ed7ef9e38b4..a3dd380fe1c1e74cc31891c329b379a2d364475f 100644 (file)
@@ -3,11 +3,11 @@ package HTML::CalendarMonth;
 use strict;
 use vars qw($VERSION @ISA);
 
-$VERSION = '1.17';
+$VERSION = '1.18';
 
 use Carp;
 
-use HTML::ElementTable 1.13;
+use HTML::ElementTable 1.15;
 use HTML::CalendarMonth::Locale;
 use HTML::CalendarMonth::DateTool;
 
index 5a8408751f0c60af59b8e47ab4b10a23ca70fcc3..17c3ed5dea5c9c5cb032b138baaa14cf591e1649 100644 (file)
@@ -9,7 +9,7 @@ use vars qw(@ISA $VERSION);
 
 @ISA = qw(HTML::CalendarMonth::DateTool);
 
-$VERSION = '0.01';
+$VERSION = '0.02';
 
 use Date::Calc qw(Days_in_Month Day_of_Week Add_Delta_Days
                   Weeks_in_Year Week_of_Year Week_Number Mktime
index d822ee7742b564ace66c3d17cf7e2b5c853c89bb..cfb25461c66926d8924f4d24788b031ab27fc30e 100644 (file)
@@ -19,21 +19,23 @@ use File::Spec;
 use HTML::CalendarMonth;
 use HTML::CalendarMonth::DateTool;
 
-my $base_dir;
+my($base_dir, $vol, $dir);
 BEGIN {
   my $pkg = __PACKAGE__;
   $pkg =~ s%::%/%g;
   $pkg .= '.pm';
   $pkg = File::Spec->canonpath($INC{$pkg});
-  $pkg =~ s/\/[^\/]+\.pm$//;
-  $base_dir = $pkg;
+  my $file;
+  ($vol, $dir, $file) = File::Spec->splitpath($pkg);
+  $base_dir = File::Spec->catpath($vol, $dir);
 }
 $Dat_Dir = $base_dir;
 
 my($tcount, $rds, %dates, @tmethods, @twy_methods, @Cals);
 
 # Required test dates
-open(D, "$Dat_Dir/test.dat") or die "Problem reading $Dat_Dir/test.dat: $!\n";
+my $dat_file = File::Spec->catpath($vol, $dir, 'test.dat');
+open(D, "<$dat_file") or die "Problem reading $dat_file: $!\n";
 $rds = <D>;
 foreach (split(' ', $rds)) {
   ++$dates{$_};