]> git.donarmstrong.com Git - deb_pkgs/libhtml-calendarmonth-perl.git/commitdiff
* Fix test comparsion to handle changes in HTML::Table (closes: #420048) debian/1.18-2
authorDon Armstrong <don@donarmstrong.com>
Tue, 24 Apr 2007 20:05:41 +0000 (20:05 +0000)
committerDon Armstrong <don@donarmstrong.com>
Tue, 24 Apr 2007 20:05:41 +0000 (20:05 +0000)
debian/changelog
t/20_i8n.t
t/testload.pm

index 299b1cd80a68ea57bc11bb2608d61f23cf7a2835..c47c3b0ba6eadf477df79e2c7e1a2dd54da44634 100644 (file)
@@ -1,9 +1,9 @@
-libhtml-calendarmonth-perl (1.18-2) UNRELEASED; urgency=low
+libhtml-calendarmonth-perl (1.18-2) unstable; urgency=low
 
-  * NOT RELEASED YET
+  * Fix test comparsion to handle changes in HTML::Table (closes: #420048)
   * Add missing = in HTML::CalenderMonth pod (closes: #394126)
 
- -- Don Armstrong <don@debian.org>  Fri, 26 May 2006 14:57:06 -0700
+ -- Don Armstrong <don@debian.org>  Mon, 23 Apr 2007 17:51:26 -0700
 
 libhtml-calendarmonth-perl (1.18-1) unstable; urgency=low
 
index e59361fcf6db2c898e91cd8c423871fe7612c859..adff29ee249a89824469237e7d9318d0064073ec 100755 (executable)
@@ -23,6 +23,7 @@ my $b = HTML::CalendarMonth->new(
 );
 my $bstr = $b->as_HTML;
 chomp($bstr);
+$bstr =~ s/\=\"(\d+)\"/=$1/g;
 cmp_ok($bstr, 'eq', $basque, "i8n: ($year/$month : Basque) using auto-detect");
 
 __DATA__
index cfb25461c66926d8924f4d24788b031ab27fc30e..63a2bb4a3335603b04c7fa8ab422b4c8c28f6433 100644 (file)
@@ -88,8 +88,11 @@ sub check_basic_with_datetool {
       week_begin => $cal->[3],
       datetool   => $datetool,
     );
+    # Because HTML::TreeBuilder has changed a few times, this can't be exactly equal
+    my $gen_html = $c->as_HTML;
+    $gen_html =~ s/\=\"(\d+)\"/=$1/g;
     my $day1 = $days[$cal->[3] - 1];
-    cmp_ok($c->as_HTML, 'eq', $cal->[2],
+    cmp_ok($gen_html, 'eq', $cal->[2],
        sprintf("(%d/%-02d %s 1st day) using %s",
                $cal->[0], $cal->[1], $day1, $method));
     if ($DEBUG && $c->as_HTML ne $cal->[2]) {
@@ -111,6 +114,7 @@ sub check_woy_with_datetool {
     );
     my $ct = $cal->as_HTML;
     chomp $ct;
+    $ct =~ s/\=\"(\d+)\"/=$1/g;
     cmp_ok($ct, 'eq', $tc, "($year/$month week of year) using $datetool");
     if ($DEBUG && $ct ne $tc) {
       debug_dump('Broken', $ct, 'Test Data', $tc);