]> git.donarmstrong.com Git - deb_pkgs/libhtml-calendarmonth-perl.git/commitdiff
Load libhtml-calendarmonth-perl-1.16 into
authorDon Armstrong <don@donarmstrong.com>
Sat, 4 Feb 2006 00:23:08 +0000 (00:23 +0000)
committerDon Armstrong <don@donarmstrong.com>
Sat, 4 Feb 2006 00:23:08 +0000 (00:23 +0000)
libhtml-calendarmonth-perl/trunk.

debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/rules [new file with mode: 0755]
debian/watch [new file with mode: 0644]
lib/HTML/CalendarMonth/DateTool/DateCalc.pm
t/test.dat

diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..4c1dd95
--- /dev/null
@@ -0,0 +1,18 @@
+libhtml-calendarmonth-perl (1.16-1) unstable; urgency=low
+
+  * New upstream release
+
+ -- Don Armstrong <don@debian.org>  Wed,  4 Jan 2006 16:23:00 -0800
+
+libhtml-calendarmonth-perl (1.15-1) unstable; urgency=low
+
+  * New upstream release (Closes: #329554)
+  * patch lib/HTML/CalendarMonth.pm to fix the useless use of + in void context warning
+
+ -- Don Armstrong <don@debian.org>  Sun, 25 Sep 2005 03:35:12 -0700
+
+libhtml-calendarmonth-perl (1.09-1) unstable; urgency=low 
+
+  * First Packaging (Closes: #150121).
+
+ -- Don Armstrong <don@donarmstrong.com>  Mon, 10 Jun 2002 21:53:52  -0700
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..b8626c4
--- /dev/null
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..b0eb355
--- /dev/null
@@ -0,0 +1,15 @@
+Source: libhtml-calendarmonth-perl
+Section: text
+Priority: optional
+Standards-Version: 3.5.6.1
+Maintainer: Don Armstrong <don@debian.org>
+Build-Depends-Indep: libhtml-element-extended-perl (>=1.11-0), debhelper (>= 3.0.18), libdatetime-locale-perl, libclass-accessor-perl, libdate-calc-perl, libdate-manip-perl, libdatetime-perl
+
+Package: libhtml-calendarmonth-perl
+Section: text
+Priority: optional
+Architecture: all
+Depends: ${perl:Depends}, libhtml-element-extended-perl (>=1.11-0), libdatetime-locale-perl, libdate-calc-perl|libdate-manip-perl|libdatetime-perl, libclass-accessor-perl
+Description: generate and manipulate calandar months in HTML.
+ This module enables you to generate and manipulate calendar
+ months in HTML.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..3aa995d
--- /dev/null
@@ -0,0 +1,10 @@
+Author: Mathew P. Sisk <sisk@mojotoad.com>
+Webpage: http://www.mojotoad.com/sisk/projects/HTML-CalendarMonth/
+Download: http://www.cpan.org/authors/id/M/MS/MSISK/HTML-CalendarMonth-1.15.tar.gz
+Debianized: Don Armstrong <don@debian.org> Sun, 23 Jun 2002 01:47:35 -0700
+
+Copyright: Copyright (c) 1999-2002 Matthew P. Sisk.  All rights
+reserved.  All wrongs revenged. This program is free software; you can
+redistribute it and/or modify it under the same terms as Perl itself.
+
+License: GPL, Artistic, available at /usr/share/common-licenses/{GPL,Artistic}
\ No newline at end of file
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..13b11fe
--- /dev/null
@@ -0,0 +1,65 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DESTDIR=$(CURDIR)/debian/$(shell dh_listpackages|head -n 1)
+
+build: build-stamp
+build-stamp:
+       dh_testdir
+
+       perl Makefile.PL INSTALLDIRS=vendor
+       $(MAKE)
+
+       touch $@
+
+test: test-stamp
+test-stamp:
+       dh_testdir
+       $(MAKE) test
+       touch $@
+
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp test-stamp
+
+       if [ -e Makefile ]; then $(MAKE) distclean; fi
+
+       dh_clean
+
+install: build test
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+
+       $(MAKE) install PREFIX=$(DESTDIR)/usr
+       rmdir -p $(DESTDIR)/usr/lib/perl5 || true
+
+# Build architecture-independent files here.
+binary-indep: install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs
+       dh_installdocs
+       dh_installexamples
+       dh_installman
+       dh_link
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_perl
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/watch b/debian/watch
new file mode 100644 (file)
index 0000000..2cdbe9b
--- /dev/null
@@ -0,0 +1,3 @@
+# format version number, currently 2; this line is compulsory!
+version=2
+http://www.perl.com/CPAN/authors/id/M/MS/MSISK/HTML-CalendarMonth-([\d\.]+).tar.gz
index 97db69135b85ea27cd0a2580636c38a809f4de32..5a8408751f0c60af59b8e47ab4b10a23ca70fcc3 100644 (file)
@@ -58,7 +58,8 @@ sub week_of_year {
   $day || croak "Day required.\n";
   $month ||= $self->month;
   $year  ||= $self->year;
-  my($week, $year) = Week_of_Year($year, $month, $day);
+  my $week;
+  ($week, $year) = Week_of_Year($year, $month, $day);
   ($year, $week);
 }
 
index 34eafcaa6b95e387f0f450ec07a74608bbf15fae..979afc2f2b829b9b6a5ef00ca225bce625b90831 100644 (file)
@@ -1,4 +1,4 @@
-2000/10 2000/12 2002/03
+2000/10 2000/12 2002/03 2002/04 2003/02 2003/05 2004/02 2004/03 2004/09 2004/12 2005/01 2005/02 2005/03 2005/09 2005/11
 2000/10 2
 <table bgcolor="white" border=1 cellpadding=0 cellspacing=0><tr align="center"><td align="left" colspan=5>October</td><td align="center" colspan=2>2000</td></tr><tr align="center"><td align="center">Mon</td><td align="center">Tue</td><td align="center">Wed</td><td align="center">Thu</td><td align="center">Fri</td><td align="center">Sat</td><td align="center">Sun</td></tr><tr align="center"><td align="center">&nbsp; </td><td align="center">&nbsp; </td><td align="center">&nbsp; </td><td align="center">&nbsp; </td><td align="center">&nbsp; </td><td align="center">&nbsp; </td><td align="center">1</td></tr><tr align="center"><td align="center">2</td><td align="center">3</td><td align="center">4</td><td align="center">5</td><td align="center">6</td><td align="center">7</td><td align="center">8</td></tr><tr align="center"><td align="center">9</td><td align="center">10</td><td align="center">11</td><td align="center">12</td><td align="center">13</td><td align="center">14</td><td align="center">15</td></tr><tr align="center"><td align="center">16</td><td align="center">17</td><td align="center">18</td><td align="center">19</td><td align="center">20</td><td align="center">21</td><td align="center">22</td></tr><tr align="center"><td align="center">23</td><td align="center">24</td><td align="center">25</td><td align="center">26</td><td align="center">27</td><td align="center">28</td><td align="center">29</td></tr><tr align="center"><td align="center">30</td><td align="center">31</td><td align="center">&nbsp; </td><td align="center">&nbsp; </td><td align="center">&nbsp; </td><td align="center">&nbsp; </td><td align="center">&nbsp; </td></tr></table>
 2000/12 2