]> git.donarmstrong.com Git - deb_pkgs/libapache-gallery-perl.git/commitdiff
[svn-inject] Applying Debian modifications (0.99-svn060811-1) to trunk
authorDon Armstrong <don@donarmstrong.com>
Wed, 16 Mar 2011 15:57:42 +0000 (15:57 +0000)
committerDon Armstrong <don@donarmstrong.com>
Wed, 16 Mar 2011 15:57:42 +0000 (15:57 +0000)
git-svn-id: file:///srv/don_svn/deb_pkgs/libapache-gallery-perl/trunk@537 8f7917da-ec0b-0410-a553-b9b0e350d17e

debian/README.Debian [new file with mode: 0644]
debian/changelog [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/cron.daily [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/rules [new file with mode: 0755]

diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644 (file)
index 0000000..06b0f74
--- /dev/null
@@ -0,0 +1,125 @@
+libapache-gallery-perl for Debian
+---------------------------------
+
+Read more to learn how to integrate Apache::Gallery in the Apache Web Server.
+You have to complete all the steps described in this README file.
+
+1. Configure your Apache server
+
+1.1 Apache 1.3
+
+You need to configure your virtualhost block to look like:
+
+<VirtualHost *>
+       ServerName   gallery.yourdomain.org
+       DocumentRoot /data/pictures/
+       ErrorLog     logs/gallery-error_log
+       TransferLog  logs/gallery-access_log
+       PerlSetVar   GalleryTemplateDir '/usr/share/libapache-gallery-perl/templates/default'
+       PerlSetVar   GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
+       PerlSetVar   GallerySizes '640 1024 1600 2272'
+       PerlSetVar   GalleryThumbnailSize '100x75'
+       PerlSetVar   GalleryCopyrightImage 'htdocs/c.png'
+       <Location />
+           SetHandler  perl-script
+           PerlHandler Apache::Gallery
+       </Location>
+</VirtualHost>
+
+NOTICE: Although stated by the original author of Apache::Gallery, some users
+have reported it is not longer true that Apache::Gallery does not work with
+mod_autoindex. If you experience problems, with your gallery, please, follow
+this instructions:
+
+WARNING: Apache::Gallery might not work properly if mod_autoindex is loaded by
+Apache. Indeed, mod_autoindex might override Apache::Gallery and might not let
+it display directory content. 
+
+To check if your apache loads mod_autoindex, just look for this line in
+httpd.conf:
+
+LoadModule autoindex_module /usr/lib/apache/1.3/mod_autoindex.so
+
+If this line is not commented, Apache::Gallery might only work when an image is
+loaded directly. Whenever a directory listing is requested, Apache might
+respond with the classic (and ugly) directory listing performed by
+mod_autoindex.
+
+1.2 Apache 2
+
+In case you run apache 2 and modperl 2 (or 1.99), it needs to look like:
+
+<VirtualHost *>
+       ServerName   gallery.yourdomain.org
+       DocumentRoot /data/pictures/
+       ErrorLog     logs/gallery-error_log
+       TransferLog  logs/gallery-access_log
+       PerlSetVar   GalleryTemplateDir '/usr/share/libapache-gallery-perl/templates/default'
+       PerlSetVar   GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
+       PerlSetVar   GallerySizes '640 1024 1600 2272'
+       PerlSetVar   GalleryThumbnailSize '100x75'
+       PerlSetVar   GalleryCopyrightImage 'htdocs/c.png'
+       PerlOptions +GlobalRequest
+       <Location />
+           SetHandler          modperl
+           PerlResponseHandler Apache::Gallery
+       </Location>
+</VirtualHost>
+
+NOTICE: Although stated by the original author of Apache::Gallery, some users
+have reported it is not longer true that Apache::Gallery does not work with
+mod_autoindex. If you experience problems, with your gallery, please, follow
+this instructions:
+
+WARNING: Apache::Gallery might not work properly if mod_autoindex is loaded by
+Apache. Indeed, mod_autoindex might override Apache::Gallery and might not let
+it display directory content. 
+
+To check if your installation loads the autoindex module, you need to check
+under /etc/apache2/mods-enabled for a link to the module (actually placed under
+/etc/apache2/mods-available)
+
+If this module is activated, Apache::Gallery might only work when an image is
+loaded directly. Whenever a directory listing is requested, Apache might
+respond with the classic (and ugly) directory listing performed by
+mod_autoindex.
+
+2. Place the icons
+
+For accessing the icons, you can create an alias to the directory where they
+reside. Icons for libapache-gallery-perl *must* appear under /icons/gallery
+on your topmost apache tree:
+
+    Alias /icons/gallery/ "/usr/share/libapache-gallery-perl/icons/"
+
+This Alias defined above should appear _before_ the "Alias /icons ..." in your
+config files.
+
+Another choice is to symlink:
+
+    /usr/share/apache2/icons/gallery -> /usr/share/libapache-gallery-perl/icons
+
+From your Apache icons directory. The example above is for Apache2.
+
+As a less recommended alternative, you can create a directory called gallery in
+your Apache icons directory and copy the png files in htdocs to this directory.
+
+3. Edit the template directory
+
+Edit the GalleryTemplateDir variable to point to the templates you want
+Apache::Gallery to use. This Debian package distributes 2 templates, called
+"default" and "new".
+
+4. Place the CSS file
+
+The gallery.css file from the template directory you choose must be 
+copied to the DocumentRoot of your gallery.
+
+That's IT!
+
+
+It is possible to include a graphical copyright notice on each picture now.
+By setting the GalleryCopyrightImage PerlSetVar you can define the path
+to a picture that you want include in the bottom right of each picture.
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Mon, 09 Apr 2004 22:31:39 +0000
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..7c3fff4
--- /dev/null
@@ -0,0 +1,120 @@
+libapache-gallery-perl (0.99-svn060811-1) unstable; urgency=low
+
+  * New svn pull release, pre 1.0.
+  * Upstream changes:
+    - Added the right gallery.css
+    - Fix xhtml validation errors.
+    - Cleaned colorcodes up at bit
+    - Initial import of new template; bright.
+    - Added missing semicolon for html validation.
+    - Cache bugfix.
+  * Added a cronjob to clean the cache (Closes: #337200)
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Fri, 11 Aug 2006 00:09:30 +0300
+
+libapache-gallery-perl (0.99-svn050921-1) unstable; urgency=low
+
+  * New svn pull release, pre 1.0.
+  * Show only sizes specified in the config file (Closes: #290900).
+  * Add copyright image also in the case the picture does not need to scaled
+    (Closes: #324524).
+  * libapache-gallery-perl should work with libapache2-mod-perl2 even if
+    libapache-mod-perl is installed (Closes: #316172).
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Tue, 20 Sep 2005 20:51:11 +0000
+
+libapache-gallery-perl (0.99-svn050708-1) unstable; urgency=low
+
+  * New svn pull release: "Debconf5 is over, so now i can work in my packages"
+    and "QA Meeting in FRA".
+  * Updated documentation.
+  * Update dependency on the new libapache2-mod-perl2.
+  * Bumped Standards, no changes needed.
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Fri,  9 Sep 2005 15:44:10 +0000
+
+libapache-gallery-perl (0.99-svn050524-1) unstable; urgency=low
+
+  * The "Pissing Manoj has its consecuences" release.
+  * Updated subversion checkout due to new API version uploaded to sid
+    (Closes: #310486).
+    This version is in fact 1.0rc1, but it requires a new version of
+    perl-modules containing a new CGI.pm release (we need 3.08 and 3.04 is the
+    one we distribute right now).
+  * Remove spurious dependency on the (otherwise outdated) libcgi-perl
+    (Closes: #310632). Kudos to Manoj for noticing.
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Tue, 24 May 2005 11:44:30 +0000
+
+libapache-gallery-perl (0.9.1-3) unstable; urgency=low
+
+  * Brown Paper Bag release.
+  * Changed back the /gallery-icons/ to /icons/gallery/ (Closes: #292604)
+    This was one of the old changes that I wanted not to introduce, but I
+    forgot I made when my hard disk drive crashed. The only working copy had
+    that change...
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Fri, 28 Jan 2005 09:11:46 +0000
+
+libapache-gallery-perl (0.9.1-2) unstable; urgency=low
+
+  * New README.Debian file with reorganized intructions. Hopefully they will
+    make it easier for the end user to get it working (Closes: #254396).
+    Also, modified the requirement for removing autoindex_module, and state
+    that might not be true (Closes: #290159)
+  * Modified Gallery.pm to include the new libapache2-mod-perl2
+    (Closes: #290678)
+  * Applied patch from Don Armstrong to get ppm, gif and tiff files displayed
+    from the cache proper (Closes: #287833)
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Sun, 16 Jan 2005 14:33:10 +0000
+
+libapache-gallery-perl (0.9.1-1) unstable; urgency=low
+
+  * New upstream release (Closes: #271223)
+  * Erased some dependencies for the build process, since we can provide the
+    dependencies during installation time. I have built it, tested it, and it
+    Works For Me (TM) (Closes: #271222).
+  * A rework for #254396 was ready when my hdd crashed. Next release, maybe...
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Sun, 12 Sep 2004 08:14:57 +0000
+
+libapache-gallery-perl (0.8-3) unstable; urgency=low
+
+  * The "Do not press gqgg while editing under vi unless you really know what
+    you are doing" release.
+  * Formated README.Debian for readability (Closes: #246465). Kudos to
+    Adeodato Simó.
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Thu, 29 Apr 2004 08:54:55 +0000
+
+libapache-gallery-perl (0.8-2) unstable; urgency=low
+
+  * debian/README: some more bits of information about the procedure to set a
+    gallery (Closes: #240635, #245725, #245728).
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Sun, 25 Apr 2004 07:30:35 +0000
+
+libapache-gallery-perl (0.8-1) unstable; urgency=low
+
+  * New upstream release
+  * Changed the dependency from libapache-mod-perl and apache-perl to
+    libapache-request-perl, which hopefully will pull the needed dependencies.
+    If only dpkg and apt-get would support conditional dependencies...
+    (Closes: #235055)
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Wed, 10 Mar 2004 19:44:10 +0000
+
+libapache-gallery-perl (0.7r237-2) unstable; urgency=low
+
+  * debian/control
+    - Ups! I missed apache-mod-perl is not a package (Closes: #234456)
+    - Standards: bumped to 3.6.1.0
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Tue, 24 Feb 2004 06:51:06 +0000
+
+libapache-gallery-perl (0.7r237-1) unstable; urgency=low
+
+  * First uploaded release (Closes: #230614)
+
+ -- Jesus Climent <jesus.climent@hispalinux.es>  Mon, 22 Dec 2003 22:31:39 +0000
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..c0d5183
--- /dev/null
@@ -0,0 +1,20 @@
+Source: libapache-gallery-perl
+Maintainer: Jesus Climent <jesus.climent@hispalinux.es>
+Priority: optional
+Section: perl
+Build-Depends-Indep: perl (>= 5.6.0-17), libmodule-build-perl
+Build-Depends: debhelper (>= 3.0.5)
+Standards-Version: 3.7.2
+
+Package: libapache-gallery-perl
+Architecture: all
+Priority: optional
+Depends: ${perl:Depends}, libapache-request-perl | libapache2-mod-perl2 (>= 2.0), libimage-size-perl, libimage-info-perl, libtemplate-perl, libimage-imlib2-perl, libtext-template-perl
+Description: Apache module to create galleries on-the-fly
+ This package contains a Perl module for Apache to create galleries.
+ .
+ The images just need to be copied into a directory where Apache will pick
+ them up and create a gallery page for you, with thumbnails and links to the
+ full size images.
+ .
+ Thumbnail size and maximum image size can be defined, among others.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..3542f69
--- /dev/null
@@ -0,0 +1,19 @@
+This is Debian GNU/Linux's prepackaged version of Apache::Gallery, a Perl
+module for Apache that allows you to have galleries created on-the-fly.
+
+Jesus Climent <jesus.climent@hispalinux.es> built this package. The original
+sources were downloaded from <URL:http://apachegallery.dk/>.
+
+Snapshots are available from <URL:http://svn.apachegallery.dk/snapshots/>.
+
+The only change for the Debian package was the addition of the debian/
+files.
+
+The Apache::Gallery copyright is as follows:
+
+Copyright (C) 2001-2003 Michael Legart <michael@legart.dk>
+
+Apache::Gallery is free software and is released under the Artistic License.
+
+In a Debian system, you can find the Perl License at:
+/usr/share/common-licenses/Artistic
diff --git a/debian/cron.daily b/debian/cron.daily
new file mode 100644 (file)
index 0000000..f196666
--- /dev/null
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# libapache-gallery-perl cleanup
+# Remove all files in $cachedir that have not been accessed in a week,
+# then remove empty directories.  Run as user $user.
+
+set -e
+
+cachedir=/var/tmp/Apache-Gallery
+user=www-data
+
+if [ -d $cachedir ]; then
+    # remove old files
+    start-stop-daemon --start --pidfile /dev/null --startas /bin/sh \
+       --oknodo --chuid $user -- -c \
+       "find $cachedir -type f -atime +6 -print0 | xargs -r0 rm -f"
+    # remove empty directories
+    start-stop-daemon --start --pidfile /dev/null --startas /bin/sh \
+       --oknodo --chuid $user -- -c \
+       "find $cachedir -depth -type d -print0 | \
+        xargs -r0 rmdir --ignore-fail-on-non-empty"
+fi
+
+exit 0
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..864117b
--- /dev/null
@@ -0,0 +1,2 @@
+usr/share/libapache-gallery-perl/templates
+usr/share/libapache-gallery-perl/icons
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..9a5efd0
--- /dev/null
@@ -0,0 +1,76 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE=1
+
+export DH_COMPAT := 4
+
+PERL ?= /usr/bin/perl
+
+b := $(shell pwd)/debian/libapache-gallery-perl
+
+arrange: arrange-stamp
+arrange-stamp: install
+       dh_testdir
+       touch arrange-stamp
+
+binary: binary-stamp
+binary-stamp: binary-indep binary-arch
+       dh_testdir
+       touch binary-stamp
+
+binary-arch: binary-arch-stamp
+binary-arch-stamp: arrange
+       dh_testdir
+       touch binary-arch-stamp
+
+binary-indep: binary-indep-stamp
+binary-indep-stamp: arrange
+       dh_testdir
+       dh_testroot
+       dh_installman
+       dh_installdocs README
+       dh_installchangelogs Changes
+       dh_installcron
+       dh_fixperms
+       dh_installdeb
+       dh_perl
+       dh_compress
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+       touch binary-indep-stamp
+
+build: build-stamp
+build-stamp: config
+       dh_testdir
+       $(MAKE)
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       -$(MAKE) clean
+       if [ -e Makefile ]; then $(MAKE) -i distclean; fi
+       dh_clean arrange-stamp binary-stamp binary-arch-stamp binary-indep-stamp build-stamp config-stamp install-stamp
+       rm -rf debian/libapache-gallery-perl
+       rm -rf Makefile.old
+
+config: config-stamp
+config-stamp:
+       dh_testdir
+       $(PERL) Makefile.PL INSTALLDIRS=vendor
+       touch config-stamp
+
+install: install-stamp
+install-stamp: build
+       dh_testdir
+       dh_clean -k
+       dh_installdirs
+       
+       $(MAKE)
+       $(MAKE) install PREFIX=$(CURDIR)/debian/libapache-gallery-perl/usr
+       cp -r $(CURDIR)/templates/* $(CURDIR)/debian/libapache-gallery-perl/usr/share/libapache-gallery-perl/templates
+       cp -r $(CURDIR)/htdocs/* $(CURDIR)/debian/libapache-gallery-perl/usr/share/libapache-gallery-perl/icons
+       touch install-stamp
+
+.PHONY: binary binary-arch binary-indep clean