]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Update upstream source from tag 'upstream/1.7'
authorDon Armstrong <don@donarmstrong.com>
Mon, 31 Dec 2018 05:58:25 +0000 (21:58 -0800)
committerDon Armstrong <don@donarmstrong.com>
Mon, 31 Dec 2018 05:58:25 +0000 (21:58 -0800)
Update to upstream version '1.7'
with Debian dir 26b05b3880352ba901b3c2a7fbc2910e5b648550

README.md
autorandr.py
contrib/packaging/autorandr.spec
setup.py

index 27cb2893e8a7e7e51f0642a13da9aaa69535b5f0..71b3aebe2923d4c8ac2a882d86e76ae3cd8b6c59 100644 (file)
--- a/README.md
+++ b/README.md
@@ -56,6 +56,7 @@ Contributors to this version of autorandr are:
 * Timo Kaufmann
 * Tomasz Bogdal
 * Victor Häggqvist
+* Jan-Oliver Kaiser
 
 ## Installation/removal
 
@@ -210,6 +211,10 @@ profiles matching multiple (or any) monitors.
 
 ## Changelog
 
+**autorandr 1.7**
+
+* *2018-09-25* Fix FB size computation with rotated screens (by @Janno, #117)
+
 **autorandr 1.6**
 
 * *2018-04-19* Bugfix: Do not load default profile unless --change is set
@@ -217,7 +222,7 @@ profiles matching multiple (or any) monitors.
 * *2018-06-29* Fix detection of current configuration if extra monitors are active
 * *2018-07-11* Bugfix in the latest change: Correctly handle "off" minitors when comparing
 * *2018-07-19* Do not kill spawned user processes from systemd unit
-* *2018-07-20* Correctly handle "off" minitors when comparing -- fixup for another bug.
+* *2018-07-20* Correctly handle "off" monitors when comparing -- fixup for another bug.
 
 **autorandr 1.5**
 
index 4187932632c1bb008c3d88cad62a31f1f1912611..d36b568485aca6e87a3b61e83ada3be63fe866b6 100755 (executable)
@@ -48,7 +48,7 @@ if sys.version_info.major == 2:
 else:
     import configparser
 
-__version__ = "1.6"
+__version__ = "1.7"
 
 try:
     input = raw_input
@@ -645,6 +645,9 @@ def get_fb_dimensions(configuration):
             x = (a * o_width + b * o_height + c) / w
             y = (d * o_width + e * o_height + f) / w
             o_width, o_height = x, y
+        if "rotate" in output.options:
+            if output.options["rotate"] in ("left", "right"):
+                o_width, o_height = o_height, o_width
         if "pos" in output.options:
             o_left, o_top = map(int, output.options["pos"].split("x"))
             o_width += o_left
index c2b668192bbd81d5e1ae78abbc8ed1ab80f17fe5..ffbb4e7f738dbe127bcca6423fe63d45a8b03b6e 100644 (file)
@@ -7,8 +7,8 @@
 %endif
 
 Name:           autorandr
-Version:        1.1
-Release:        2%{?dist}
+Version:        1.5
+Release:        1%{?dist}
 Summary:        Automatically select a display configuration based on connected devices
 
 License:        GPL
@@ -16,10 +16,12 @@ URL:            https://github.com/phillipberndt/autorandr
 Source0:        https://github.com/phillipberndt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
 
 BuildArch:     noarch
-Requires:       systemd
+Requires:       python2
 %if 0%{?use_pm_utils}
 Requires:      pm-utils
 %endif
+%{?systemd_ordering}
+BuildRequires: systemd
 
 %description
 
@@ -36,12 +38,13 @@ install -D -m 644 contrib/bash_completion/autorandr %{buildroot}%{_datarootdir}/
 install -d -m 755 %{buildroot}%{_datarootdir}/bash-completion/completions
 ln -s ../../autorandr/completions/autorandr %{buildroot}%{_datarootdir}/bash-completion/completions/autorandr
 install -D -m 755 contrib/pm-utils/40autorandr %{buildroot}%{_sysconfdir}/pm/sleep.d/40autorandr
-install -D -m 644 contrib/systemd/autorandr.service %{buildroot}%{_sysconfdir}/systemd/system/autorandr.service
+install -D -m 644 contrib/systemd/autorandr.service %{buildroot}%{_unitdir}/autorandr.service
 #install -D -m 644 contrib/udev/40-monitor-hotplug.rules %{buildroot}%{_sysconfdir}/udev/rules.d/40-monitor-hotplug.rules
 install -D -m 644 contrib/etc/xdg/autostart/autorandr.desktop %{buildroot}%{_sysconfdir}/etc/xdg/autostart/autorandr.desktop
 
 %files
 %defattr(-,root,root,-)
+%attr(0644,root,root) %{_unitdir}/autorandr.service
 
 %license gpl-3.0.txt 
 %doc README.md
@@ -55,6 +58,9 @@ install -D -m 644 contrib/etc/xdg/autostart/autorandr.desktop %{buildroot}%{_sys
 
 
 %changelog
+* Thu Jul 19 2018 Maciej Sitarz <macieksitarz@wp.pl> - 1.5-1
+- Updated to stable 1.5
+- Changed dest path for systemd service file
 * Sun Oct 01 2017 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 1.1-2
 - Added conditionals for pm-utils, compability with Fedora26+
 - Removed bash-completion from requisites
index 4309c15fe3e3e4b306612b0bbaa204c037d097df..02b347aa7a7f01e3d60f1a10061d7901f68551b7 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ except:
 setup(
     name='autorandr',
 
-    version='1.6-1',
+    version='1.7-1',
 
     description='Automatically select a display configuration based on connected devices',
     long_description=long_description,