]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Merge pull request #290 from mikelward/makedeb
authorPhillip Berndt <phillip.berndt@googlemail.com>
Sat, 4 Jun 2022 11:50:38 +0000 (13:50 +0200)
committerGitHub <noreply@github.com>
Sat, 4 Jun 2022 11:50:38 +0000 (13:50 +0200)
Fix 'make deb' build target to build a .deb package

contrib/packaging/debian/debian/control
contrib/packaging/debian/make_deb.sh

index 7fb2be8666eb60bed46434ee31170c4c5fcceeff..f5d6b516aef5a290e04dcdb7b215af3220aec498 100644 (file)
@@ -7,7 +7,7 @@ Build-Depends: debhelper (>=9)
 Standards-Version: 3.9.6
 Homepage: https://github.com/phillipberndt/autorandr
 Architecture: all
-Depends: x11-xserver-utils, python
+Depends: x11-xserver-utils, python3
 Description: Automatically select a display configuration for connected devices
  Autorandr is a script for managing xrandr configurations based on the
  connected devices. It can be set up to automatically switch to a stored
index fe8fe375f18b2ca8ee206cb5a527a45bf9636992..32d1b7b1f94a5056f0064520fe0afe7b80774443 100755 (executable)
@@ -45,7 +45,7 @@ SIZE=$(du -s $D | awk '{print $1}')
 
 cp -r "$P/debian" "$D/DEBIAN"
 chmod 0755 "$D/DEBIAN"
-[ -d "$D/etc" ] && (cd $D; find etc -type f) > "$D/DEBIAN/conffiles"
+[ -d "$D/etc" ] && (cd $D; find etc -type f -printf '/%p\n') > "$D/DEBIAN/conffiles"
 sed -i -re "s#Version:.+#Version: $V#" "$D/DEBIAN/control"
 echo "Installed-Size: $SIZE" >> "$D/DEBIAN/control"
 fakeroot dpkg-deb -b "$D" "$O"