]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Merge branch 'feature/preswitch_scripts' of http://github.com/torrancew/autorandr
authorPhillip Berndt <phillip.berndt@googlemail.com>
Thu, 30 Jan 2014 12:41:30 +0000 (13:41 +0100)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Thu, 30 Jan 2014 12:41:30 +0000 (13:41 +0100)
Makefile [new file with mode: 0644]
README [deleted file]
README.md [new file with mode: 0644]
autorandr
bash_completion/autorandr
contrib/autorandr_monitor/Xsession.d/autorandr [new file with mode: 0644]
contrib/autorandr_monitor/autorandr_monitor [new file with mode: 0755]
pm-utils/40auto-disper [new symlink]
pm-utils/40autorandr
udev/40-monitor-hotplug.rules [new file with mode: 0644]

diff --git a/Makefile b/Makefile
new file mode 100644 (file)
index 0000000..f1d2725
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,19 @@
+all:
+       @echo "Call \"make install\" to install this program."
+       @echo "Call \"make hotplug\" to install matching hotplug events."
+
+INSTALL_PATH=/usr/local/bin
+install:
+       install -D auto-disper ${DESTDIR}${INSTALL_PATH}/auto-disper
+       install -D -m 755 autorandr ${DESTDIR}${INSTALL_PATH}/autorandr
+       install -D -m 644 bash_completion/autorandr ${DESTDIR}/etc/bash_completion.d/autorandr
+
+hotplug:
+       install -D -m 755 pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
+       install -D -m 644 udev/40-monitor-hotplug.rules ${DESTDIR}/etc/udev/rules.d/40-monitor-hotplug.rules
+ifeq (${USER},root)
+       udevadm control --reload-rules
+else
+       @echo "Please run this command as root:"
+       @echo "    udevadm control --reload-rules"
+endif
diff --git a/README b/README
deleted file mode 100644 (file)
index 9b54600..0000000
--- a/README
+++ /dev/null
@@ -1,46 +0,0 @@
-Tool: "autorandr"
-
-Automatically select a display configuration based on connected devices
-
-Stefan Tomanek <stefan.tomanek@wertarbyte.de>
-
-How to use:
-
-Save your current display configuration and setup with:
- $ autorandr --save mobile
-
-Connect an additional display, configure your setup and save it:
- $ autorandr --save docked
-
-Now autorandr can detect which hardware setup is active:
- $ autorandr
-   mobile
-   docked (detected)
-
-To automatically reload your setup, just append --change to the command line
-
-To manually load a profile, you can use the --load <profile> option.
-
-autorandr tries to avoid reloading an identical configuration. To force the
-(re)configuration, apply --force.
-
-To prevent a profile from being loaded, place a script call "block" in its
-directory. The script is evaluated before the screen setup is inspected, and
-in case of it returning a value of 0 the profile is skipped. This can be used
-to query the status of a docking station you are about to leave.
-
-If no suitable profile can be identified, the current configuration is kept.
-To change this behaviour and switch to a fallback configuration, specify
---default <profile>
-
-Another script called "postswitch "can be placed in the directory
-~/.autorandr as well as in all profile directories: The scripts are executed
-after a mode switch has taken place and can notify window managers or other
-applications about it.
-
-
-While the script uses xrandr by default, calling it by the name "autodisper"
-or "auto-disper" forces it to use the "disper" utility, which is useful for
-controlling nvidia chipsets. The formats for fingerprinting the current setup
-and saving/loading the current configuration are adjusted accordingly.
-
diff --git a/README.md b/README.md
new file mode 100644 (file)
index 0000000..619a992
--- /dev/null
+++ b/README.md
@@ -0,0 +1,73 @@
+# autorandr
+
+Automatically select a display configuration based on connected devices
+
+Stefan Tomanek <[stefan.tomanek@wertarbyte.de](stefan.tomanek@wertarbyte.de)>
+
+## Branch information
+
+The original wertarbyte/autorandr tree seems unmaintained, with lots of open
+pull requests and issues. I forked it and merged what I thought were the most
+important changes. I will maintain this branch until wertarbyte finds the time
+to maintain his branch again.
+
+
+## How to use
+
+Save your current display configuration and setup with:
+```
+autorandr --save mobile
+```
+
+Connect an additional display, configure your setup and save it:
+```
+autorandr --save docked
+```
+
+Now autorandr can detect which hardware setup is active:
+```
+ $ autorandr
+   mobile
+   docked (detected)
+```
+
+To automatically reload your setup, just append `--change` to the command line
+
+To manually load a profile, you can use the `--load <profile>` option.
+
+autorandr tries to avoid reloading an identical configuration. To force the
+(re)configuration, apply `--force`.
+
+To prevent a profile from being loaded, place a script call _block_ in its
+directory. The script is evaluated before the screen setup is inspected, and
+in case of it returning a value of 0 the profile is skipped. This can be used
+to query the status of a docking station you are about to leave.
+
+If no suitable profile can be identified, the current configuration is kept.
+To change this behaviour and switch to a fallback configuration, specify
+`--default <profile>`.
+
+Another script called `postswitch` can be placed in the directory
+`~/.autorandr` as well as in all profile directories: The scripts are executed
+after a mode switch has taken place and can notify window managers or other
+applications about it.
+
+While the script uses xrandr by default, calling it by the name `autodisper`
+or `auto-disper` forces it to use the [disper](http://willem.engen.nl/projects/disper/)
+utility, which is useful for controlling nvidia chipsets. The formats for
+fingerprinting the current setup and saving/loading the current configuration
+are adjusted accordingly.
+
+To install autorandr call `make install`, define your setup and then call
+`make hotplug` to install hotplug scripts.
+
+For Debian using auto-disper:
+To make the screen auto-configure when your computer wakes up,
+* Copy auto-disper into /usr/local/bin/
+* Copy pm-utils/40auto-disper into /etc/pm/sleep.d/
+* (Assuming gnome) Run gnome-keybinding-properties and ADD a shortcut,
+  I called it "Run auto-disper", I set it to CTRL-F7, and the command is:
+  `auto-disper -c --default default`
+* Create a default disper setting... eg for laptop: unplug all monitors,
+  set up the screen nicely on the laptop display.
+  Then run `auto-disper --save laptop`
index e77aeb74b23f58b2ca0c1c707fd01ba64ce7b22d..fbf17a14699bb96989ebc3587db2c7477779b1a7 100755 (executable)
--- a/autorandr
+++ b/autorandr
@@ -55,7 +55,7 @@ FORCE_LOAD=0
 DEFAULT_PROFILE=""
 SAVE_PROFILE=""
 
-FP_METHODS="setup_fp_xrandr_edid setup_fp_sysfs_edid"
+FP_METHODS="setup_fp_sysfs_edid setup_fp_xrandr_edid"
 CURRENT_CFG_METHOD="current_cfg_xrandr"
 LOAD_METHOD="load_cfg_xrandr"
 
@@ -121,15 +121,22 @@ current_cfg_xrandr() {
        $XRANDR -q | awk -v primary_setup="${PRIMARY_SETUP}" '
        # display is connected and has a mode
        /^[^ ]+ connected [^(]/ {
-               split($3, A, "+");
                print "output "$1;
+               if ($3 == "primary") {
+                       print $3
+                       split($4, A, "+")
+                       $4=$5
+               }
+               else {
+                       split($3, A, "+");
+                       if (A[1] A[2] "," A[3] == primary_setup)
+                               print "primary";
+               }
                print "mode "A[1];
                print "pos "A[2]"x"A[3];
                if ($4 !~ /^\(/) {
                        print "rotate "$4;
                }
-               if (A[1] A[2] "," A[3] == primary_setup)
-                       print "primary";
                next;
        }
        # disconnected or disabled displays
@@ -167,7 +174,28 @@ config_equal() {
 }
 
 load_cfg_xrandr() {
-       sed 's!^!--!' "$1" | xargs $XRANDR
+       # sed 1: Prefix arguments with "--"
+       # sed 2: Merge arguments into one line per output
+       # sed 3: Merge into two lines, all --off outputs in the first one
+       sed 's/^/--/' "$1" | sed -e '
+               :START
+               /\n--output/{P;D}
+               s/\n/ /
+               N;bSTART' | sed -e '
+                       ### First line
+                       / --off/{
+                               G
+                               # Merge if next line contains --off
+                               s/\n\([^\n]* --off\)/ \1/
+                               h
+                               $!d;b
+                       }
+                       ### Last line
+                       H;x
+                       # Merge if previous line contains --mode
+                       s/\(--mode [^\n]*\)\n/\1 /
+                       h
+                       $!d' | xargs -L 1 $XRANDR
 }
 
 load_cfg_disper() {
index b00999452fdb4d4cb1b73ebc1ece66793858cccd..151c59698807c5b7de8d2a7ebc43b5677d88ecb0 100644 (file)
@@ -10,7 +10,11 @@ _autorandr ()
 
        opts="-h -c -s -l -d"
        lopts="--help --change --save --load --default --force --fingerprint"
-       prfls="`find ~/.autorandr/* -maxdepth 1 -type d -printf '%f\n'`"
+       if [ -d ~/.autorandr ]; then
+               prfls="`find ~/.autorandr/* -maxdepth 1 -type d -printf '%f\n'`"
+       else
+               prfls=""
+       fi
 
        case "${cur}" in
                --*)
diff --git a/contrib/autorandr_monitor/Xsession.d/autorandr b/contrib/autorandr_monitor/Xsession.d/autorandr
new file mode 100644 (file)
index 0000000..d0b568a
--- /dev/null
@@ -0,0 +1,3 @@
+# -*- sh -*-
+
+/usr/bin/autorandr_monitor &> /tmp/autorandr_monitor &
diff --git a/contrib/autorandr_monitor/autorandr_monitor b/contrib/autorandr_monitor/autorandr_monitor
new file mode 100755 (executable)
index 0000000..6f369bb
--- /dev/null
@@ -0,0 +1,53 @@
+#!/usr/bin/env python
+""""
+Author:  Tomasz Bogdal (a.k.a. QueezyTheGreat)
+Home:    https://github.com/queezythegreat/autorandr
+License: This Source Code Form is subject to the terms of the
+         Mozilla Public License, v. 2.0
+"""
+import os
+import pyinotify
+from pyinotify import ProcessEvent
+
+#TODO: Fork off when started
+#TODO: Add configuration file
+#TODO: Add command line options
+
+SYS_VIDEO_OUTPUTS='/sys/class/drm/'
+DEFAULT_PROFILE='default'
+AUTORANDR_CMD='autorandr --change --default %s' % DEFAULT_PROFILE
+
+class VideoOutputMonitor(ProcessEvent):
+    """ Launch autorandr when video card output status is changed. """
+
+    def process_IN_ACCESS(self, event):
+        """ Handle IN_ACCESS events to `status` file. """
+        if event.name == 'status':
+            print 'Change status of %s' % os.path.basename(event.path)
+            os.system(AUTORANDR_CMD)
+
+
+def register_video_cards(manager):
+    """ Register all video card ouptus for monitoring. """
+    if not os.path.exists(SYS_VIDEO_OUTPUTS):
+        return
+
+    for directory in os.listdir(SYS_VIDEO_OUTPUTS):
+        path = os.path.join(SYS_VIDEO_OUTPUTS, directory)
+        status = os.path.join(path, 'status')
+        if os.path.exists(status):
+            print 'Monitoring %s' % path
+            manager.add_watch(path, pyinotify.ALL_EVENTS)
+
+def main():
+    # pyinotify.log.setLevel(10)
+    manager = pyinotify.WatchManager()
+    handler = VideoOutputMonitor()
+    notifier = pyinotify.Notifier(manager, default_proc_fun=handler)
+
+    register_video_cards(manager)
+
+    notifier.loop()
+
+if __name__ == '__main__':
+    main()
diff --git a/pm-utils/40auto-disper b/pm-utils/40auto-disper
new file mode 120000 (symlink)
index 0000000..9d7b227
--- /dev/null
@@ -0,0 +1 @@
+40autorandr
\ No newline at end of file
index 60ca9ae8f374b3d4d9a1ab144863428758f546fb..74549fc49a7f4e64f7f932398b5c95e965ea7b18 100755 (executable)
@@ -1,15 +1,26 @@
 #!/bin/sh
 #
 # 40autorandr: Change autorandr profile on thaw/resume
+exec > /var/log/autorandr.log 2>&1
 
-AUTORANDR="autorandr -c"
+# detect if we are being called as 40auto-disper or 40autorandr
+FORM=${0##*40}
+case $FORM in
+       auto-disper)
+               AUTORANDR="auto-disper -c --default default"
+               ;;
+       *)
+               AUTORANDR="autorandr -c --default default"
+               ;;
+esac
 
 detect_display()
 {
        for X in /tmp/.X11-unix/X*; do
                D="${X##/tmp/.X11-unix/X}"
-               user=$(who | awk -vD="$D" '$5 ~ "\\(:"D"\\)$" {print $1}')
+               user=$(w -h | awk -vD="$D" '$3 ~ ":"D"(\\.[0-9])?$" {print $1}' | head -1)
                if [ x"$user" != x"" ]; then
+                       logger "autorandr: Changing display configuration for user '$user'"
                        export DISPLAY=":$D"
                        /bin/su -c "${AUTORANDR}" "$user"
                fi
diff --git a/udev/40-monitor-hotplug.rules b/udev/40-monitor-hotplug.rules
new file mode 100644 (file)
index 0000000..4c48ffb
--- /dev/null
@@ -0,0 +1 @@
+ACTION=="change", SUBSYSTEM=="drm", RUN+="/etc/pm/sleep.d/40autorandr thaw"