]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Call systemctl with `--no-block` from udev rule (Fixes #61)
authorPhillip Berndt <phillip.berndt@googlemail.com>
Wed, 7 Jun 2017 08:31:01 +0000 (10:31 +0200)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Wed, 7 Jun 2017 08:31:18 +0000 (10:31 +0200)
Makefile
README.md

index 7125730d3bfe285ce6d70760e4d0bc3928ec8bea..1af39a34cd43ba8672b2309b29b0139d650921a4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -111,7 +111,7 @@ endif
 install_udev:
        $(if $(UDEV_RULES_DIR),,$(error UDEV_RULES_DIR is not defined))
        mkdir -p ${DESTDIR}/${UDEV_RULES_DIR}/
-       echo 'ACTION=="change", SUBSYSTEM=="drm", RUN+="$(if $(findstring systemd, $(TARGETS)),/bin/systemctl start autorandr.service,${PREFIX}/bin/autorandr --batch --change --default default)"' > ${DESTDIR}/${UDEV_RULES_DIR}/40-monitor-hotplug.rules
+       echo 'ACTION=="change", SUBSYSTEM=="drm", RUN+="$(if $(findstring systemd, $(TARGETS)),/bin/systemctl start --no-block autorandr.service,${PREFIX}/bin/autorandr --batch --change --default default)"' > ${DESTDIR}/${UDEV_RULES_DIR}/40-monitor-hotplug.rules
        @echo
        @echo "To activate the udev rules, run this command as root:"
        @echo "    udevadm control --reload-rules"
index 728def60e006a49a5e9dd5640dd4c996b6670beb..2c08d50057d0a94189c4cfc2d2c5d7c8fd5124f5 100644 (file)
--- a/README.md
+++ b/README.md
@@ -135,6 +135,7 @@ The most useful one is `$AUTORANDR_CURRENT_PROFILE`.
 
 ## Changelog
 
+* *2017-06-07* Call systemctl with `--no-block` from udev rule (See #61)
 * *2017-01-20* New script hook, `predetect`
 * *2017-01-18* Accept comments (lines starting with `#`) in config/setup files