]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Undo making the launcher the default
authorPhillip Berndt <phillip.berndt@googlemail.com>
Mon, 4 May 2020 07:19:53 +0000 (09:19 +0200)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Mon, 4 May 2020 07:19:53 +0000 (09:19 +0200)
See #195

Makefile

index 55596e2387a4dc8babb034d8c9192f49b3a328d7..2ce8f7df081c222d8e84541f0c501b89ed3ec692 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,9 +24,11 @@ all:
        @echo
        @echo 'E.g. "make install TARGETS='autorandr pmutils' PM_UTILS_DIR=/etc/pm/sleep.d".'
        @echo
-       @echo "By default, if xcb libraries are available, autorandr prefers to"
-       @echo "install a launcher that listens for X11 randr events and runs"
-       @echo "autorandr whenever something changes, over udev/systemd rules."
+       @echo "An additional TARGETS variable \"launcher\" is available. This"
+       @echo "installs a launcher called \"autorandr_launcher\". The launcher"
+       @echo "is able to be run by the user and calls autorandr automatically"
+       @echo "without using udev rules. The launcher is an alternative to the"
+       @echo "udev/systemd setup that is more stable for some users."
        @echo
        @echo "The following additional targets are available:"
        @echo
@@ -141,11 +143,6 @@ uninstall_manpage:
 
 # Rules for launcher
 LAUNCHER_FLAGS=$(shell pkg-config --libs --cflags pkg-config xcb xcb-randr 2>/dev/null)
-ifneq (,$(LAUNCHER_FLAGS))
-DEFAULT_TARGETS+=launcher
-DEFAULT_TARGETS:=$(filter-out systemd udev,$(DEFAULT_TARGETS))
-endif
-
 install_launcher:
        gcc -Wall $(CFLAGS) contrib/autorandr_launcher/autorandr_launcher.c -o contrib/autorandr_launcher/autorandr-launcher $(LAUNCHER_FLAGS)
        install -D -m 755 contrib/autorandr_launcher/autorandr-launcher ${DESTDIR}${PREFIX}/bin/autorandr-launcher