]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Output all non-error output to stdout instead of stderr
authorPhillip Berndt <phillip.berndt@googlemail.com>
Wed, 7 Mar 2018 06:42:23 +0000 (07:42 +0100)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Wed, 7 Mar 2018 06:42:23 +0000 (07:42 +0100)
Fixes #98. This breaks compatibility with older versions of autorandr in
case users relied on which stream to use for parsing its output.

README.md
autorandr.py
setup.py

index ee935177390b5fb84b7b66054bf62d08a78348d5..94aadb14b6ab1eaceea3278a8577664d017727af 100644 (file)
--- a/README.md
+++ b/README.md
@@ -197,6 +197,7 @@ running `xrandr`.
 ## Changelog
 
 * *2018-01-04* Fixed vertical/horizontal/clone-largest virtual profiles
+* *2018-03-07* Output all non-error messages to stdout instead of stderr
 
 **autorandr 1.4**
 
index 237aa83edc9035423b760bfa7382590f82bc64df..95867a34f051d4ddaa47cfaffde6ab298696a202 100755 (executable)
@@ -817,18 +817,18 @@ def print_profile_differences(one, another):
     "Print the differences between two profiles for debugging"
     if one == another:
         return
-    print("| Differences between the two profiles:", file=sys.stderr)
+    print("| Differences between the two profiles:")
     for output in set(chain.from_iterable((one.keys(), another.keys()))):
         if output not in one:
             if "off" not in another[output].options:
-                print("| Output `%s' is missing from the active configuration" % output, file=sys.stderr)
+                print("| Output `%s' is missing from the active configuration" % output)
         elif output not in another:
             if "off" not in one[output].options:
-                print("| Output `%s' is missing from the new configuration" % output, file=sys.stderr)
+                print("| Output `%s' is missing from the new configuration" % output)
         else:
             for line in one[output].verbose_diff(another[output]):
-                print("| [Output %s] %s" % (output, line), file=sys.stderr)
-    print("\\-", file=sys.stderr)
+                print("| [Output %s] %s" % (output, line))
+    print("\\-")
 
 
 def exit_help():
@@ -1165,7 +1165,7 @@ def main(argv):
 
         for profile_name in profiles.keys():
             if profile_blocked(os.path.join(profile_path, profile_name), block_script_metadata):
-                print("%s (blocked)" % profile_name, file=sys.stderr)
+                print("%s (blocked)" % profile_name)
                 continue
             props = []
             if profile_name in detected_profiles:
@@ -1174,7 +1174,7 @@ def main(argv):
                     load_profile = profile_name
             if profile_name in current_profiles:
                 props.append("(current)")
-            print("%s%s%s" % (profile_name, " " if props else "", " ".join(props)), file=sys.stderr)
+            print("%s%s%s" % (profile_name, " " if props else "", " ".join(props)))
             if not configs_are_equal and "--debug" in options and profile_name in detected_profiles:
                 print_profile_differences(config, profiles[profile_name]["config"])
 
index 7282c7c45ee05bea8d5f29ddfd5623a486391538..efe9523b14957501fec50da0594447a2c6e02b1b 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -2,14 +2,14 @@ from setuptools import setup
 
 
 try:
-    long_description = open('README.md').read()
+    long_description = open('README.rst').read()
 except:
     long_description = 'Automatically select a display configuration based on connected devices'
 
 setup(
     name='autorandr',
 
-    version='1.4-1',
+    version='1.4-2',
 
     description='Automatically select a display configuration based on connected devices',
     long_description=long_description,